summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2020-11-16 23:25:56 -0500
committerMatt Turner <mattst88@gentoo.org>2020-11-16 23:27:06 -0500
commit1c27654c5672f00c41543ae15ffdab77ade2004c (patch)
treec9fdc35bde246fe560c19f75545928f8359998af /x11-libs/libdrm
parentdev-libs/libevdev: Version bump to 1.10.0 (diff)
downloadgentoo-1c27654c5672f00c41543ae15ffdab77ade2004c.tar.gz
gentoo-1c27654c5672f00c41543ae15ffdab77ade2004c.tar.bz2
gentoo-1c27654c5672f00c41543ae15ffdab77ade2004c.zip
x11-libs/libdrm: Version bump to 2.4.103
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-libs/libdrm')
-rw-r--r--x11-libs/libdrm/Manifest1
-rw-r--r--x11-libs/libdrm/libdrm-2.4.103.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/x11-libs/libdrm/Manifest b/x11-libs/libdrm/Manifest
index 44c92d1497c2..f01e85dd819b 100644
--- a/x11-libs/libdrm/Manifest
+++ b/x11-libs/libdrm/Manifest
@@ -1 +1,2 @@
DIST libdrm-2.4.102.tar.xz 408844 BLAKE2B f3a5ddb96130d175e860984412949713cd30145a3a9e453f666b650ec9b7eedb1c8e230aa7c5769331a330d833fdeba3da28b339150d81c17716a96935267178 SHA512 386afd228efd809fe32776a6ff5d9dd95d1409a6a6a89b3806a3b42ed27e84f1e090f3b7834973f834d6b0d1342b7034447fe8690d072f85f03292d7795c3e0c
+DIST libdrm-2.4.103.tar.xz 412796 BLAKE2B 64904bebb923d79b83fbe1949aa24c697cff2a258f415c4633991f938772980e985df19f44df881d10b14268ea414ff99220c8f003ad09ac1decdc6c85249240 SHA512 15b098b962008271400692b6b15ecb7e22676f8698e0220ad969735ac2315ccc737d19558afb6abda82bae15117e5f306c048184a2369f434b85ecaa670ca885
diff --git a/x11-libs/libdrm/libdrm-2.4.103.ebuild b/x11-libs/libdrm/libdrm-2.4.103.ebuild
new file mode 100644
index 000000000000..46ea35c8a426
--- /dev/null
+++ b/x11-libs/libdrm/libdrm-2.4.103.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+EGIT_REPO_URI="https://gitlab.freedesktop.org/mesa/drm.git"
+
+if [[ ${PV} = 9999* ]]; then
+ GIT_ECLASS="git-r3"
+fi
+
+inherit ${GIT_ECLASS} meson multilib-minimal
+
+DESCRIPTION="X.Org libdrm library"
+HOMEPAGE="https://dri.freedesktop.org/ https://gitlab.freedesktop.org/mesa/drm"
+if [[ ${PV} = 9999* ]]; then
+ SRC_URI=""
+else
+ SRC_URI="https://dri.freedesktop.org/libdrm/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+VIDEO_CARDS="amdgpu exynos freedreno intel nouveau omap radeon tegra vc4 vivante vmware"
+for card in ${VIDEO_CARDS}; do
+ IUSE_VIDEO_CARDS+=" video_cards_${card}"
+done
+
+IUSE="${IUSE_VIDEO_CARDS} libkms valgrind"
+RESTRICT="test" # see bug #236845
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ video_cards_intel? ( >=x11-libs/libpciaccess-0.13.1-r1:=[${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}
+ valgrind? ( dev-util/valgrind )"
+
+multilib_src_configure() {
+ local emesonargs=(
+ # Udev is only used by tests now.
+ -Dudev=false
+ -Dcairo-tests=false
+ -Damdgpu=$(usex video_cards_amdgpu true false)
+ -Dexynos=$(usex video_cards_exynos true false)
+ -Dfreedreno=$(usex video_cards_freedreno true false)
+ -Dintel=$(usex video_cards_intel true false)
+ -Dnouveau=$(usex video_cards_nouveau true false)
+ -Domap=$(usex video_cards_omap true false)
+ -Dradeon=$(usex video_cards_radeon true false)
+ -Dtegra=$(usex video_cards_tegra true false)
+ -Dvc4=$(usex video_cards_vc4 true false)
+ -Detnaviv=$(usex video_cards_vivante true false)
+ -Dvmwgfx=$(usex video_cards_vmware true false)
+ -Dlibkms=$(usex libkms true false)
+ # valgrind installs its .pc file to the pkgconfig for the primary arch
+ -Dvalgrind=$(usex valgrind auto false)
+ )
+ meson_src_configure
+}
+
+multilib_src_compile() {
+ meson_src_compile
+}
+
+multilib_src_test() {
+ meson_src_test
+}
+
+multilib_src_install() {
+ meson_src_install
+}