summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2016-03-19 15:18:49 +0100
committerManuel Rüger <mrueg@gentoo.org>2016-03-19 15:18:49 +0100
commit2109e57ebcccc802c906de63d50164c9f9952caa (patch)
treef618200bfea34951ea4b7ebeb60e38ecd7cd0a3b /x11-libs/libxkbcommon
parentdev-python/colorama: Version bump to 0.3.7 (diff)
downloadgentoo-2109e57ebcccc802c906de63d50164c9f9952caa.tar.gz
gentoo-2109e57ebcccc802c906de63d50164c9f9952caa.tar.bz2
gentoo-2109e57ebcccc802c906de63d50164c9f9952caa.zip
x11-libs/libxkbcommon: Version bump to 0.6.0
Package-Manager: portage-2.2.28
Diffstat (limited to 'x11-libs/libxkbcommon')
-rw-r--r--x11-libs/libxkbcommon/Manifest1
-rw-r--r--x11-libs/libxkbcommon/libxkbcommon-0.6.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/x11-libs/libxkbcommon/Manifest b/x11-libs/libxkbcommon/Manifest
index 51ea195b6b46..9fabee90ffa6 100644
--- a/x11-libs/libxkbcommon/Manifest
+++ b/x11-libs/libxkbcommon/Manifest
@@ -2,3 +2,4 @@ DIST libxkbcommon-0.2.0.tar.bz2 715987 SHA256 74eb0a121ca3998015fd687591426bb15c
DIST libxkbcommon-0.3.1.tar.xz 605756 SHA256 9c973581bba0c883a301fa6474d9c3e4f3a06c34e4ae4f1f4e113692cb18b38e SHA512 d5682f3663560d54bd3227ca0fdf52e651f2a14af46f49b4e7a5df2dc2e52748748f42c6334d6fd7328be72bd0c7e673e9783aa91d65a55a71266236f8b6a504 WHIRLPOOL f6472fa24c16c6f263e2ace807e4b2c7d4442d82e8d76ec047d4b9c312eaf889be26518fe3ffbd343610a5d966cf6b5df95cc47120ea60811cea4b687cc831ed
DIST libxkbcommon-0.4.1.tar.xz 551424 SHA256 90ee502ec919814533c65e74c208212854f5bae9b9b87932eeb96fb3876b8ff6 SHA512 b4e416691f0257c85421e782543518ba8f02e0a30d9b3ff4bf4fbe1eade6f661113a843f79f718af6bacadcd44052468663bad7a2d70545acf13a6c04f7a7229 WHIRLPOOL c9d58b5587a0e5b9de64f3e811178f523c72af6e980bbdf85f77628f85c6530f00977081eda5f1d2df1149e554d7d7d9692d45b49730fd155c82fcef76b5e359
DIST libxkbcommon-0.5.0.tar.xz 615504 SHA256 90bd7824742b9a6f52a6cf80e2cadd6f5349cf600a358d08260772615b89d19c SHA512 63ef6b586743a1fbee1e4a92dd9709eedfd66d4ed1f342976534a2c818b896aaab7712ea6871abb19845439cae4b17b2e624f1ae279da151ddead53f22a48c2e WHIRLPOOL b4fa342fbca2aa7ac60d2daf2269d891e83564bf016ee420c106c86513a780a279471e3eada9f18600ae9e0f5a3740423d9127ca71bc65f1b00ca5c76b61b756
+DIST libxkbcommon-0.6.0.tar.xz 608700 SHA256 69235ec3a13194dea9555d7994bc4548b3ee20070e05a135af5372a958149ef0 SHA512 b70ff4b3b85f03cc2875622ccfa60ba6f1b86a07be90df8be73b867771dd08a85740df95fe8dfef2bacf4356a6dfc9c51523ec6ce60d197184860577b39586c4 WHIRLPOOL f2f07b96912ed91790511fab4da3ef11492b74dd9059d1f3df35c58def3d8bffec8857be5c24835662aabe25cdc2c13437e2721a8200736d90e1d6c557fac7d3
diff --git a/x11-libs/libxkbcommon/libxkbcommon-0.6.0.ebuild b/x11-libs/libxkbcommon/libxkbcommon-0.6.0.ebuild
new file mode 100644
index 000000000000..b24928d3e630
--- /dev/null
+++ b/x11-libs/libxkbcommon/libxkbcommon-0.6.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+XORG_EAUTORECONF="yes"
+XORG_MULTILIB="yes"
+
+if [[ ${PV} = *9999* ]]; then
+ GIT_ECLASS="git-r3"
+ EXPERIMENTAL="true"
+ EGIT_REPO_URI="git://github.com/xkbcommon/${PN}"
+else
+ XORG_BASE_INDIVIDUAL_URI=""
+ SRC_URI="http://xkbcommon.org/download/${P}.tar.xz"
+fi
+
+inherit xorg-2 ${GIT_ECLASS}
+
+DESCRIPTION="X.Org xkbcommon library"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="X doc test"
+
+DEPEND="sys-devel/bison
+ sys-devel/flex
+ X? ( >=x11-libs/libxcb-1.10[${MULTILIB_USEDEP},xkb] )
+ >=x11-proto/xproto-7.0.24[${MULTILIB_USEDEP}]
+ >=x11-proto/kbproto-1.0.6-r1[${MULTILIB_USEDEP}]
+ doc? ( app-doc/doxygen )"
+RDEPEND=""
+
+pkg_setup() {
+ XORG_CONFIGURE_OPTIONS=(
+ --with-xkb-config-root="${EPREFIX}/usr/share/X11/xkb"
+ $(use X || use_enable X x11)
+ $(use_with doc doxygen)
+ )
+ xorg-2_pkg_setup
+}