summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-08-07 10:00:42 +0200
committerLars Wendler <polynomial-c@gentoo.org>2017-08-07 10:00:42 +0200
commit426afd9adb991f80e4f1ba010f9bcf0c07e0f10d (patch)
tree5f3e3b679647b8f452a16c16d9c594019b37fdca /x11-libs/libxkbcommon
parentsys-fs/udisks: Bump to version 2.7.2 (diff)
downloadgentoo-426afd9adb991f80e4f1ba010f9bcf0c07e0f10d.tar.gz
gentoo-426afd9adb991f80e4f1ba010f9bcf0c07e0f10d.tar.bz2
gentoo-426afd9adb991f80e4f1ba010f9bcf0c07e0f10d.zip
x11-libs/libxkbcommon: Bump to version 0.7.2
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'x11-libs/libxkbcommon')
-rw-r--r--x11-libs/libxkbcommon/Manifest1
-rw-r--r--x11-libs/libxkbcommon/libxkbcommon-0.7.2.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/x11-libs/libxkbcommon/Manifest b/x11-libs/libxkbcommon/Manifest
index c7ba87477fb2..f7c4cff22a52 100644
--- a/x11-libs/libxkbcommon/Manifest
+++ b/x11-libs/libxkbcommon/Manifest
@@ -1,2 +1,3 @@
DIST libxkbcommon-0.6.0.tar.xz 608700 SHA256 69235ec3a13194dea9555d7994bc4548b3ee20070e05a135af5372a958149ef0 SHA512 b70ff4b3b85f03cc2875622ccfa60ba6f1b86a07be90df8be73b867771dd08a85740df95fe8dfef2bacf4356a6dfc9c51523ec6ce60d197184860577b39586c4 WHIRLPOOL f2f07b96912ed91790511fab4da3ef11492b74dd9059d1f3df35c58def3d8bffec8857be5c24835662aabe25cdc2c13437e2721a8200736d90e1d6c557fac7d3
DIST libxkbcommon-0.7.1.tar.xz 622384 SHA256 ba59305d2e19e47c27ea065c2e0df96ebac6a3c6e97e28ae5620073b6084e68b SHA512 9f209214d5d7f9334cabb2cd7e0d9b9b0392c1fae06b60e92a03398875399fe48754b543389f78b8b06dd28a86dfd440720e534bae309ca8ef882eb874dce4e1 WHIRLPOOL cc397b6e24c943ea506400789d2fca501d62eb03ead929662c037175c98d2f5b7bc723e4f967b48692646e25b74d1e2120de213014d26b74cc7a85e127bda733
+DIST libxkbcommon-0.7.2.tar.xz 630276 SHA256 28a4dc2735863bec2dba238de07fcdff28c5dd2300ae9dfdb47282206cd9b9d8 SHA512 4a06f9d719393a34689fdd74b0cce80af20e26cc5bd6e1b34fff4093a4f8f103704bdc54f0245b62903cdd7529cd8d59864924b9f4ddab314d152804da4da649 WHIRLPOOL 9bf843b03a6a03411d57fa6e0a3f643e3c58b1fdf5f810ef597c4fbde9813059b8d4ea98b556c5c7af2383d0c6b78c8d67b9234105c6f9322fbccfe0a075e9f5
diff --git a/x11-libs/libxkbcommon/libxkbcommon-0.7.2.ebuild b/x11-libs/libxkbcommon/libxkbcommon-0.7.2.ebuild
new file mode 100644
index 000000000000..0a4987e6ce5a
--- /dev/null
+++ b/x11-libs/libxkbcommon/libxkbcommon-0.7.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+XORG_MULTILIB="yes"
+
+if [[ ${PV} = *9999* ]]; then
+ GIT_ECLASS="git-r3"
+ EXPERIMENTAL="true"
+ EGIT_REPO_URI="https://github.com/xkbcommon/${PN}"
+else
+ XORG_BASE_INDIVIDUAL_URI=""
+ SRC_URI="https://xkbcommon.org/download/${P}.tar.xz"
+fi
+
+inherit xorg-2 ${GIT_ECLASS}
+
+DESCRIPTION="X.Org xkbcommon library"
+HOMEPAGE="https://xkbcommon.org/"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="X doc test"
+
+DEPEND="sys-devel/bison
+ X? (
+ >=x11-libs/libxcb-1.10[${MULTILIB_USEDEP},xkb]
+ >=x11-proto/xproto-7.0.24[${MULTILIB_USEDEP}]
+ >=x11-proto/kbproto-1.0.6-r1[${MULTILIB_USEDEP}]
+ )
+ doc? ( app-doc/doxygen )"
+RDEPEND="X? ( >=x11-libs/libxcb-1.10[${MULTILIB_USEDEP},xkb] )"
+
+pkg_setup() {
+ XORG_CONFIGURE_OPTIONS=(
+ --with-xkb-config-root="${EPREFIX}/usr/share/X11/xkb"
+ $(use X || use_enable X x11)
+ $(use_with doc doxygen)
+ )
+ xorg-2_pkg_setup
+}