summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-02-06 15:07:47 -0800
committerMatt Turner <mattst88@gentoo.org>2022-02-06 15:10:48 -0800
commit6f708745949718ac7f9f22d360df3889bb8d83c7 (patch)
tree0f163489a7e5b2ee0806c3e7da525542f843e440 /x11-libs/libxkbcommon
parentmedia-video/ffmpeg: add mips, x86 (i486) to atomic workaround (diff)
downloadgentoo-6f708745949718ac7f9f22d360df3889bb8d83c7.tar.gz
gentoo-6f708745949718ac7f9f22d360df3889bb8d83c7.tar.bz2
gentoo-6f708745949718ac7f9f22d360df3889bb8d83c7.zip
x11-libs/libxkbcommon: Version bump to 1.4.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-libs/libxkbcommon')
-rw-r--r--x11-libs/libxkbcommon/Manifest1
-rw-r--r--x11-libs/libxkbcommon/libxkbcommon-1.4.0.ebuild62
-rw-r--r--x11-libs/libxkbcommon/metadata.xml3
3 files changed, 66 insertions, 0 deletions
diff --git a/x11-libs/libxkbcommon/Manifest b/x11-libs/libxkbcommon/Manifest
index 78e37feb74df..52bc9955af84 100644
--- a/x11-libs/libxkbcommon/Manifest
+++ b/x11-libs/libxkbcommon/Manifest
@@ -1 +1,2 @@
DIST libxkbcommon-1.3.1.tar.xz 471036 BLAKE2B c46d39876bd4477fe838e17e744ed04388417cfae8bb77c7de48237d31f51fe230d2705733dc0873253b48c61530fbe932e4da7317217c31a7897702fa1d03b4 SHA512 3b2cf6ae9ba4dc8b6fe702ac1fa700034fbc9bd147c73bd2cd93546bcfb71865734b3e46bad35a8fd618ed97266a02dad1dc966c63e6b10404a64919459d933e
+DIST libxkbcommon-1.4.0.tar.xz 471948 BLAKE2B 5b0a155a3a47adb7302db01f3daa0ef81993a9754b032b01f1cdbd53af74d15df95dc6c9334860211a28272b246f66978ad6e409db74a242afb13c17dc25b76e SHA512 7dd86952c036a6a78455b1ba05b53fcff9d6f133bb01c83fa860b4eaec3fc26bb0b5535948bcc2dafbd27204c3c91d01404ca9fc52896cc36af509384797d4f1
diff --git a/x11-libs/libxkbcommon/libxkbcommon-1.4.0.ebuild b/x11-libs/libxkbcommon/libxkbcommon-1.4.0.ebuild
new file mode 100644
index 000000000000..91654e01156c
--- /dev/null
+++ b/x11-libs/libxkbcommon/libxkbcommon-1.4.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} = *9999* ]]; then
+ GIT_ECLASS="git-r3"
+ EGIT_REPO_URI="https://github.com/xkbcommon/${PN}"
+else
+ SRC_URI="https://xkbcommon.org/download/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+fi
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit meson-multilib ${GIT_ECLASS} python-any-r1 virtualx
+
+DESCRIPTION="keymap handling library for toolkits and window systems"
+HOMEPAGE="https://xkbcommon.org/ https://github.com/xkbcommon/libxkbcommon/"
+LICENSE="MIT"
+IUSE="doc static-libs test tools wayland X"
+RESTRICT="!test? ( test )"
+SLOT="0"
+
+BDEPEND="
+ sys-devel/bison
+ doc? ( app-doc/doxygen )
+ test? ( ${PYTHON_DEPS} )
+ wayland? ( dev-util/wayland-scanner )
+"
+RDEPEND="
+ X? ( >=x11-libs/libxcb-1.10:=[${MULTILIB_USEDEP},xkb] )
+ wayland? ( >=dev-libs/wayland-1.2.0 )
+ dev-libs/libxml2[${MULTILIB_USEDEP}]
+ x11-misc/compose-tables
+"
+DEPEND="${RDEPEND}
+ X? ( x11-base/xorg-proto )
+ wayland? ( >=dev-libs/wayland-protocols-1.12 )
+"
+
+pkg_setup() {
+ if use test; then
+ python-any-r1_pkg_setup
+ fi
+}
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Ddefault_library="$(usex static-libs both shared)"
+ -Dxkb-config-root="${EPREFIX}/usr/share/X11/xkb"
+ $(meson_native_use_bool tools enable-tools)
+ $(meson_use X enable-x11)
+ $(meson_native_use_bool doc enable-docs)
+ $(meson_use wayland enable-wayland)
+ )
+ meson_src_configure
+}
+
+multilib_src_test() {
+ virtx meson_src_test
+}
diff --git a/x11-libs/libxkbcommon/metadata.xml b/x11-libs/libxkbcommon/metadata.xml
index 9527efe6ae50..045195581cc6 100644
--- a/x11-libs/libxkbcommon/metadata.xml
+++ b/x11-libs/libxkbcommon/metadata.xml
@@ -5,6 +5,9 @@
<email>x11@gentoo.org</email>
<name>X11</name>
</maintainer>
+ <use>
+ <flag name="tools">Build the xkbcli tools</flag>
+ </use>
<upstream>
<remote-id type="cpe">cpe:/a:xkbcommon:libxkbcommon</remote-id>
</upstream>