summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-libs/qwtplot3d
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-libs/qwtplot3d')
-rw-r--r--x11-libs/qwtplot3d/Manifest1
-rw-r--r--x11-libs/qwtplot3d/files/qwtplot3d-doxygen.patch28
-rw-r--r--x11-libs/qwtplot3d/files/qwtplot3d-examples.patch125
-rw-r--r--x11-libs/qwtplot3d/files/qwtplot3d-gcc44.patch12
-rw-r--r--x11-libs/qwtplot3d/files/qwtplot3d-profile.patch27
-rw-r--r--x11-libs/qwtplot3d/files/qwtplot3d-qt48.patch19
-rw-r--r--x11-libs/qwtplot3d/files/qwtplot3d-sys-gl2ps.patch31
-rw-r--r--x11-libs/qwtplot3d/metadata.xml12
-rw-r--r--x11-libs/qwtplot3d/qwtplot3d-0.2.7-r2.ebuild60
9 files changed, 315 insertions, 0 deletions
diff --git a/x11-libs/qwtplot3d/Manifest b/x11-libs/qwtplot3d/Manifest
new file mode 100644
index 000000000000..62eefb2c61c4
--- /dev/null
+++ b/x11-libs/qwtplot3d/Manifest
@@ -0,0 +1 @@
+DIST qwtplot3d-0.2.7.tgz 183836 SHA256 1208336b15e82e7a9d22cbc743e46f27e2fad716094a9c133138f259fa299a42
diff --git a/x11-libs/qwtplot3d/files/qwtplot3d-doxygen.patch b/x11-libs/qwtplot3d/files/qwtplot3d-doxygen.patch
new file mode 100644
index 000000000000..b0632a380a2a
--- /dev/null
+++ b/x11-libs/qwtplot3d/files/qwtplot3d-doxygen.patch
@@ -0,0 +1,28 @@
+--- qwtplot3d/doc/Doxyfile.doxygen.orig 2007-11-26 22:30:57.000000000 +0000
++++ qwtplot3d/doc/Doxyfile.doxygen 2007-11-26 22:30:03.000000000 +0000
+@@ -116,7 +116,7 @@
+ HTML_ALIGN_MEMBERS = YES
+ GENERATE_HTMLHELP = NO
+ CHM_FILE = qwtplot3d.chm
+-HHC_LOCATION = "c:\Programme\HTML Help Workshop\hhc.exe"
++#HHC_LOCATION = "c:\Programme\HTML Help Workshop\hhc.exe"
+ GENERATE_CHI = NO
+ BINARY_TOC = YES
+ TOC_EXPAND = YES
+@@ -181,7 +181,7 @@
+ MACRO_EXPANSION = NO
+ EXPAND_ONLY_PREDEF = NO
+ SEARCH_INCLUDES = YES
+-INCLUDE_PATH = V:/cvs/qwtplot3d/include/
++INCLUDE_PATH = ../include
+ INCLUDE_FILE_PATTERNS = *.h
+ PREDEFINED = QWT3D_NOT_FOR_DOXYGEN \
+ QT_VERSION=0x040000
+@@ -212,7 +212,6 @@
+ GRAPHICAL_HIERARCHY = YES
+ DIRECTORY_GRAPH = YES
+ DOT_IMAGE_FORMAT = png
+-DOT_PATH = V:/graphviz/Graphviz/bin/
+ DOTFILE_DIRS =
+ MAX_DOT_GRAPH_WIDTH = 974
+ MAX_DOT_GRAPH_HEIGHT = 10000
diff --git a/x11-libs/qwtplot3d/files/qwtplot3d-examples.patch b/x11-libs/qwtplot3d/files/qwtplot3d-examples.patch
new file mode 100644
index 000000000000..f142c3379274
--- /dev/null
+++ b/x11-libs/qwtplot3d/files/qwtplot3d-examples.patch
@@ -0,0 +1,125 @@
+diff -Nur qwtplot3d.orig/examples/axes/src/axesmainwindow.cpp qwtplot3d/examples/axes/src/axesmainwindow.cpp
+--- qwtplot3d.orig/examples/axes/src/axesmainwindow.cpp 2007-11-26 22:16:54.000000000 +0000
++++ qwtplot3d/examples/axes/src/axesmainwindow.cpp 2007-11-26 22:21:56.000000000 +0000
+@@ -9,7 +9,7 @@
+
+ #include "axes.h"
+ #include "axesmainwindow.h"
+-#include "../../../include/qwt3d_function.h"
++#include <qwt3d_function.h>
+
+ using namespace std;
+ using namespace Qwt3D;
+diff -Nur qwtplot3d.orig/examples/common.pro qwtplot3d/examples/common.pro
+--- qwtplot3d.orig/examples/common.pro 2007-11-26 22:16:54.000000000 +0000
++++ qwtplot3d/examples/common.pro 2007-11-26 23:43:33.000000000 +0000
+@@ -1,13 +1,13 @@
+ TEMPLATE = app
+-CONFIG += qt warn_on thread debug
++CONFIG += qt warn_on thread
+ UI_DIR = tmp
+ MOC_DIR = tmp
+ OBJECTS_DIR = tmp
+-INCLUDEPATH += ../../include
++INCLUDEPATH += /usr/include/qwtplot3d
+ DEPENDPATH = $$INCLUDEPATH
+ DESTDIR = ../bin
+
+-unix:LIBS += -lqwtplot3d -L../../lib
++unix:LIBS += -lqwtplot3d
+ linux-g++:QMAKE_CXXFLAGS += -fno-exceptions
+
+ win32{
+@@ -25,7 +25,7 @@
+ ISQT4 = $$find(MYVERSION, ^[2-9])
+
+ !isEmpty( ISQT4 ) {
+-RESOURCES = ../images.qrc
++#RESOURCES = ../images.qrc
+ QT += opengl
+ }
+
+diff -Nur qwtplot3d.orig/examples/enrichments/src/enrichmentmainwindow.cpp qwtplot3d/examples/enrichments/src/enrichmentmainwindow.cpp
+--- qwtplot3d.orig/examples/enrichments/src/enrichmentmainwindow.cpp 2007-11-26 22:16:54.000000000 +0000
++++ qwtplot3d/examples/enrichments/src/enrichmentmainwindow.cpp 2007-11-26 22:22:48.000000000 +0000
+@@ -6,7 +6,7 @@
+
+ #include "enrichmentmainwindow.h"
+ #include "enrichments.h"
+-#include "../../../include/qwt3d_function.h"
++#include <qwt3d_function.h>
+
+ using namespace Qwt3D;
+
+diff -Nur qwtplot3d.orig/examples/mesh2/src/colormapreader.h qwtplot3d/examples/mesh2/src/colormapreader.h
+--- qwtplot3d.orig/examples/mesh2/src/colormapreader.h 2007-11-26 22:16:54.000000000 +0000
++++ qwtplot3d/examples/mesh2/src/colormapreader.h 2007-11-26 22:23:19.000000000 +0000
+@@ -5,7 +5,7 @@
+ #include <qframe.h>
+ #include <qpixmap.h>
+
+-#include "../../../include/qwt3d_types.h"
++#include <qwt3d_types.h>
+
+ #if QT_VERSION < 0x040000
+
+diff -Nur qwtplot3d.orig/examples/mesh2/src/functions.h qwtplot3d/examples/mesh2/src/functions.h
+--- qwtplot3d.orig/examples/mesh2/src/functions.h 2007-11-26 22:16:54.000000000 +0000
++++ qwtplot3d/examples/mesh2/src/functions.h 2007-11-26 22:23:47.000000000 +0000
+@@ -2,8 +2,8 @@
+ #define __EXAMPLE_H__
+
+ #include <math.h>
+-#include "../../../include/qwt3d_parametricsurface.h"
+-#include "../../../include/qwt3d_function.h"
++#include <qwt3d_parametricsurface.h>
++#include <qwt3d_function.h>
+
+ using namespace Qwt3D;
+
+diff -Nur qwtplot3d.orig/examples/mesh2/src/lightingdlg.h qwtplot3d/examples/mesh2/src/lightingdlg.h
+--- qwtplot3d.orig/examples/mesh2/src/lightingdlg.h 2007-11-26 22:16:54.000000000 +0000
++++ qwtplot3d/examples/mesh2/src/lightingdlg.h 2007-11-26 22:24:41.000000000 +0000
+@@ -3,10 +3,10 @@
+
+ #include <math.h>
+ #include <qapplication.h>
+-#include "../../../include/qwt3d_parametricsurface.h"
+-#include "../../../include/qwt3d_surfaceplot.h"
+-#include "../../../include/qwt3d_enrichment.h"
+-#include "../../../include/qwt3d_color.h"
++#include <qwt3d_parametricsurface.h>
++#include <qwt3d_surfaceplot.h>
++#include <qwt3d_enrichment.h>
++#include <qwt3d_color.h>
+
+ #if QT_VERSION < 0x040000
+ #include "lightingdlgbase.h"
+diff -Nur qwtplot3d.orig/examples/mesh2/src/mesh2mainwindow.cpp qwtplot3d/examples/mesh2/src/mesh2mainwindow.cpp
+--- qwtplot3d.orig/examples/mesh2/src/mesh2mainwindow.cpp 2007-11-26 22:16:54.000000000 +0000
++++ qwtplot3d/examples/mesh2/src/mesh2mainwindow.cpp 2007-11-26 22:25:33.000000000 +0000
+@@ -33,9 +33,9 @@
+ #include "colormapreader.h"
+ #include "lightingdlg.h"
+ #include "femreader.h"
+-#include "../../../include/qwt3d_io.h"
+-#include "../../../include/qwt3d_io_gl2ps.h"
+-#include "../../../include/qwt3d_io_reader.h"
++#include <qwt3d_io.h>
++#include <qwt3d_io_gl2ps.h>
++#include <qwt3d_io_reader.h>
+
+ using namespace Qwt3D;
+ using namespace std;
+diff -Nur qwtplot3d.orig/examples/mesh2/src/mesh2mainwindow.h qwtplot3d/examples/mesh2/src/mesh2mainwindow.h
+--- qwtplot3d.orig/examples/mesh2/src/mesh2mainwindow.h 2007-11-26 22:16:54.000000000 +0000
++++ qwtplot3d/examples/mesh2/src/mesh2mainwindow.h 2007-11-26 22:26:09.000000000 +0000
+@@ -1,7 +1,7 @@
+ #ifndef mesh2mainwindow_h__2004_03_07_13_38_begin_guarded_code
+ #define mesh2mainwindow_h__2004_03_07_13_38_begin_guarded_code
+
+-#include "../../../include/qwt3d_surfaceplot.h"
++#include <qwt3d_surfaceplot.h>
+
+
+ #if QT_VERSION < 0x040000
diff --git a/x11-libs/qwtplot3d/files/qwtplot3d-gcc44.patch b/x11-libs/qwtplot3d/files/qwtplot3d-gcc44.patch
new file mode 100644
index 000000000000..a76fe831ab91
--- /dev/null
+++ b/x11-libs/qwtplot3d/files/qwtplot3d-gcc44.patch
@@ -0,0 +1,12 @@
+diff -ur qwtplot3d-orig/include/qwt3d_function.h qwtplot3d/include/qwt3d_function.h
+--- qwtplot3d-orig/include/qwt3d_function.h 2009-07-25 18:18:58.000000000 -0400
++++ qwtplot3d/include/qwt3d_function.h 2009-07-25 18:19:19.000000000 -0400
+@@ -2,6 +2,7 @@
+ #define qwt3d_function_h__2004_03_05_13_51_begin_guarded_code
+
+ #include "qwt3d_gridmapping.h"
++#include <cstdio>
+
+ namespace Qwt3D
+ {
+Only in qwtplot3d/tmp: qwt3d_function.o
diff --git a/x11-libs/qwtplot3d/files/qwtplot3d-profile.patch b/x11-libs/qwtplot3d/files/qwtplot3d-profile.patch
new file mode 100644
index 000000000000..831ad558d2f4
--- /dev/null
+++ b/x11-libs/qwtplot3d/files/qwtplot3d-profile.patch
@@ -0,0 +1,27 @@
+--- qwtplot3d.orig/qwtplot3d.pro 2007-11-26 22:16:54.000000000 +0000
++++ qwtplot3d/qwtplot3d.pro 2007-11-26 23:45:18.000000000 +0000
+@@ -3,7 +3,7 @@
+
+ TARGET = qwtplot3d
+ TEMPLATE = lib
+-CONFIG += qt warn_on opengl thread zlib debug
++CONFIG += qt warn_on opengl thread zlib
+ MOC_DIR = tmp
+ OBJECTS_DIR = tmp
+ INCLUDEPATH = include
+@@ -21,7 +21,7 @@
+ win32:CONFIG -= zlib
+
+ linux-g++:TMAKE_CXXFLAGS += -fno-exceptions
+-unix:VERSION = 0.2.6
++unix:VERSION = 0.2.7
+
+ # Input
+ SOURCES += src/qwt3d_axis.cpp \
+@@ -92,4 +92,4 @@
+ DEFINES += GL2PS_HAVE_ZLIB
+ win32:LIBS += zlib.lib
+ unix:LIBS += -lz
+-}
+\ No newline at end of file
++}
diff --git a/x11-libs/qwtplot3d/files/qwtplot3d-qt48.patch b/x11-libs/qwtplot3d/files/qwtplot3d-qt48.patch
new file mode 100644
index 000000000000..4e558eda7c96
--- /dev/null
+++ b/x11-libs/qwtplot3d/files/qwtplot3d-qt48.patch
@@ -0,0 +1,19 @@
+ include/qwt3d_openglhelper.h | 5 +++++
+ 1 files changed, 5 insertions(+), 0 deletions(-)
+
+diff --git a/include/qwt3d_openglhelper.h b/include/qwt3d_openglhelper.h
+index e5499c2..a7ecddc 100644
+--- a/include/qwt3d_openglhelper.h
++++ b/include/qwt3d_openglhelper.h
+@@ -8,6 +8,11 @@
+ #include <QtOpenGL/qgl.h>
+ #endif
+
++#if QT_VERSION < 0x047999
++#include <GL/glu.h>
++#endif
++
++
+ namespace Qwt3D
+ {
+
diff --git a/x11-libs/qwtplot3d/files/qwtplot3d-sys-gl2ps.patch b/x11-libs/qwtplot3d/files/qwtplot3d-sys-gl2ps.patch
new file mode 100644
index 000000000000..81a77e13249f
--- /dev/null
+++ b/x11-libs/qwtplot3d/files/qwtplot3d-sys-gl2ps.patch
@@ -0,0 +1,31 @@
+--- qwtplot3d.pro.orig 2009-04-07 19:45:29.985645378 +0100
++++ qwtplot3d.pro 2009-04-07 19:46:50.095747068 +0100
+@@ -80,13 +80,11 @@
+ include/qwt3d_graphplot.h \
+ include/qwt3d_multiplot.h
+
+-# gl2ps support
+-HEADERS+=3rdparty/gl2ps/gl2ps.h \
+- include/qwt3d_io_gl2ps.h
++# gl2ps support taken from system libs
++HEADERS+=include/qwt3d_io_gl2ps.h
+
+-SOURCES+=src/qwt3d_io_gl2ps.cpp \
+- 3rdparty/gl2ps/gl2ps.c
+-
++SOURCES+=src/qwt3d_io_gl2ps.cpp
++unix:LIBS += -lgl2ps
+ # zlib support for gl2ps
+ zlib {
+ DEFINES += GL2PS_HAVE_ZLIB
+--- src/qwt3d_io_gl2ps.cpp.orig 2009-04-07 19:44:38.536418391 +0100
++++ src/qwt3d_io_gl2ps.cpp 2009-04-07 19:45:03.685133854 +0100
+@@ -4,7 +4,7 @@
+
+ #include <time.h>
+ #include "qwt3d_openglhelper.h"
+-#include "../3rdparty/gl2ps/gl2ps.h"
++#include <gl2ps.h>
+ #include "qwt3d_io_gl2ps.h"
+ #include "qwt3d_plot.h"
+
diff --git a/x11-libs/qwtplot3d/metadata.xml b/x11-libs/qwtplot3d/metadata.xml
new file mode 100644
index 000000000000..e06eb8b1e62d
--- /dev/null
+++ b/x11-libs/qwtplot3d/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <longdescription>
+ QwtPlot3D isa feature-rich Qt/OpenGL-based C++ programming library,
+ providing essentially a bunch of 3D-widgets for programmers.
+ </longdescription>
+ <upstream>
+ <remote-id type="sourceforge">qwtplot3d</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/x11-libs/qwtplot3d/qwtplot3d-0.2.7-r2.ebuild b/x11-libs/qwtplot3d/qwtplot3d-0.2.7-r2.ebuild
new file mode 100644
index 000000000000..b39c275345c8
--- /dev/null
+++ b/x11-libs/qwtplot3d/qwtplot3d-0.2.7-r2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit qt4-r2
+
+DESCRIPTION="Qt4/OpenGL-based 3D widget library for C++"
+HOMEPAGE="http://qwtplot3d.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+
+LICENSE="ZLIB"
+SLOT="0"
+IUSE="doc examples"
+KEYWORDS="amd64 ~ppc ~ppc64 x86"
+
+RDEPEND="dev-qt/qtgui:4
+ dev-qt/qtopengl:4
+ x11-libs/gl2ps"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+S=${WORKDIR}/${PN}
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-profile.patch
+ "${FILESDIR}"/${PN}-examples.patch
+ "${FILESDIR}"/${PN}-doxygen.patch
+ "${FILESDIR}"/${PN}-sys-gl2ps.patch
+ "${FILESDIR}"/${PN}-gcc44.patch
+ "${FILESDIR}"/${PN}-qt48.patch
+ )
+
+src_prepare() {
+ qt4-r2_src_prepare
+ cat >> ${PN}.pro <<-EOF
+ target.path = /usr/$(get_libdir)
+ headers.path = /usr/include/${PN}
+ headers.files = \$\$HEADERS
+ INSTALLS = target headers
+ EOF
+}
+
+src_compile() {
+ qt4-r2_src_compile
+ if use doc ; then
+ cd doc
+ doxygen Doxyfile.doxygen || die "doxygen failed"
+ fi
+}
+
+src_install () {
+ qt4-r2_src_install
+ if use examples; then
+ insinto /usr/share/${PN}
+ doins -r examples
+ fi
+ use doc && dohtml -r doc/web/doxygen/*
+}