summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-12-07 21:31:03 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-12-07 23:40:02 +0100
commit966bea3444ebf960f008e7d1b0373df99ccdd28c (patch)
treeb9cc12f5e1718ece24ed214e93ec8fdc22ed5f4d /x11-libs/qwtplot3d
parentx11-libs/qwt: slot 5, also install the headers (diff)
downloadgentoo-966bea3444ebf960f008e7d1b0373df99ccdd28c.tar.gz
gentoo-966bea3444ebf960f008e7d1b0373df99ccdd28c.tar.bz2
gentoo-966bea3444ebf960f008e7d1b0373df99ccdd28c.zip
x11-libs/qwtplot3d: also install headers
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'x11-libs/qwtplot3d')
-rw-r--r--x11-libs/qwtplot3d/files/qwtplot3d-0.2_p20210828-install-headers.patch18
-rw-r--r--x11-libs/qwtplot3d/qwtplot3d-0.2_p20210828.ebuild1
2 files changed, 19 insertions, 0 deletions
diff --git a/x11-libs/qwtplot3d/files/qwtplot3d-0.2_p20210828-install-headers.patch b/x11-libs/qwtplot3d/files/qwtplot3d-0.2_p20210828-install-headers.patch
new file mode 100644
index 000000000000..611f9111b38b
--- /dev/null
+++ b/x11-libs/qwtplot3d/files/qwtplot3d-0.2_p20210828-install-headers.patch
@@ -0,0 +1,18 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 12657be..5306d02 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -1,4 +1,5 @@
+ cmake_minimum_required(VERSION 3.16)
++include(GNUInstallDirs)
+
+ project( QwtPlot3D
+ VERSION 0.3.0
+@@ -106,6 +107,7 @@ set( HEADERS
+ configure_file( "include/qwt3d_version.h.in" "qwt3d_version.h" @ONLY )
+
+ add_library( qwtplot3d ${SRCS} ${HEADERS} )
++set_target_properties( qwtplot3d PROPERTIES PUBLIC_HEADER "${HEADERS}" )
+
+ target_link_libraries( qwtplot3d
+ Qt${QT_VERSION_MAJOR}::Core
diff --git a/x11-libs/qwtplot3d/qwtplot3d-0.2_p20210828.ebuild b/x11-libs/qwtplot3d/qwtplot3d-0.2_p20210828.ebuild
index 0824caa45404..09a4bfa5cc32 100644
--- a/x11-libs/qwtplot3d/qwtplot3d-0.2_p20210828.ebuild
+++ b/x11-libs/qwtplot3d/qwtplot3d-0.2_p20210828.ebuild
@@ -34,6 +34,7 @@ DEPEND="${RDEPEND}"
PATCHES=(
"${FILESDIR}/${PN}-doxygen.patch"
"${FILESDIR}/${PN}-gcc44.patch"
+ "${FILESDIR}/${P}-install-headers.patch"
)
src_compile() {