summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2020-02-22 12:53:20 -0800
committerMatt Turner <mattst88@gentoo.org>2020-02-22 13:06:01 -0800
commit0aa6646d51d8724c62cbd4002c395fbe930e0893 (patch)
tree06fe78190ff258705aaad79a8b3879956f1d9e77 /x11-libs
parentx11-base/xcb-proto: Version bump to 1.14 (diff)
downloadgentoo-0aa6646d51d8724c62cbd4002c395fbe930e0893.tar.gz
gentoo-0aa6646d51d8724c62cbd4002c395fbe930e0893.tar.bz2
gentoo-0aa6646d51d8724c62cbd4002c395fbe930e0893.zip
x11-libs/libxcb: Version bump to 1.14
Closes: https://bugs.gentoo.org/708284 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/libxcb/Manifest1
-rw-r--r--x11-libs/libxcb/libxcb-1.14.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/x11-libs/libxcb/Manifest b/x11-libs/libxcb/Manifest
index 8e383a3b0300..e05955a0809b 100644
--- a/x11-libs/libxcb/Manifest
+++ b/x11-libs/libxcb/Manifest
@@ -1 +1,2 @@
DIST libxcb-1.13.1.tar.bz2 506778 BLAKE2B eca685a21d40f664b611c0c8da845e3464126b101320a86db27ee4d87b85ac0ad1a41950281b7f0ecca06883c591571d059a913591b0281890b339f279b7af93 SHA512 763edff9572623674f75a858adc57b5c09591f508cc5d5093218e7bb047abdbe0a0108bd465419a8bf15c7dcdc85efdd2d4d9fd56605c41475d15dc992640c23
+DIST libxcb-1.14.tar.xz 439404 BLAKE2B 63605e02dd32b4d26b3ac6d3b93b7383dbc30701b9a063e8efa5b387215c9325196451f80c7b0b357df1773c6fd1224eea8eeca2a456055a2cdc61082c726111 SHA512 b90a23204b0d2c29d8b115577edb01df0465e02d6a8876550fecd62375d24a5d5f872ddd5946772ddba077cadce75b12c7a6d218469dc30b5b92bc82188e8bc6
diff --git a/x11-libs/libxcb/libxcb-1.14.ebuild b/x11-libs/libxcb/libxcb-1.14.ebuild
new file mode 100644
index 000000000000..baab92359da0
--- /dev/null
+++ b/x11-libs/libxcb/libxcb-1.14.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_6,3_7,3_8} )
+PYTHON_REQ_USE=xml
+
+XORG_TARBALL_SUFFIX="xz"
+XORG_MULTILIB=yes
+XORG_DOC=doc
+
+inherit python-any-r1 xorg-3
+
+DESCRIPTION="X C-language Bindings library"
+HOMEPAGE="https://xcb.freedesktop.org/ https://gitlab.freedesktop.org/xorg/lib/libxcb"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc selinux test +xkb"
+RESTRICT="!test? ( test )"
+SLOT="0/1.12"
+
+RDEPEND="
+ >=x11-libs/libXau-1.0.7-r1[${MULTILIB_USEDEP}]
+ >=x11-libs/libXdmcp-1.1.1-r1[${MULTILIB_USEDEP}]"
+# Note: ${PYTHON_USEDEP} needs to go verbatim
+DEPEND="${RDEPEND}
+ test? ( dev-libs/check[${MULTILIB_USEDEP}] )
+ doc? ( app-doc/doxygen[dot] )
+ dev-libs/libxslt
+ ${PYTHON_DEPS}
+ $(python_gen_any_dep \
+ ">=x11-base/xcb-proto-1.14[${MULTILIB_USEDEP},\${PYTHON_USEDEP}]")"
+
+python_check_deps() {
+ has_version -b ">=x11-base/xcb-proto-1.14[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_enable doc devel-docs)
+ $(use_enable selinux)
+ )
+}