summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2018-01-05 10:06:47 -0800
committerMatt Turner <mattst88@gentoo.org>2018-01-05 10:10:58 -0800
commit81d300b0339ed621ca3203d1a609c4fba359efb4 (patch)
tree39f0edf4fc8e3ff820af30c47251b94792674358 /x11-libs
parentx11-libs/libdrm: Move KEYWORDS assignment (diff)
downloadgentoo-81d300b0339ed621ca3203d1a609c4fba359efb4.tar.gz
gentoo-81d300b0339ed621ca3203d1a609c4fba359efb4.tar.bz2
gentoo-81d300b0339ed621ca3203d1a609c4fba359efb4.zip
x11-libs/libdrm: Version bump to 2.4.89
Bug: https://bugs.gentoo.org/643482
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/libdrm/Manifest1
-rw-r--r--x11-libs/libdrm/libdrm-2.4.89.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/x11-libs/libdrm/Manifest b/x11-libs/libdrm/Manifest
index 8f08cdd4ba63..c9fbe8ab2990 100644
--- a/x11-libs/libdrm/Manifest
+++ b/x11-libs/libdrm/Manifest
@@ -1,2 +1,3 @@
DIST libdrm-2.4.82.tar.bz2 754053 BLAKE2B 83d0a7203826c093bfb6b3ce4836f3ec6182a75f08f4cecb142e5707eb525cfbba9a123a94235b09370ac53cb7beb443604cb7dfba4cf375e0d0a74f71ce8bb4 SHA512 e69fd8c2b392daabbb3a548179e3a21a555d5174c11d76a288eb2a08850849aa867c7777b67798ec00e026e998a3b128c22698f05a7b44eb24cddc5c8a3a02d0
DIST libdrm-2.4.88.tar.bz2 796583 BLAKE2B 4130633fea39e12514e6c6e7a926ca7ccca618ecb15a67cd27ee577a4ad56ecf6d09e20a323546a2b9698d7e41bd28377e7e04e8f478a3ca957868e1ac51cf98 SHA512 0d9d4bcc0d9be1fb6b1ca075339b22b0f927288a4c02bbcbf95406b5c095051890f3d2e0d32e529ef9b6952ce1250afd1e0765ad3188c2bac924dda8c33afabb
+DIST libdrm-2.4.89.tar.bz2 792940 BLAKE2B 86c8227a06060e827f39da9f1debae54784e38e34becfb3ace1329f68b0fa4cfb90532606cd3618987af2cb48b53f0277e4032055eccc164f7e6b910d3c055e0 SHA512 380e4e46cd3971a73264bd1b482791fab0503268adb65ac81b674df009662cfb8ef5741e362f19670b2a43b1c46f022d857706c9a4bebed2b1cddaa317b7706d
diff --git a/x11-libs/libdrm/libdrm-2.4.89.ebuild b/x11-libs/libdrm/libdrm-2.4.89.ebuild
new file mode 100644
index 000000000000..f9f91008a7ac
--- /dev/null
+++ b/x11-libs/libdrm/libdrm-2.4.89.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+XORG_MULTILIB=yes
+inherit xorg-2
+
+DESCRIPTION="X.Org libdrm library"
+HOMEPAGE="https://dri.freedesktop.org/"
+if [[ ${PV} = 9999* ]]; then
+ EGIT_REPO_URI="https://anongit.freedesktop.org/git/mesa/drm.git"
+else
+ SRC_URI="https://dri.freedesktop.org/libdrm/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux"
+fi
+
+VIDEO_CARDS="amdgpu exynos freedreno intel nouveau omap radeon tegra vc4 vivante vmware"
+for card in ${VIDEO_CARDS}; do
+ IUSE_VIDEO_CARDS+=" video_cards_${card}"
+done
+
+IUSE="${IUSE_VIDEO_CARDS} libkms valgrind"
+RESTRICT="test" # see bug #236845
+
+RDEPEND=">=dev-libs/libpthread-stubs-0.3-r1:=[${MULTILIB_USEDEP}]
+ video_cards_intel? ( >=x11-libs/libpciaccess-0.13.1-r1:=[${MULTILIB_USEDEP}] )
+ abi_x86_32? ( !app-emulation/emul-linux-x86-opengl[-abi_x86_32(-)] )"
+DEPEND="${RDEPEND}
+ valgrind? ( dev-util/valgrind )"
+
+src_prepare() {
+ if [[ ${PV} = 9999* ]]; then
+ # tests are restricted, no point in building them
+ sed -ie 's/tests //' "${S}"/Makefile.am
+ fi
+ xorg-2_src_prepare
+ epatch_user
+}
+
+src_configure() {
+ XORG_CONFIGURE_OPTIONS=(
+ # Udev is only used by tests now.
+ --disable-udev
+ --disable-cairo-tests
+ $(use_enable video_cards_amdgpu amdgpu)
+ $(use_enable video_cards_exynos exynos-experimental-api)
+ $(use_enable video_cards_freedreno freedreno)
+ $(use_enable video_cards_intel intel)
+ $(use_enable video_cards_nouveau nouveau)
+ $(use_enable video_cards_omap omap-experimental-api)
+ $(use_enable video_cards_radeon radeon)
+ $(use_enable video_cards_tegra tegra-experimental-api)
+ $(use_enable video_cards_vc4 vc4)
+ $(use_enable video_cards_vivante etnaviv-experimental-api)
+ $(use_enable video_cards_vmware vmwgfx)
+ $(use_enable libkms)
+ # valgrind installs its .pc file to the pkgconfig for the primary arch
+ --enable-valgrind=$(usex valgrind auto no)
+ )
+
+ xorg-2_src_configure
+}