summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2019-08-29 07:25:15 +0200
committerJeroen Roovers <jer@gentoo.org>2019-08-29 07:26:38 +0200
commitd6b13dd81f28c88e23fad47930c5c591718aba4b (patch)
treed61e48353189b07f53a097d0b9726cecde2185d2 /x11-libs
parentmedia-radio/flrig: Drop old (diff)
downloadgentoo-d6b13dd81f28c88e23fad47930c5c591718aba4b.tar.gz
gentoo-d6b13dd81f28c88e23fad47930c5c591718aba4b.tar.bz2
gentoo-d6b13dd81f28c88e23fad47930c5c591718aba4b.zip
x11-libs/libvdpau: Version 1.3
Package-Manager: Portage-2.3.73, Repoman-2.3.17 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/libvdpau/Manifest1
-rw-r--r--x11-libs/libvdpau/libvdpau-1.3.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/x11-libs/libvdpau/Manifest b/x11-libs/libvdpau/Manifest
index 1e330c7a150e..efdd5694ada3 100644
--- a/x11-libs/libvdpau/Manifest
+++ b/x11-libs/libvdpau/Manifest
@@ -1 +1,2 @@
+DIST libvdpau-1.3.tar.bz2 139009 BLAKE2B d535c7723638339d4e67002721e9d0d8aae89a6001fccc41d9c3b21d52f0fae9237705bca448fbf1c244dd7eeb71f5fc74ed81f05c975bed798fce503a571c90 SHA512 c06c23062816e8b207d38d9d53df43a1b193bb9836b48bd6d79a63d76522e87d383c446285b9877fe9c99faa0d290da8a49ccbb58eefa138cc38d0929a8e1330
DIST libvdpau-libvdpau-1.2.tar.bz2 140017 BLAKE2B 0420961c48fcd5c92e7e98f84f629946f6234c28781bd7d8c9eb4aa2ab11b76e89e05f50cc423a2935b3376ff3b919ad9e6ef1710ff3549369567f298b5efa50 SHA512 f76c2283a1bd2e854aa6b86a564f7f08c1ff7da34e971c7c39f36e77fbd51fe0440d1ba01bff0b80be6c0326817ee4e6bff719dbe8dbf5e1ec7a94fad5016b7e
diff --git a/x11-libs/libvdpau/libvdpau-1.3.ebuild b/x11-libs/libvdpau/libvdpau-1.3.ebuild
new file mode 100644
index 000000000000..2dc4d12a5faa
--- /dev/null
+++ b/x11-libs/libvdpau/libvdpau-1.3.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+VIRTUALX_REQUIRED="test"
+inherit flag-o-matic meson virtualx multilib-minimal
+
+DESCRIPTION="VDPAU wrapper and trace libraries"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/VDPAU"
+SRC_URI="https://gitlab.freedesktop.org/vdpau/${PN}/-/archive/${PV}/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm64 ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="doc dri"
+
+RDEPEND="
+ >=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
+ dri? ( >=x11-libs/libXext-1.3.2[${MULTILIB_USEDEP}] )
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+ doc? (
+ app-doc/doxygen
+ media-gfx/graphviz
+ virtual/latex-base
+ )
+ dri? ( x11-base/xorg-proto )
+"
+
+src_prepare() {
+ sed -i -e "/^docdir/s|${PN}|${PF}|g" doc/meson.build || die
+ default
+}
+
+multilib_src_configure() {
+ append-cppflags -D_GNU_SOURCE
+ local emesonargs=(
+ -Ddri2=$(usex dri true false)
+ -Ddocumentation=$(usex doc true false)
+ )
+ meson_src_configure
+}
+
+multilib_src_compile() {
+ meson_src_compile
+}
+multilib_src_test() {
+ virtx meson_src_test
+}
+
+multilib_src_install() {
+ meson_src_install
+ find "${ED}" -name '*.la' -delete || die
+}