summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-10-14 18:19:23 +0100
committerSam James <sam@gentoo.org>2021-10-14 18:19:23 +0100
commit713c81a6f76b62ea0f5a6d868c6189a1a438d320 (patch)
tree98448c38c857fe593df713d2b0332292b9d95add /x11-misc/compose-tables/compose-tables-1.7.2-r1.ebuild
parentprofiles/features/musl: use full path in INSTALL_MASK for locale.alias (diff)
downloadgentoo-713c81a6f76b62ea0f5a6d868c6189a1a438d320.tar.gz
gentoo-713c81a6f76b62ea0f5a6d868c6189a1a438d320.tar.bz2
gentoo-713c81a6f76b62ea0f5a6d868c6189a1a438d320.zip
x11-misc/compose-tables: revbump to force reinstall on musl
It's a tiny package and it'll mean that the locale files properly get installed following the INSTALL_MASK fix. Closes: https://bugs.gentoo.org/799437 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-misc/compose-tables/compose-tables-1.7.2-r1.ebuild')
-rw-r--r--x11-misc/compose-tables/compose-tables-1.7.2-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/x11-misc/compose-tables/compose-tables-1.7.2-r1.ebuild b/x11-misc/compose-tables/compose-tables-1.7.2-r1.ebuild
new file mode 100644
index 000000000000..e6d977c13554
--- /dev/null
+++ b/x11-misc/compose-tables/compose-tables-1.7.2-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+XORG_MULTILIB=no
+inherit xorg-3
+
+# Note: please bump this with x11-libs/libX11
+DESCRIPTION="X.Org Compose Key tables from libX11"
+# xorg-3.eclass would attempt to fetch a tarball with a matching name to this package
+SRC_URI="${XORG_BASE_INDIVIDUAL_URI}/lib/libX11-${PV}.tar.${XORG_TARBALL_SUFFIX}"
+S="${WORKDIR}/libX11-${PV}/"
+
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+
+# Only needed by configure
+DEPEND="
+ x11-base/xorg-proto
+ >=x11-libs/libxcb-1.11.1
+ x11-libs/xtrans"
+RDEPEND="!<x11-libs/libX11-1.7.0"
+
+XORG_CONFIGURE_OPTIONS=(
+ --without-xmlto
+ --without-fop
+ --disable-specs
+ --disable-xkb
+)
+
+src_compile() {
+ emake -C nls
+}
+
+src_test() {
+ :;
+}
+
+src_install() {
+ emake DESTDIR="${D}" -C nls install
+}