summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDouglas Agbeve <douglas@agbeve.com>2021-12-19 19:48:51 +0100
committerSergey Popov <pinkbyte@gentoo.org>2021-12-30 09:51:38 +0300
commita45623966ad5651c9e3beb9e09428dbc09f1da52 (patch)
treeae41fdbe76340e49590b12bbf56a7a4659c07e23 /x11-misc/dex/dex-0.9.0.ebuild
parentdev-ruby/zeitwerk: add 2.5.2 (diff)
downloadgentoo-a45623966ad5651c9e3beb9e09428dbc09f1da52.tar.gz
gentoo-a45623966ad5651c9e3beb9e09428dbc09f1da52.tar.bz2
gentoo-a45623966ad5651c9e3beb9e09428dbc09f1da52.zip
x11-misc/dex: bump to v0.9.0
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Douglas Agbeve <douglas@agbeve.com> Signed-off-by: Sergey Popov <pinkbyte@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/23422
Diffstat (limited to 'x11-misc/dex/dex-0.9.0.ebuild')
-rw-r--r--x11-misc/dex/dex-0.9.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/x11-misc/dex/dex-0.9.0.ebuild b/x11-misc/dex/dex-0.9.0.ebuild
new file mode 100644
index 000000000000..191bf3097bcb
--- /dev/null
+++ b/x11-misc/dex/dex-0.9.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit python-r1
+
+DESCRIPTION="DesktopEntry eXecution - tool to manage and launch autostart entries"
+HOMEPAGE="http://e-jc.de/"
+SRC_URI="https://github.com/jceb/dex/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+IUSE="doc"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}"
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx )"
+
+src_compile() {
+ # Makefile is for creating man page only
+ use doc && emake
+}
+
+src_install() {
+ dobin dex
+ python_replicate_script "${ED}/usr/bin/dex"
+ dodoc CHANGELOG.md README.rst
+ use doc && doman dex.1
+}