summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/i855crt
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/i855crt')
-rw-r--r--x11-misc/i855crt/Manifest1
-rw-r--r--x11-misc/i855crt/files/i855crt-i915support.diff70
-rw-r--r--x11-misc/i855crt/i855crt-0.4-r1.ebuild42
-rw-r--r--x11-misc/i855crt/metadata.xml12
4 files changed, 125 insertions, 0 deletions
diff --git a/x11-misc/i855crt/Manifest b/x11-misc/i855crt/Manifest
new file mode 100644
index 000000000000..f6d65cf6bacf
--- /dev/null
+++ b/x11-misc/i855crt/Manifest
@@ -0,0 +1 @@
+DIST i855crt-0.4.tar.gz 65209 SHA256 942fb0cde89737e921837d5ecab2a49158b04a5389205728cfa49108ee0bc269
diff --git a/x11-misc/i855crt/files/i855crt-i915support.diff b/x11-misc/i855crt/files/i855crt-i915support.diff
new file mode 100644
index 000000000000..5aea3a7dd96c
--- /dev/null
+++ b/x11-misc/i855crt/files/i855crt-i915support.diff
@@ -0,0 +1,70 @@
+--- a/dumpreg.c
++++ b/dumpreg.c
+@@ -36,10 +36,11 @@
+ (p = strstr(*buff_ptr, I810_DC100STR_1)) != NULL ||
+ (p = strstr(*buff_ptr, I810_DC100STR_2)) != NULL ||
+ (p = strstr(*buff_ptr, I810_IGSTR)) != NULL ||
+- (p = strstr(*buff_ptr, I810_CFCSTR)) != NULL;
++ (p = strstr(*buff_ptr, I810_CFCSTR)) != NULL ||
+ (p = strstr(*buff_ptr, I830STR)) != NULL ||
+ (p = strstr(*buff_ptr, I845STR)) != NULL ||
+- (p = strstr(*buff_ptr, I865STR)) != NULL ;
++ (p = strstr(*buff_ptr, I865STR)) != NULL ||
++ (p = strstr(*buff_ptr, I915STR)) != NULL ;
+
+ if(i)
+ {
+@@ -89,7 +90,7 @@
+ chip = i810_chip(&buff, &len, pci_f);
+ if (chip == NULL)
+ {
+- fprintf(stderr, "No know videocard has been found.\n");
++ fprintf(stderr, "No known videocard has been found.\n");
+ exit(1);
+ }
+ pclose(pci_f);
+--- a/i855crt.c
++++ b/i855crt.c
+@@ -254,14 +254,15 @@
+ (p = strstr(*buff_ptr, I810_DC100STR_1)) != NULL ||
+ (p = strstr(*buff_ptr, I810_DC100STR_2)) != NULL ||
+ (p = strstr(*buff_ptr, I810_IGSTR)) != NULL ||
+- (p = strstr(*buff_ptr, I810_CFCSTR)) != NULL;
++ (p = strstr(*buff_ptr, I810_CFCSTR)) != NULL ||
+ (p = strstr(*buff_ptr, I830STR)) != NULL ||
+ (p = strstr(*buff_ptr, I845STR)) != NULL ||
+- (p = strstr(*buff_ptr, I865STR)) != NULL ;
++ (p = strstr(*buff_ptr, I865STR)) != NULL ||
++ (p = strstr(*buff_ptr, I915STR)) != NULL ;
+
+ if(i)
+ {
+- fprintf(stderr,"This driver is untested with your videocard !\n");
++ fprintf(stderr,"This driver is untested with your video card !\n");
+ return p;
+ }
+
+@@ -493,7 +494,7 @@
+ chip = i810_chip(&buff, &len, pci_f);
+ if (chip == NULL)
+ {
+- fprintf(stderr, "No know videocard has been found.\n");
++ fprintf(stderr, "No known videocard has been found.\n");
+ exit(1);
+ }
+ pclose(pci_f);
+--- a/i855crt.h
++++ b/i855crt.h
+@@ -1,3 +1,4 @@
++
+ /*
+ * This is part of the source for i855crt driver
+ * copyright(c) Merello Andrea 2004
+@@ -45,6 +46,7 @@
+ #define I845STR "8086:2562"
+ #define I855STR "8086:3582"
+ #define I865STR "8086:2572"
++#define I915STR "8086:2592"
+ #define MEMSTR "Memory at"
+ #define NONPRSTR "32-bit, non-prefetchable"
+
diff --git a/x11-misc/i855crt/i855crt-0.4-r1.ebuild b/x11-misc/i855crt/i855crt-0.4-r1.ebuild
new file mode 100644
index 000000000000..8ce6e2304a75
--- /dev/null
+++ b/x11-misc/i855crt/i855crt-0.4-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Intel Montara 855GM CRT out auxiliary driver"
+HOMEPAGE="http://i855crt.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="
+ x11-libs/libX11
+ x11-libs/libXv
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-i915support.diff
+
+ # respect CC, fix underlinking
+ sed -i Makefile \
+ -e 's|gcc|$(CC)|g;/LDFLAGS/{s|$| -lX11|g};s|-lXext||g' \
+ || die
+ export LIBS="-lX11"
+ tc-export CC
+
+ # upstream ships it with the binary, we want to make sure we compile it
+ emake clean
+}
+
+src_install() {
+ dobin i855crt
+ insinto /etc
+ doins i855crt.conf
+}
diff --git a/x11-misc/i855crt/metadata.xml b/x11-misc/i855crt/metadata.xml
new file mode 100644
index 000000000000..91dfec751a9f
--- /dev/null
+++ b/x11-misc/i855crt/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>desktop-misc</herd>
+ <longdescription lang="en">
+i855crt is a tool to send the output of a i855-based graphic card to the
+external VGA, primarily used for presentations.
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">i855crt</remote-id>
+ </upstream>
+</pkgmetadata>