summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-04-18 11:11:18 +0100
committerSam James <sam@gentoo.org>2023-04-18 11:24:44 +0100
commit69a7d428ae3555c23c74ece8fecea229ca6cf7d1 (patch)
tree5683e6446f9d90401facbd0e9c1b8efe7f252a09 /x11-misc/j4-dmenu-desktop
parentapp-admin/syslog-ng: Stabilize 4.0.1 amd64, #904444 (diff)
downloadgentoo-69a7d428ae3555c23c74ece8fecea229ca6cf7d1.tar.gz
gentoo-69a7d428ae3555c23c74ece8fecea229ca6cf7d1.tar.bz2
gentoo-69a7d428ae3555c23c74ece8fecea229ca6cf7d1.zip
x11-misc/j4-dmenu-desktop: fix build w/ gcc 13
Closes: https://bugs.gentoo.org/895200 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-misc/j4-dmenu-desktop')
-rw-r--r--x11-misc/j4-dmenu-desktop/files/j4-dmenu-desktop-2.18-gcc13.patch25
-rw-r--r--x11-misc/j4-dmenu-desktop/j4-dmenu-desktop-2.18-r1.ebuild6
2 files changed, 30 insertions, 1 deletions
diff --git a/x11-misc/j4-dmenu-desktop/files/j4-dmenu-desktop-2.18-gcc13.patch b/x11-misc/j4-dmenu-desktop/files/j4-dmenu-desktop-2.18-gcc13.patch
new file mode 100644
index 000000000000..269044a01ba7
--- /dev/null
+++ b/x11-misc/j4-dmenu-desktop/files/j4-dmenu-desktop-2.18-gcc13.patch
@@ -0,0 +1,25 @@
+https://github.com/enkore/j4-dmenu-desktop/pull/139
+
+From 53e318f155875562b22318395461b836e9ec7e8b Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Tue, 18 Apr 2023 11:08:53 +0100
+Subject: [PATCH] Fix build with GCC 13
+
+GCC 13 (as usual for new compiler releases) shuffles around some internal includes so some
+are no longer transitively included.
+
+See https://gnu.org/software/gcc/gcc-13/porting_to.html.
+
+Bug: https://bugs.gentoo.org/895200
+--- a/src/Application.hh
++++ b/src/Application.hh
+@@ -19,7 +19,8 @@
+ #define APPLICATION_DEF
+
+ #include <algorithm>
+-#include <string.h>
++#include <cstdint>
++#include <cstring>
+ #include <unistd.h>
+
+ #include "Utilities.hh"
diff --git a/x11-misc/j4-dmenu-desktop/j4-dmenu-desktop-2.18-r1.ebuild b/x11-misc/j4-dmenu-desktop/j4-dmenu-desktop-2.18-r1.ebuild
index 1ad6b767f43d..0e03d6f0d6be 100644
--- a/x11-misc/j4-dmenu-desktop/j4-dmenu-desktop-2.18-r1.ebuild
+++ b/x11-misc/j4-dmenu-desktop/j4-dmenu-desktop-2.18-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -21,6 +21,10 @@ RESTRICT="!test? ( test )"
DEPEND="test? ( dev-cpp/catch:1 )"
RDEPEND="dmenu? ( x11-misc/dmenu )"
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.18-gcc13.patch
+)
+
src_prepare() {
cmake_src_prepare