summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/parcellite
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/parcellite')
-rw-r--r--x11-misc/parcellite/Manifest1
-rw-r--r--x11-misc/parcellite/metadata.xml8
-rw-r--r--x11-misc/parcellite/parcellite-1.1.9.ebuild48
3 files changed, 57 insertions, 0 deletions
diff --git a/x11-misc/parcellite/Manifest b/x11-misc/parcellite/Manifest
new file mode 100644
index 000000000000..bf9877081aad
--- /dev/null
+++ b/x11-misc/parcellite/Manifest
@@ -0,0 +1 @@
+DIST parcellite-1.1.9.tar.gz 720177 SHA256 cba89585082eebbe848ac1c0023cc71a0184c0db24ebc5f8a21039e46d7f11d4 SHA512 24721dbd4f049f65a40f4e4c6914344062d49dfb50e3cf6496c6f14d9aff02bef5b88d3a714e8176955c84b1324c9ca1f35b389e8033d1232dd3c802c40e32bf WHIRLPOOL ce605b7fdb000840eada03e6c29d9ea86a9a9f1f7461e34206bfd10960967bad3bc7b093ce32a8d337cde07337ebcde5cf041b50bd8785178c4a70426482e130
diff --git a/x11-misc/parcellite/metadata.xml b/x11-misc/parcellite/metadata.xml
new file mode 100644
index 000000000000..8e77238df625
--- /dev/null
+++ b/x11-misc/parcellite/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>desktop-misc</herd>
+ <upstream>
+ <remote-id type="sourceforge">parcellite</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/x11-misc/parcellite/parcellite-1.1.9.ebuild b/x11-misc/parcellite/parcellite-1.1.9.ebuild
new file mode 100644
index 000000000000..a76ef01e489f
--- /dev/null
+++ b/x11-misc/parcellite/parcellite-1.1.9.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils fdo-mime
+
+MY_P=${PN}-${PV/_}
+
+DESCRIPTION="A lightweight GTK+ based clipboard manager"
+HOMEPAGE="http://parcellite.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="nls"
+
+RDEPEND=">=dev-libs/glib-2.14
+ >=x11-libs/gtk+-2.10:2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? (
+ dev-util/intltool
+ sys-devel/gettext
+ )"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ sed -i data/${PN}.desktop.in -e 's:Application;::g' || die
+
+ sed -i -e '/^ALL_LINGUAS=/d' configure || die
+ strip-linguas -i po/
+ export ALL_LINGUAS="${LINGUAS}"
+}
+
+src_configure() {
+ econf $(use_enable nls)
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+}