summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2021-10-16 19:37:51 +0200
committerDavid Seifert <soap@gentoo.org>2021-10-16 19:37:51 +0200
commit96d5ed7743f1bdfa521e7dbb7e838ccff49eb8e0 (patch)
treeac24ef7363f57c19e3078e14313e44235098f3e8 /x11-misc/parcellite
parentx11-misc/kbdd: update EAPI 5 -> 7 (diff)
downloadgentoo-96d5ed7743f1bdfa521e7dbb7e838ccff49eb8e0.tar.gz
gentoo-96d5ed7743f1bdfa521e7dbb7e838ccff49eb8e0.tar.bz2
gentoo-96d5ed7743f1bdfa521e7dbb7e838ccff49eb8e0.zip
x11-misc/parcellite: update EAPI 5 -> 8
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'x11-misc/parcellite')
-rw-r--r--x11-misc/parcellite/files/parcellite-1.2.1-desktop-QA.patch9
-rw-r--r--x11-misc/parcellite/parcellite-1.2.1.ebuild32
2 files changed, 20 insertions, 21 deletions
diff --git a/x11-misc/parcellite/files/parcellite-1.2.1-desktop-QA.patch b/x11-misc/parcellite/files/parcellite-1.2.1-desktop-QA.patch
new file mode 100644
index 000000000000..1590a76505bf
--- /dev/null
+++ b/x11-misc/parcellite/files/parcellite-1.2.1-desktop-QA.patch
@@ -0,0 +1,9 @@
+--- a/data/parcellite.desktop.in
++++ b/data/parcellite.desktop.in
+@@ -6,5 +6,5 @@
+ Exec=parcellite
+ Terminal=false
+ Type=Application
+-Categories=GTK;GNOME;Application;Utility;
++Categories=GTK;GNOME;Utility;
+ OnlyShowIn=GNOME;KDE;LXDE;MATE;Razor;ROX;TDE;Unity;XFCE;Old;
diff --git a/x11-misc/parcellite/parcellite-1.2.1.ebuild b/x11-misc/parcellite/parcellite-1.2.1.ebuild
index b89ab441c540..d9bab58ad41d 100644
--- a/x11-misc/parcellite/parcellite-1.2.1.ebuild
+++ b/x11-misc/parcellite/parcellite-1.2.1.ebuild
@@ -1,51 +1,41 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=8
-inherit autotools eutils xdg-utils
+inherit autotools xdg
MY_P=${PN}-${PV/_}
DESCRIPTION="A lightweight GTK+ based clipboard manager"
HOMEPAGE="http://parcellite.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="amd64 ~ppc x86"
IUSE="nls"
-RDEPEND=">=dev-libs/glib-2.14
- >=x11-libs/gtk+-2.10:2
+RDEPEND="
+ dev-libs/glib:2
+ x11-libs/gtk+:2
x11-misc/xdotool"
-DEPEND="${RDEPEND}
+DEPEND="${RDEPEND}"
+BDEPEND="
virtual/pkgconfig
nls? (
dev-util/intltool
sys-devel/gettext
)"
-S=${WORKDIR}/${MY_P}
+PATCHES=( "${FILESDIR}"/${P}-desktop-QA.patch )
src_prepare() {
- sed -i data/${PN}.desktop.in -e 's:Application;::g' || die
-
- sed -i -e '/^ALL_LINGUAS=/d' configure.ac || die
- strip-linguas -i po/
- export ALL_LINGUAS="${LINGUAS}"
-
+ default
eautoreconf
}
src_configure() {
econf $(use_enable nls)
}
-
-pkg_postinst() {
- xdg_desktop_database_update
-}
-
-pkg_postrm() {
- xdg_desktop_database_update
-}