summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKajzer <kajzersoze72@gmail.com>2018-07-23 15:51:51 +0200
committerTony Vroon <chainsaw@gentoo.org>2018-07-23 16:56:26 +0100
commitf7aa86360511c47a98eaa9c9a8086fca2f75aff8 (patch)
tree228edcd3fe40cd2a388ffe0f1708cf8b45bcc9d6 /x11-misc/polybar
parentdev-haskell/language-docker: Version bump to 6.0.4 (diff)
downloadgentoo-f7aa86360511c47a98eaa9c9a8086fca2f75aff8.tar.gz
gentoo-f7aa86360511c47a98eaa9c9a8086fca2f75aff8.tar.bz2
gentoo-f7aa86360511c47a98eaa9c9a8086fca2f75aff8.zip
x11-misc/polybar: version bump to 3.2.0
Closes: https://github.com/gentoo/gentoo/pull/9326
Diffstat (limited to 'x11-misc/polybar')
-rw-r--r--x11-misc/polybar/Manifest1
-rw-r--r--x11-misc/polybar/polybar-3.2.0.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/x11-misc/polybar/Manifest b/x11-misc/polybar/Manifest
index 4648dddbc079..b56893708543 100644
--- a/x11-misc/polybar/Manifest
+++ b/x11-misc/polybar/Manifest
@@ -1,3 +1,4 @@
DIST i3ipcpp-0.7.1.tar.gz 191417 BLAKE2B 62b76a0921c78f374309d26856c01d1467b8bd181ce922fd47daec406afda9d76eea9a1f473b4899e22f99e2ef36fc70f72db1bb17eb1f3e71a8431c2634b915 SHA512 ef9f591bb4436916ad038bcb0c15ea3415d1978ff264fb276108ddac89c98515c464fbf252429f6a76589cb78e1434adba2efefb5a844dadad0e261f3806fb72
DIST polybar-3.1.0.tar.gz 418298 BLAKE2B 1c7394a17ff1ec5b0dec519b7aa58e63cfcec0f104d4302051f6e12753b7074c3d85072a3d78e7ce135c53d4ddd4a6f68ea61ffb7b2ad04997bbf0c836115046 SHA512 6d8759d9f750c2abfa79fe735615b0ed3d1827e3a88561317712c6f02cb32a0a77726f97cb419f3a040ae9085a34a23cb1aad0aacf3f14e56c542977b89036b2
+DIST polybar-3.2.0.tar.gz 242314 BLAKE2B 1bdecba237f6d400479305caa2e571b5de708b07251c77f999fdc16af4c89a54ff722956c24b0b188aa76b5418cdf159eb21004091d87d2b93e2d43ba8a888c8 SHA512 14516e37bc39736eddb53aaffd38bbfa8443fa6744bd3bd374359b9d55c085c89f59ecaa80f31815f4828398d378d2772bbd79fac36a639a208814a0bf230930
DIST xpp-1.4.0.tar.gz 84095 BLAKE2B 2af4221953abe7f40473c55cd50c608b54ebc85a62be65af987ed5e6c5eaf56fbd92531788becf39ba5ad52099ac78f36e9b2a2515b473f4d86ed5fda3fa5065 SHA512 d34cbbe2391db36db7dffac0415d26b7487536e97c4d7efd472ab0aeffa4c8e757ee030b05e2aa1cfa8a591ee591bb96a6db7eb9fa5850027f958e92f078739c
diff --git a/x11-misc/polybar/polybar-3.2.0.ebuild b/x11-misc/polybar/polybar-3.2.0.ebuild
new file mode 100644
index 000000000000..480c094886de
--- /dev/null
+++ b/x11-misc/polybar/polybar-3.2.0.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit cmake-utils python-single-r1
+
+XPP_VERSION="1.4.0"
+I3IPCPP_VERSION="0.7.1"
+
+DESCRIPTION="A fast and easy-to-use tool for creating status bars"
+HOMEPAGE="https://github.com/jaagr/polybar"
+SRC_URI="https://github.com/jaagr/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/jaagr/xpp/archive/${XPP_VERSION}.tar.gz -> xpp-${XPP_VERSION}.tar.gz
+ https://github.com/jaagr/i3ipcpp/archive/v${I3IPCPP_VERSION}.tar.gz -> i3ipcpp-${I3IPCPP_VERSION}.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+IUSE="alsa curl i3wm ipc mpd network pulseaudio"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="
+ ${PYTHON_DEPS}
+ x11-base/xcb-proto
+ x11-libs/cairo[xcb]
+ x11-libs/libxcb[xkb]
+ x11-libs/xcb-util-image
+ x11-libs/xcb-util-wm
+ x11-libs/xcb-util-xrm
+ alsa? ( media-libs/alsa-lib )
+ curl? ( net-misc/curl )
+ i3wm? ( dev-libs/jsoncpp )
+ mpd? ( media-libs/libmpdclient )
+ network? ( net-wireless/wireless-tools )
+ pulseaudio? ( media-sound/pulseaudio )
+"
+
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ cmake-utils_src_prepare
+
+ rmdir "${S}"/lib/xpp || die
+ mv "${WORKDIR}"/xpp-$XPP_VERSION "${S}"/lib/xpp || die
+
+ rmdir "${S}"/lib/i3ipcpp || die
+ mv "${WORKDIR}"/i3ipcpp-$I3IPCPP_VERSION "${S}"/lib/i3ipcpp || die
+
+ sed -i "s/.*cpp_error,.*/&\n\t 'eventstruct' : lambda x, y: None,/" lib/xpp/generators/cpp_client.py || die "sed failed"
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_ALSA="$(usex alsa)"
+ -DENABLE_CURL="$(usex curl)"
+ -DENABLE_I3="$(usex i3wm)"
+ -DBUILD_IPC_MSG="$(usex ipc)"
+ -DENABLE_MPD="$(usex mpd)"
+ -DENABLE_NETWORK="$(usex network)"
+ -DENABLE_PULSEAUDIO="$(usex pulseaudio)"
+ )
+ cmake-utils_src_configure
+}