summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIngolf Wagner <contact@ingolf-wagner.de>2016-12-21 21:38:28 +0100
committerDavid Seifert <soap@gentoo.org>2017-01-04 23:55:52 +0200
commit676abc6970aa6853a0220206c174be170bee3070 (patch)
tree416ea8e71c8278a2a3bbe984d41ec81751baa29e /x11-misc/slop/files/slop-4.3.21-no-librt.patch
parentsys-apps/sysvinit: block <sys-apps/openrc-0.13 (diff)
downloadgentoo-676abc6970aa6853a0220206c174be170bee3070.tar.gz
gentoo-676abc6970aa6853a0220206c174be170bee3070.tar.bz2
gentoo-676abc6970aa6853a0220206c174be170bee3070.zip
x11-misc/slop: add new package
Closes: https://github.com/gentoo/gentoo/pull/2796
Diffstat (limited to 'x11-misc/slop/files/slop-4.3.21-no-librt.patch')
-rw-r--r--x11-misc/slop/files/slop-4.3.21-no-librt.patch37
1 files changed, 37 insertions, 0 deletions
diff --git a/x11-misc/slop/files/slop-4.3.21-no-librt.patch b/x11-misc/slop/files/slop-4.3.21-no-librt.patch
new file mode 100644
index 000000000000..0b95b833ffda
--- /dev/null
+++ b/x11-misc/slop/files/slop-4.3.21-no-librt.patch
@@ -0,0 +1,37 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -75,10 +75,6 @@ find_package( GLX REQUIRED )
+ find_package( XRender REQUIRED )
+ find_package( XRandr REQUIRED )
+ find_package( GLEW REQUIRED )
+-# This library is needed only for Ubuntu it seems, some platforms don't even
+-# ship with it. I couldn't find a way to do a test compile to check if librt
+-# was needed, so instead I just didn't mark it as REQUIRED.
+-find_package( RT )
+
+ set( CMAKE_CXX_FLAGS
+ "${CMAKE_CXX_FLAGS} ${CMAKE_IMLIB2_CXX_FLAGS}" )
+@@ -96,10 +92,6 @@ include_directories( "${IMLIB2_INCLUDE_DIR}"
+ ${XRENDER_INCLUDE_DIRS} )
+ endif()
+
+-if ( RT_INCLUDE_DIR )
+- include_directories( ${RT_INCLUDE_DIR} )
+-endif()
+-
+ # Executable
+ add_executable( "${BIN_TARGET}" ${source} )
+
+@@ -119,11 +111,6 @@ if ( CMAKE_OPENGL_SUPPORT )
+ endif()
+
+
+-if ( RT_LIBRARY )
+- target_link_libraries( "${BIN_TARGET}"
+- "${RT_LIBRARY}" )
+-endif()
+-
+ install( TARGETS ${BIN_TARGET}
+ DESTINATION "${CMAKE_INSTALL_PREFIX}/bin" )
+