summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHarri Nieminen <moikkis@gmail.com>2017-02-13 19:00:17 +0200
committerDavid Seifert <soap@gentoo.org>2017-02-14 20:44:06 +0100
commitb8f9aa4340cc676f691d235cd2fbf4e445898938 (patch)
treec15f1a19d95acb5ec48ac61824ec6ecea26c7a7e /x11-misc/trayer
parentx11-plugins/pidgintex: remove old, migrate away from google code #544092 (diff)
downloadgentoo-b8f9aa4340cc676f691d235cd2fbf4e445898938.tar.gz
gentoo-b8f9aa4340cc676f691d235cd2fbf4e445898938.tar.bz2
gentoo-b8f9aa4340cc676f691d235cd2fbf4e445898938.zip
x11-misc/trayer: EAPI bump 4 -> 6
Package-Manager: Portage-2.3.3, Repoman-2.3.1 Closes: https://github.com/gentoo/gentoo/pull/3957
Diffstat (limited to 'x11-misc/trayer')
-rw-r--r--x11-misc/trayer/trayer-1.0-r2.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/x11-misc/trayer/trayer-1.0-r2.ebuild b/x11-misc/trayer/trayer-1.0-r2.ebuild
new file mode 100644
index 000000000000..be69dd0547de
--- /dev/null
+++ b/x11-misc/trayer/trayer-1.0-r2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit toolchain-funcs
+
+DESCRIPTION="Lightweight GTK+ based systray for UNIX desktop"
+HOMEPAGE="http://home.gna.org/fvwm-crystal/"
+SRC_URI="http://download.gna.org/fvwm-crystal/trayer/${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-libs/glib:2
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:2
+ x11-libs/libX11
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+ # fix for as-needed, bug #141707
+ # fix pre-stripped files, bug #252098
+ sed -i Makefile \
+ -e 's:$(LIBS) $(OBJ) $(SYSTRAYOBJ):$(OBJ) $(SYSTRAYOBJ) $(LIBS):' \
+ -e 's:strip:true:g' \
+ || die
+ # fix underlinking, bug #369591
+ sed -i Makefile.common \
+ -e '/^LIBS/s:).*: x11):' \
+ -e '/^INC/s:).*: x11):' \
+ || die
+}
+
+src_compile() {
+ emake -j1 CC=$(tc-getCC) CFLAGS="${CFLAGS}" CPPFLAGS="${CPPFLAGS}"
+}
+
+src_install() {
+ dobin trayer
+ doman trayer.1
+ einstalldocs
+}