summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/unclutter
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/unclutter')
-rw-r--r--x11-misc/unclutter/Manifest1
-rw-r--r--x11-misc/unclutter/files/unclutter-8-FocusOut.patch17
-rw-r--r--x11-misc/unclutter/files/unclutter-8-include.patch10
-rw-r--r--x11-misc/unclutter/metadata.xml5
-rw-r--r--x11-misc/unclutter/unclutter-8-r2.ebuild37
-rw-r--r--x11-misc/unclutter/unclutter-8-r3.ebuild37
6 files changed, 107 insertions, 0 deletions
diff --git a/x11-misc/unclutter/Manifest b/x11-misc/unclutter/Manifest
new file mode 100644
index 000000000000..2687c6940fc9
--- /dev/null
+++ b/x11-misc/unclutter/Manifest
@@ -0,0 +1 @@
+DIST unclutter-8.tar.Z 12344 SHA256 b855a78d4465ab2f86287eacac63a73f1504b08522840aa37718776e7ec9192a SHA512 9a64e6eceae685cf34b1ea85818735f8f85514ba1eea262476653886d74e469cfd6b9a39edbd098b138a5c89e6b97b42cf251bee59272c76cbeba190979744b4 WHIRLPOOL 9cccf31b0e64e37d075ec411398abbeea399745ae2e90f3c35e707a78c8a8c04e017d24f4a2f135cc75e04c5915cdc7bd5b3c16fdf1e7fbf73174cc30a461873
diff --git a/x11-misc/unclutter/files/unclutter-8-FocusOut.patch b/x11-misc/unclutter/files/unclutter-8-FocusOut.patch
new file mode 100644
index 000000000000..d26ef8e6a652
--- /dev/null
+++ b/x11-misc/unclutter/files/unclutter-8-FocusOut.patch
@@ -0,0 +1,17 @@
+Description: Fixes blinking pointer and 100% CPU usage with GTK applications
+Author: Tao Nelson <taobert@gmail.com>
+Debian-Bug: 266118
+
+--- a/unclutter.c
++++ b/unclutter.c
+@@ -399,7 +399,9 @@
+ do{
+ XNextEvent(display,&event);
+ }while(event.type!=LeaveNotify &&
+- event.type!=FocusOut &&
++ /* Some gtk applications seem not to like this:
++ * event.type!=FocusOut &&
++ */
+ event.type!=UnmapNotify &&
+ event.type!=ConfigureNotify &&
+ event.type!=CirculateNotify &&
diff --git a/x11-misc/unclutter/files/unclutter-8-include.patch b/x11-misc/unclutter/files/unclutter-8-include.patch
new file mode 100644
index 000000000000..688fa129c561
--- /dev/null
+++ b/x11-misc/unclutter/files/unclutter-8-include.patch
@@ -0,0 +1,10 @@
+--- a/unclutter.c
++++ b/unclutter.c
+@@ -24,6 +24,7 @@
+ #include <X11/Xutil.h>
+ #include <X11/Xproto.h>
+ #include <stdio.h>
++#include <stdlib.h>
+ #include "vroot.h"
+
+ char *progname;
diff --git a/x11-misc/unclutter/metadata.xml b/x11-misc/unclutter/metadata.xml
new file mode 100644
index 000000000000..40838bc36783
--- /dev/null
+++ b/x11-misc/unclutter/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>desktop-misc</herd>
+</pkgmetadata>
diff --git a/x11-misc/unclutter/unclutter-8-r2.ebuild b/x11-misc/unclutter/unclutter-8-r2.ebuild
new file mode 100644
index 000000000000..9d68313ac09b
--- /dev/null
+++ b/x11-misc/unclutter/unclutter-8-r2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+
+inherit toolchain-funcs
+
+DESCRIPTION="Hides mouse pointer while not in use"
+HOMEPAGE="http://www.ibiblio.org/pub/X11/contrib/utilities/unclutter-8.README"
+SRC_URI="ftp://ftp.x.org/contrib/utilities/${P}.tar.Z"
+
+SLOT="0"
+LICENSE="public-domain"
+KEYWORDS="alpha amd64 hppa ~mips ppc ppc64 ~sparc x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11"
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ sed -i -e "/stdio/ a #include <stdlib.h>" unclutter.c || die #implictits
+}
+
+src_compile() {
+ emake CDEBUGFLAGS="${CFLAGS}" CC="$(tc-getCC)" \
+ LDOPTIONS="${LDFLAGS}" || die
+}
+
+src_install () {
+ dobin unclutter || die
+ newman unclutter.man unclutter.1x || die
+ dodoc README || die
+}
diff --git a/x11-misc/unclutter/unclutter-8-r3.ebuild b/x11-misc/unclutter/unclutter-8-r3.ebuild
new file mode 100644
index 000000000000..260ebc9d0ee8
--- /dev/null
+++ b/x11-misc/unclutter/unclutter-8-r3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Hides mouse pointer while not in use"
+HOMEPAGE="http://www.ibiblio.org/pub/X11/contrib/utilities/unclutter-8.README"
+SRC_URI="ftp://ftp.x.org/contrib/utilities/${P}.tar.Z"
+
+SLOT="0"
+LICENSE="public-domain"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="x11-libs/libX11"
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-include.patch \
+ "${FILESDIR}"/${P}-FocusOut.patch
+}
+
+src_compile() {
+ emake CDEBUGFLAGS="${CFLAGS}" CC="$(tc-getCC)" LDOPTIONS="${LDFLAGS}"
+}
+
+src_install () {
+ dobin unclutter
+ newman unclutter.man unclutter.1x
+ dodoc README
+}