summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2019-10-01 00:35:15 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2019-10-01 00:36:02 +0100
commit1abb23efdc71ee0f54b2a602c2b40e986e860e20 (patch)
treebeba36b1566081ef504cc31d2e6d882133bcb43b /x11-misc/xmobar
parentprofiles: Fix issues with PHP 5.6 mask (diff)
downloadgentoo-1abb23efdc71ee0f54b2a602c2b40e986e860e20.tar.gz
gentoo-1abb23efdc71ee0f54b2a602c2b40e986e860e20.tar.bz2
gentoo-1abb23efdc71ee0f54b2a602c2b40e986e860e20.zip
x11-misc/xmobar: drop underscores from IUSE, bug #695144
Reported-by: Michał Górny Closes: https://bugs.gentoo.org/695144 Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'x11-misc/xmobar')
-rw-r--r--x11-misc/xmobar/metadata.xml4
-rw-r--r--x11-misc/xmobar/xmobar-0.24.2.ebuild10
-rw-r--r--x11-misc/xmobar/xmobar-0.24.3.ebuild10
3 files changed, 12 insertions, 12 deletions
diff --git a/x11-misc/xmobar/metadata.xml b/x11-misc/xmobar/metadata.xml
index 7cb1b0df7941..69dba3f2e452 100644
--- a/x11-misc/xmobar/metadata.xml
+++ b/x11-misc/xmobar/metadata.xml
@@ -9,8 +9,8 @@
<flag name="mpd">Support mpd plugin</flag>
<flag name="mpris">Enables MPRIS v1, v2 support</flag>
<flag name="timezone">Enables localized date support</flag>
- <flag name="with_conduit">Use conduit to fetch weather data.</flag>
- <flag name="with_uvmeter">Plugin to show UV data for Australia.</flag>
+ <flag name="conduit">Use conduit to fetch weather data.</flag>
+ <flag name="uvmeter">Plugin to show UV data for Australia.</flag>
</use>
<longdescription>
Xmobar is a minimalistic text based status bar.
diff --git a/x11-misc/xmobar/xmobar-0.24.2.ebuild b/x11-misc/xmobar/xmobar-0.24.2.ebuild
index 6444bb6aae47..e6856fed386e 100644
--- a/x11-misc/xmobar/xmobar-0.24.2.ebuild
+++ b/x11-misc/xmobar/xmobar-0.24.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -16,7 +16,7 @@ SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="alsa dbus inotify mpd mpris timezone wifi with_conduit with_uvmeter xft xpm"
+IUSE="alsa dbus inotify mpd mpris timezone wifi conduit uvmeter xft xpm"
RDEPEND=">=dev-haskell/http-4000.2.4:=
>=dev-haskell/mtl-2.1:= <dev-haskell/mtl-2.3:=
@@ -39,7 +39,7 @@ RDEPEND=">=dev-haskell/http-4000.2.4:=
timezone? ( >=dev-haskell/timezone-olson-0.1:= <dev-haskell/timezone-olson-0.2:=
>=dev-haskell/timezone-series-0.1:= <dev-haskell/timezone-series-0.2:= )
wifi? ( net-wireless/wireless-tools )
- with_conduit? ( dev-haskell/http-conduit:=
+ conduit? ( dev-haskell/http-conduit:=
dev-haskell/http-types:= )
xft? ( >=dev-haskell/x11-xft-0.2:= <dev-haskell/x11-xft-0.4:= )
xpm? ( x11-libs/libXpm )
@@ -72,7 +72,7 @@ src_configure() {
haskell-cabal_src_configure \
--flag=-all_extensions \
$(cabal_flag alsa with_alsa) \
- $(cabal_flag with_conduit with_conduit) \
+ $(cabal_flag conduit with_conduit) \
$(cabal_flag timezone with_datezone) \
$(cabal_flag dbus with_dbus) \
$(cabal_flag inotify with_inotify) \
@@ -81,7 +81,7 @@ src_configure() {
$(cabal_flag mpris with_mpris) \
--flag=with_threaded \
--flag=with_utf8 \
- $(cabal_flag with_uvmeter with_uvmeter) \
+ $(cabal_flag uvmeter with_uvmeter) \
$(cabal_flag xft with_xft) \
$(cabal_flag xpm with_xpm)
}
diff --git a/x11-misc/xmobar/xmobar-0.24.3.ebuild b/x11-misc/xmobar/xmobar-0.24.3.ebuild
index 99ba81604786..fbc0b390b6e6 100644
--- a/x11-misc/xmobar/xmobar-0.24.3.ebuild
+++ b/x11-misc/xmobar/xmobar-0.24.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -16,7 +16,7 @@ SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="alsa dbus inotify mpd mpris timezone wifi with_conduit with_uvmeter xft xpm"
+IUSE="alsa dbus inotify mpd mpris timezone wifi conduit uvmeter xft xpm"
RDEPEND=">=dev-haskell/http-4000.2.4:=
>=dev-haskell/mtl-2.1:= <dev-haskell/mtl-2.3:=
@@ -38,7 +38,7 @@ RDEPEND=">=dev-haskell/http-4000.2.4:=
timezone? ( >=dev-haskell/timezone-olson-0.1:= <dev-haskell/timezone-olson-0.2:=
>=dev-haskell/timezone-series-0.1:= <dev-haskell/timezone-series-0.2:= )
wifi? ( net-wireless/wireless-tools )
- with_conduit? ( dev-haskell/http-conduit:=
+ conduit? ( dev-haskell/http-conduit:=
dev-haskell/http-types:= )
xft? ( >=dev-haskell/x11-xft-0.2:= <dev-haskell/x11-xft-0.4:= )
xpm? ( x11-libs/libXpm )
@@ -73,7 +73,7 @@ src_configure() {
haskell-cabal_src_configure \
--flag=-all_extensions \
$(cabal_flag alsa with_alsa) \
- $(cabal_flag with_conduit with_conduit) \
+ $(cabal_flag conduit with_conduit) \
$(cabal_flag timezone with_datezone) \
$(cabal_flag dbus with_dbus) \
$(cabal_flag inotify with_inotify) \
@@ -82,7 +82,7 @@ src_configure() {
$(cabal_flag mpris with_mpris) \
--flag=with_threaded \
--flag=with_utf8 \
- $(cabal_flag with_uvmeter with_uvmeter) \
+ $(cabal_flag uvmeter with_uvmeter) \
$(cabal_flag xft with_xft) \
$(cabal_flag xpm with_xpm)
}