summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2021-07-24 22:42:22 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2021-07-24 22:42:37 -0700
commitf84c3871f3cc3e57f4267ee7bd2208af1c82789f (patch)
tree17fa949cce6eaa089c36f9444c56942e34dee342 /x11-misc/xscreensaver/xscreensaver-6.01-r3.ebuild
parentdev-libs/libverto: add missing || die (diff)
downloadgentoo-f84c3871f3cc3e57f4267ee7bd2208af1c82789f.tar.gz
gentoo-f84c3871f3cc3e57f4267ee7bd2208af1c82789f.tar.bz2
gentoo-f84c3871f3cc3e57f4267ee7bd2208af1c82789f.zip
x11-misc/xscreensaver: packaging fix for LINGUAS & pam.d false positive error
Closes: https://bugs.gentoo.org/803479 Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
Diffstat (limited to 'x11-misc/xscreensaver/xscreensaver-6.01-r3.ebuild')
-rw-r--r--x11-misc/xscreensaver/xscreensaver-6.01-r3.ebuild15
1 files changed, 14 insertions, 1 deletions
diff --git a/x11-misc/xscreensaver/xscreensaver-6.01-r3.ebuild b/x11-misc/xscreensaver/xscreensaver-6.01-r3.ebuild
index 10eae1bbfe28..fc75283e450c 100644
--- a/x11-misc/xscreensaver/xscreensaver-6.01-r3.ebuild
+++ b/x11-misc/xscreensaver/xscreensaver-6.01-r3.ebuild
@@ -125,8 +125,19 @@ src_prepare() {
eapply_user
# Must be eauto*re*conf, to force the rebuild
+ # it is NOT an entirely normal autoconf so there is weirdness!
eautoreconf
eautoheader
+
+ # Afterwards, fix the linguas
+ # doesn't populate @install_sh@ properly
+ # https://bugs.gentoo.org/803479
+ # requires LINGUAS to trigger
+ sed -i.orig \
+ -e "/^install_sh = /s!=.*!= ${S}/install-sh!g" \
+ "${S}/po/Makefile.in.in" || die
+ grep -e install_sh \
+ "${S}/po/Makefile.in.in" || die
}
src_configure() {
@@ -183,7 +194,8 @@ src_compile() {
}
src_install() {
- emake install_prefix="${D}" install
+ use pam && dodir /etc/pam.d/
+ emake install_prefix="${D}" DESTDIR="${D}" install
if use fonts; then
# Do not install fonts with unclear licensing
@@ -200,6 +212,7 @@ src_install() {
dodoc README{,.hacking}
if use pam; then
+ rm -f "${ED}/etc/pam.d/xscreensaver" # install our version instead
fperms 755 /usr/bin/${PN}
pamd_mimic_system ${PN} auth
fi