summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHarri Nieminen <moikkis@gmail.com>2017-02-27 18:47:14 +0200
committerDavid Seifert <soap@gentoo.org>2017-03-01 21:44:43 +0100
commit08a84ae4072eb3a06c6762b29788f3ff6c3d47ef (patch)
tree185e0a258153421b5f5b03241eab17d6da6e2dac /x11-misc/xscreensaver
parentx11-misc/cairo-clock: EAPI bump 4 -> 6, fix #452106 (diff)
downloadgentoo-08a84ae4072eb3a06c6762b29788f3ff6c3d47ef.tar.gz
gentoo-08a84ae4072eb3a06c6762b29788f3ff6c3d47ef.tar.bz2
gentoo-08a84ae4072eb3a06c6762b29788f3ff6c3d47ef.zip
x11-misc/xscreensaver: Depend on x11-libs/gdk-pixbuf[X], fixes #608982
Configure step gives following warning otherwise. Warning: GTK version 2.24.31 was found, but at least one supporting library (gdk-pixbuf-xlib-2.0) was not, so GTK can't be used. Perhaps some of the development packages are not installed? Warning: The GTK libraries do not seem to be available; the `xscreensaver-demo' program requires them. Warning: Use of GDK-Pixbuf was requested, but it was not found. The XPM library is being used instead. Some of the demos will not use images as much as they could. You should consider installing GDK-Pixbuf and re-running configure. (GDK-Pixbuf is recommended over XPM, as it provides support for more image formats.) Gentoo-Bug: https://bugs.gentoo.org/608982 Package-Manager: Portage-2.3.3, Repoman-2.3.1 Closes: https://github.com/gentoo/gentoo/pull/4091
Diffstat (limited to 'x11-misc/xscreensaver')
-rw-r--r--x11-misc/xscreensaver/xscreensaver-5.36-r1.ebuild144
1 files changed, 144 insertions, 0 deletions
diff --git a/x11-misc/xscreensaver/xscreensaver-5.36-r1.ebuild b/x11-misc/xscreensaver/xscreensaver-5.36-r1.ebuild
new file mode 100644
index 000000000000..2733736ca6be
--- /dev/null
+++ b/x11-misc/xscreensaver/xscreensaver-5.36-r1.ebuild
@@ -0,0 +1,144 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit autotools flag-o-matic multilib pam
+
+DESCRIPTION="A modular screen saver and locker for the X Window System"
+HOMEPAGE="https://www.jwz.org/xscreensaver/"
+SRC_URI="${HOMEPAGE}${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x64-solaris ~x86-solaris"
+IUSE="gdm jpeg new-login offensive opengl pam +perl selinux suid xinerama"
+
+COMMON_DEPEND="
+ >=gnome-base/libglade-2
+ dev-libs/libxml2
+ media-libs/netpbm
+ x11-apps/appres
+ x11-apps/xwininfo
+ x11-libs/gdk-pixbuf:2[X]
+ x11-libs/gtk+:2
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXmu
+ x11-libs/libXrandr
+ x11-libs/libXt
+ x11-libs/libXxf86misc
+ x11-libs/libXxf86vm
+ jpeg? ( virtual/jpeg:0 )
+ new-login? (
+ gdm? ( gnome-base/gdm )
+ !gdm? ( || ( x11-misc/lightdm lxde-base/lxdm ) )
+ )
+ opengl? (
+ virtual/glu
+ virtual/opengl
+ )
+ pam? ( virtual/pam )
+ xinerama? ( x11-libs/libXinerama )
+"
+# For USE="perl" see output of `qlist xscreensaver | grep bin | xargs grep '::'`
+RDEPEND="
+ ${COMMON_DEPEND}
+ perl? (
+ dev-lang/perl
+ dev-perl/libwww-perl
+ virtual/perl-Digest-MD5
+ )
+ selinux? ( sec-policy/selinux-xscreensaver )
+"
+DEPEND="
+ ${COMMON_DEPEND}
+ dev-util/intltool
+ sys-devel/bc
+ sys-devel/gettext
+ virtual/pkgconfig
+ x11-proto/recordproto
+ x11-proto/scrnsaverproto
+ x11-proto/xextproto
+ x11-proto/xf86miscproto
+ x11-proto/xf86vidmodeproto
+ xinerama? ( x11-proto/xineramaproto )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-5.05-interix.patch
+ "${FILESDIR}"/${PN}-5.20-blurb-hndl-test-passwd.patch
+ "${FILESDIR}"/${PN}-5.20-test-passwd-segv-tty.patch
+ "${FILESDIR}"/${PN}-5.20-tests-miscfix.patch
+ "${FILESDIR}"/${PN}-5.28-comment-style.patch
+ "${FILESDIR}"/${PN}-5.31-pragma.patch
+ "${FILESDIR}"/${PN}-5.35-gentoo.patch
+)
+
+src_prepare() {
+ use offensive || PATCHES+=( "${FILESDIR}"/${PN}-5.35-offensive.patch )
+ default
+
+ mv configure.{in,ac} || die #426262
+
+ sed -i configure.ac -e '/^ALL_LINGUAS=/d' || die
+ strip-linguas -i po/
+ export ALL_LINGUAS="${LINGUAS}"
+
+ if use new-login && ! use gdm; then #392967
+ sed -i \
+ -e "/default_l.*1/s:gdmflexiserver -ls:${EPREFIX}/usr/libexec/lightdm/&:" \
+ configure{,.ac} || die
+ fi
+
+ eautoconf
+ eautoheader
+}
+
+src_configure() {
+ if use ppc || use ppc64; then
+ filter-flags -maltivec -mabi=altivec
+ append-flags -U__VEC__
+ fi
+
+ unset BC_ENV_ARGS #24568
+ export RPM_PACKAGE_VERSION=no #368025
+
+ econf \
+ $(use_with jpeg) \
+ $(use_with new-login login-manager) \
+ $(use_with opengl gl) \
+ $(use_with pam) \
+ $(use_with suid setuid-hacks) \
+ $(use_with xinerama xinerama-ext) \
+ --enable-locking \
+ --with-configdir="${EPREFIX}"/usr/share/${PN}/config \
+ --with-dpms-ext \
+ --with-gtk \
+ --with-hackdir="${EPREFIX}"/usr/$(get_libdir)/misc/${PN} \
+ --with-pixbuf \
+ --with-proc-interrupts \
+ --with-randr-ext \
+ --with-text-file="${EPREFIX}"/etc/gentoo-release \
+ --with-x-app-defaults="${EPREFIX}"/usr/share/X11/app-defaults \
+ --with-xdbe-ext \
+ --with-xf86gamma-ext \
+ --with-xf86vmode-ext \
+ --with-xinput-ext \
+ --with-xshm-ext \
+ --without-gle \
+ --without-kerberos \
+ --x-includes="${EPREFIX}"/usr/include \
+ --x-libraries="${EPREFIX}"/usr/$(get_libdir)
+}
+
+src_install() {
+ emake install_prefix="${D}" install
+ einstalldocs
+
+ use pam && fperms 755 /usr/bin/${PN}
+ pamd_mimic_system ${PN} auth
+
+ rm -f "${ED%/}"/usr/share/${PN}/config/{electricsheep,fireflies}.xml || die
+}