summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2019-07-23 12:03:16 +0200
committerJeroen Roovers <jer@gentoo.org>2019-07-23 12:03:34 +0200
commit5601cabf5c3865f8b3267162eb3588f89bda2c91 (patch)
treeb39b0ff2388055fb9d8c74fcaa4c02126ab3eb4d /x11-misc
parentx11-misc/i3lock: Version 2.12 (diff)
downloadgentoo-5601cabf5c3865f8b3267162eb3588f89bda2c91.tar.gz
gentoo-5601cabf5c3865f8b3267162eb3588f89bda2c91.tar.bz2
gentoo-5601cabf5c3865f8b3267162eb3588f89bda2c91.zip
x11-misc/xdesktopwaves: Version 1.4
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/xdesktopwaves/Manifest1
-rw-r--r--x11-misc/xdesktopwaves/files/xdesktopwaves-1.4-gentoo.patch40
-rw-r--r--x11-misc/xdesktopwaves/xdesktopwaves-1.4.ebuild39
3 files changed, 80 insertions, 0 deletions
diff --git a/x11-misc/xdesktopwaves/Manifest b/x11-misc/xdesktopwaves/Manifest
index 89734173b05e..60a54f7429c9 100644
--- a/x11-misc/xdesktopwaves/Manifest
+++ b/x11-misc/xdesktopwaves/Manifest
@@ -1 +1,2 @@
DIST xdesktopwaves-1.3.tar.gz 49302 BLAKE2B 96348d80ba71a179df09afbaa8f2fb79725e049203e9644769e5a41b7fa8a9cae06ef2002ac3062f317f84419ae2ef739e7a90142b9b06118f51754d295e70ed SHA512 7dd3eb4f3a9291e9afab7aab7385cc271af2754adecde85ef3a2dfbc6a0bd96bab440cdb9f34cabb9e7c6d9ee25cdc64bf57ba7edc4df03f344b5b10404cd52e
+DIST xdesktopwaves-1.4.tar.gz 50259 BLAKE2B 5512746c9a035878f50abfc35c088f2953c5a0decaab6e0fc3cd31e29e75d100430c36df5a0043f64222521e939797ad24b9147a66cf5ba20f7f4c22fc78767d SHA512 06ec5bea51737d066beccad57db63ef7e56e59c18bb7c1dcaf06f6691940ac32a32b7cd06d9e3f16ad472e3d793c391b072a753e0088ab71ae7304b20b2fa3ba
diff --git a/x11-misc/xdesktopwaves/files/xdesktopwaves-1.4-gentoo.patch b/x11-misc/xdesktopwaves/files/xdesktopwaves-1.4-gentoo.patch
new file mode 100644
index 000000000000..528e4780f6f7
--- /dev/null
+++ b/x11-misc/xdesktopwaves/files/xdesktopwaves-1.4-gentoo.patch
@@ -0,0 +1,40 @@
+--- a/Makefile
++++ b/Makefile
+@@ -11,14 +11,14 @@
+
+ #=========================== C compiler configuration ==========================
+
+-CC = gcc
+-CFLAGS = -I/usr/X11R6/include -O2
++CC ?= gcc
++CFLAGS += $(shell $(PKG_CONFIG) --cflags x11 xext)
+
+ #============================= Linker configuration ============================
+
+-LINK = gcc
+-LFLAGS = -L/usr/X11R6/lib64 -L/usr/X11R6/lib
+-LIBS = -lm -lX11 -lXext
++LINK = $(CC)
++LFLAGS = $(LDFLAGS)
++LIBS = -lm $(shell $(PKG_CONFIG) --libs x11 xext)
+
+ #============================ Installer configuration ==========================
+
+--- a/xdwapi/Makefile
++++ b/xdwapi/Makefile
+@@ -1,10 +1,10 @@
+ # Makefile for the xdesktopwaves API and its demo program
+
+-CC = gcc
+-CFLAGS = -I/usr/X11R6/include -O2
+-LINK = gcc
+-LFLAGS = -L/usr/X11R6/lib64 -L/usr/X11R6/lib
+-LIBS = -lm -lX11
++CC ?= gcc
++CFLAGS += $(shell $(PKG_CONFIG) --cflags x11 xext)
++LINK ?= $(CC)
++LFLAGS = $(LDFLAGS)
++LIBS = -lm $(shell $(PKG_CONFIG) --libs x11 xext)
+
+ all: xdwapidemo
+
diff --git a/x11-misc/xdesktopwaves/xdesktopwaves-1.4.ebuild b/x11-misc/xdesktopwaves/xdesktopwaves-1.4.ebuild
new file mode 100644
index 000000000000..901b11eb7789
--- /dev/null
+++ b/x11-misc/xdesktopwaves/xdesktopwaves-1.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit desktop toolchain-funcs
+
+DESCRIPTION="A cellular automata setting the background of your X Windows desktop under water"
+HOMEPAGE="http://xdesktopwaves.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+RDEPEND="
+ x11-libs/libXext
+"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto
+"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.4-gentoo.patch
+)
+
+src_compile() {
+ tc-export CC PKG_CONFIG
+ emake
+ emake -C xdwapi
+}
+
+src_install() {
+ dobin xdesktopwaves xdwapi/xdwapidemo
+ doman xdesktopwaves.1
+ insinto /usr/share/pixmaps
+ doins xdesktopwaves.xpm
+ make_desktop_entry xdesktopwaves
+ einstalldocs
+}