summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2021-06-07 10:15:22 -0500
committerBen Kohler <bkohler@gentoo.org>2021-06-08 07:18:00 -0500
commit7f10f39477e20c0bd1951069826659a89d86eff4 (patch)
treeaa9385d437e892714506b63dfa0da1ef191936a9 /x11-misc
parentdev-lang/go: x86 stable wrt bug #794784 (diff)
downloadgentoo-7f10f39477e20c0bd1951069826659a89d86eff4.tar.gz
gentoo-7f10f39477e20c0bd1951069826659a89d86eff4.tar.bz2
gentoo-7f10f39477e20c0bd1951069826659a89d86eff4.zip
x11-misc/i3blocks-contrib: bump to 2.0.0
Package-Manager: Portage-3.0.19, Repoman-3.0.3 Signed-off-by: Ben Kohler <bkohler@gentoo.org>
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/i3blocks-contrib/Manifest1
-rw-r--r--x11-misc/i3blocks-contrib/files/i3blocks-contrib-2.0.0-respect-CFLAGS.patch58
-rw-r--r--x11-misc/i3blocks-contrib/i3blocks-contrib-2.0.0.ebuild52
3 files changed, 111 insertions, 0 deletions
diff --git a/x11-misc/i3blocks-contrib/Manifest b/x11-misc/i3blocks-contrib/Manifest
index 3cc417c32e8a..5cebdc38823a 100644
--- a/x11-misc/i3blocks-contrib/Manifest
+++ b/x11-misc/i3blocks-contrib/Manifest
@@ -1 +1,2 @@
DIST i3blocks-contrib-1.4.0_p20201127.tar.gz 738457 BLAKE2B 1db16c40323d0c191bb44c50d6a66523391adfdf9652976f78238fffe0ee50d99d3bd6fbcfd1a0eeef8308fd466a3eeda479299f462b4d4d31ae2f2bc7ea6b31 SHA512 ff09c7b8e4b630d014f0441342835dbf03642f32de6806a1204eccb6166eade190abe43b331ef72aaa3ba5a77f9690ae8c36a9ef9aa6d312ae5e543a46b99a72
+DIST i3blocks-contrib-2.0.0.tar.gz 840332 BLAKE2B e220566edea4249c25ac80dcba3e24fc37de842049ad072a14fd5003e298ec9a4b4f36cd3937682ab00355b1f1c3fc7ea795ac6593f24aed2438b465ad338d8f SHA512 30cf9297e710a2d685b275d424de817e7940a487c615e64ffaf15e0f90e937bedbd3921dfeece081e32f720b6add92c0790fa7a29e4e8f81f85c3a74cbcea835
diff --git a/x11-misc/i3blocks-contrib/files/i3blocks-contrib-2.0.0-respect-CFLAGS.patch b/x11-misc/i3blocks-contrib/files/i3blocks-contrib-2.0.0-respect-CFLAGS.patch
new file mode 100644
index 000000000000..da72ecd10d81
--- /dev/null
+++ b/x11-misc/i3blocks-contrib/files/i3blocks-contrib-2.0.0-respect-CFLAGS.patch
@@ -0,0 +1,58 @@
+--- a/bandwidth2/Makefile
++++ b/bandwidth2/Makefile
+@@ -1,6 +1,6 @@
+ P=bandwidth2
+ OBJECTS=
+-CFLAGS=-g -Wall -Werror -O2 -std=c11
++CFLAGS ?= -g -Wall -Werror -O2 -std=c11
+ LDLIBS=
+
+ $(P): $(OBJECTS)
+--- a/brightness/Makefile
++++ b/brightness/Makefile
+@@ -16,14 +16,14 @@
+
+ PRG = brightness
+ INCLUDES := -Iinc
+-CFLAGS := $(INCLUDES) $(DEFS) $(WARN_LEVEL) -pipe -O0 -g3 -std=c11
++CFLAGS ?= -pipe -O0 -g3 -std=c11
+
+ debug: CFLAGS += -O0 -g3
+ debug: all
+
+ release: CFLAGS += -O2
+ release: all
+-LDFLAGS = $(LIBS) -ffunction-sections -Wl,--gc-sections
++LDFLAGS ?= -ffunction-sections -Wl,--gc-sections
+
+ SRC_C := $(wildcard *.c) $(wildcard src/*.c)
+ SRC_A := $(wildcard src/*.s)
+@@ -41,7 +41,7 @@
+
+ $(OBJ_DIR)/%.o: %.c
+ @mkdir -p $(@D)
+- $(CC) $(CFLAGS) -o $@ -c $<
++ $(CC) $(CFLAGS) $(INCLUDES) $(DEFS) $(WARN_LEVEL) -o $@ -c $<
+
+ $(BIN_DIR)/$(PRG): $(OBJECTS)
+ @mkdir -p $(@D)
+--- a/cpu_usage2/Makefile
++++ b/cpu_usage2/Makefile
+@@ -1,6 +1,6 @@
+ P=cpu_usage2
+ OBJECTS=
+-CFLAGS=-g -Wall -Werror -O2 -std=gnu11
++CFLAGS ?= -g -Wall -Werror -O2 -std=gnu11
+ LDLIBS=
+
+ $(P): $(OBJECTS)
+--- a/memory2/Makefile
++++ b/memory2/Makefile
+@@ -1,6 +1,6 @@
+ P=memory2
+ OBJECTS=
+-CFLAGS=-g -Wall -Werror -O2 -std=c11
++CFLAGS ?= -g -Wall -Werror -O2 -std=c11
+ LDLIBS=
+
+ $(P): $(OBJECTS)
diff --git a/x11-misc/i3blocks-contrib/i3blocks-contrib-2.0.0.ebuild b/x11-misc/i3blocks-contrib/i3blocks-contrib-2.0.0.ebuild
new file mode 100644
index 000000000000..51f71d6cbffa
--- /dev/null
+++ b/x11-misc/i3blocks-contrib/i3blocks-contrib-2.0.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit optfeature
+
+DESCRIPTION="A set of scripts for i3blocks, contributed by the community"
+HOMEPAGE="https://github.com/vivien/i3blocks-contrib"
+SRC_URI="https://github.com/vivien/i3blocks-contrib/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+DEPEND=""
+RDEPEND="!<x11-misc/i3blocks-1.5
+ >=x11-misc/i3blocks-1.5"
+BDEPEND=""
+
+PATCHES=( "${FILESDIR}"/${P}-respect-CFLAGS.patch )
+
+src_prepare() {
+ sed -i -e '/^$(_BLOCKS):/ s/$/ installdirs/' Makefile
+ default
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX=/usr install
+}
+
+pkg_postinst() {
+ optfeature_header "The following deps may be required for certain ${PN} scripts:"
+ optfeature "backlight" sys-power/acpilight x11-apps/xbacklight
+ optfeature "battery{,2,bar}" sys-power/acpi
+ optfeature "colorpicker" x11-misc/grabc x11-misc/xdotool
+ optfeature "cpu_usage" app-admin/sysstat
+ optfeature "disk-io" app-admin/sysstat
+ optfeature "email" dev-python/keyring gnome-base/gnome-keyring
+ optfeature "eyedropper" media-fonts/fontawesome x11-misc/grabc x11-misc/xclip
+ optfeature "github" dev-util/github-cli media-fonts/fontawesome
+ optfeature "gpu-load" x11-drivers/nvidia-drivers app-misc/radeontop
+ optfeature "i3-focusedwindow" x11-apps/xprop
+ optfeature "kbdd_layout" x11-misc/kbdd
+ optfeature "key_light" sys-power/upower
+ optfeature "kubernetes" sys-cluster/kubectl
+ optfeature "monitor_manager" "dev-lang/python[tk] media-fonts/fontawesome x11-apps/xrandr"
+ optfeature "purpleair" app-misc/jq net-misc/curl
+ optfeature "rofi-calendar" x11-misc/rofi
+ optfeature "ssid and wlan-dbm" net-wireless/iw
+ optfeature "temperature" sys-apps/lm-sensors
+ optfeature "ytdl-mpv" "media-fonts/fontawesome media-video/mpv x11-misc/xclip net-misc/youtube-dl"
+}