summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetrus.Z <silencly07@gmail.com>2021-11-27 12:27:17 +0800
committerFlorian Schmaus <flow@gentoo.org>2021-11-27 08:59:22 +0100
commita343faa3acf56af5d62eb9a4d303e2ad43ee6b6a (patch)
treeeea4f58e692d3282fc7906047827b3de73520c76 /x11-misc
parentdev-python/pip: Stabilize 21.3.1 ALLARCHES, #827590 (diff)
downloadgentoo-a343faa3acf56af5d62eb9a4d303e2ad43ee6b6a.tar.gz
gentoo-a343faa3acf56af5d62eb9a4d303e2ad43ee6b6a.tar.bz2
gentoo-a343faa3acf56af5d62eb9a4d303e2ad43ee6b6a.zip
x11-misc/rofi: version bump to 1.7.1
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Petrus Zhao <petrus.zy.07@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/23094 Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/rofi/Manifest1
-rw-r--r--x11-misc/rofi/rofi-1.7.1.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/x11-misc/rofi/Manifest b/x11-misc/rofi/Manifest
index 6c71b2feda60..0039d1e34e9b 100644
--- a/x11-misc/rofi/Manifest
+++ b/x11-misc/rofi/Manifest
@@ -1,2 +1,3 @@
DIST rofi-1.6.1.tar.gz 569262 BLAKE2B 938b45f8326b5a28e349ac9f7028c476274faa4f932a773acc350d5e1dc8d5c05c7cfb7ec10f1ab5d8c83590074424c3379768671d37ee799d78e508b8c4a4cb SHA512 b54e75818a98fa9262a3016260051837de189d49beff4f4a158cb2e7f41438641377e11d75c164f423e6a86d8b8fca3b76e2630611678525465d06c21b393f60
DIST rofi-1.7.0.tar.gz 902294 BLAKE2B 281f48702650f65e4b037fdbbe6861e173dd3465cf6a80a1d2038271511a9f85ebdb19d8e7a1854f82d52172bbfea6eb1b1685228fc4ff874773033406c9267b SHA512 84a42ecf519c7eed8093c4af3b66731b890939a2bf2a63290e599103705f6bacaba59ade1b8a1bc854f6b767e8d44ee42c20e44f63886bcacbfdbe0468d350b4
+DIST rofi-1.7.1.tar.gz 917891 BLAKE2B 475bcd9d56ba7d3e0f600a342d39a409fdb21da5e8dc54c7008a79d393024668525f170450ebc3cfdd69061d1865520a8854b00d747df98e7e1eb1fd62f95b98 SHA512 741b03ca240f94eb2c91e965b294f7a22e0e76499e9d71827621aa8355f78ed1068a1fe1165ee51b3d2f9f0cfad8814749276e0326eed10bc70e43698e927cba
diff --git a/x11-misc/rofi/rofi-1.7.1.ebuild b/x11-misc/rofi/rofi-1.7.1.ebuild
new file mode 100644
index 000000000000..813b6e07de00
--- /dev/null
+++ b/x11-misc/rofi/rofi-1.7.1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools toolchain-funcs
+
+DESCRIPTION="A window switcher, run dialog and dmenu replacement"
+HOMEPAGE="https://github.com/davatorium/rofi"
+SRC_URI="https://github.com/davatorium/rofi/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="+drun test +windowmode"
+RESTRICT="!test? ( test )"
+
+BDEPEND="virtual/pkgconfig"
+RDEPEND="
+ dev-libs/glib:2
+ gnome-base/librsvg:2
+ media-libs/freetype
+ virtual/jpeg
+ x11-libs/cairo[X,xcb(+)]
+ x11-libs/libXft
+ x11-libs/libXinerama
+ x11-libs/libxcb
+ x11-libs/libxkbcommon[X]
+ x11-libs/pango[X]
+ x11-libs/startup-notification
+ x11-libs/xcb-util
+ x11-libs/xcb-util-wm
+ x11-libs/xcb-util-xrm
+ x11-misc/xkeyboard-config
+"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto
+ test? ( >=dev-libs/check-0.11 )
+"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ tc-export CC
+
+ local myeconfargs=(
+ $(use_enable drun)
+ $(use_enable test check)
+ $(use_enable windowmode)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+pkg_postinst() {
+ for v in ${REPLACING_VERSIONS}; do
+ if ver_test "${v}" -lt 1.7.0; then
+ elog "Rofi 1.7.0 removed the (deprecated) xresources based configuration setup."
+ elog "If you are still using old configuration setup, please convert it to new format manually."
+ elog "The new format configuration can be generated by 'rofi -dump-config > ~/.config/rofi/config.rasi'."
+ elog "For more information, please see https://github.com/davatorium/rofi/releases/tag/1.7.0"
+ fi
+ done
+}