summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2020-05-03 21:23:00 +0200
committerConrad Kostecki <conikost@gentoo.org>2020-05-03 21:23:00 +0200
commit4550530aae0b821499f72fb8d7cf3430b52c734d (patch)
treeef0d4178bbb5b556f47f5b14cd3986431940d4d0 /x11-plugins/pidgin-telegram
parentsys-fs/multipath-tools: fix building against GCC 10 (diff)
downloadgentoo-4550530aae0b821499f72fb8d7cf3430b52c734d.tar.gz
gentoo-4550530aae0b821499f72fb8d7cf3430b52c734d.tar.bz2
gentoo-4550530aae0b821499f72fb8d7cf3430b52c734d.zip
x11-plugins/pidgin-telegram: bump to version 1.4.3
Closes: https://bugs.gentoo.org/720816 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'x11-plugins/pidgin-telegram')
-rw-r--r--x11-plugins/pidgin-telegram/Manifest1
-rw-r--r--x11-plugins/pidgin-telegram/files/pidgin-telegram-1.4.3-change-metadata-location.patch33
-rw-r--r--x11-plugins/pidgin-telegram/pidgin-telegram-1.4.3.ebuild54
3 files changed, 88 insertions, 0 deletions
diff --git a/x11-plugins/pidgin-telegram/Manifest b/x11-plugins/pidgin-telegram/Manifest
index aab75ef96c38..6e29d4800e5c 100644
--- a/x11-plugins/pidgin-telegram/Manifest
+++ b/x11-plugins/pidgin-telegram/Manifest
@@ -1 +1,2 @@
DIST telegram-purple_1.4.2.orig.tar.gz 484790 BLAKE2B d198ce3d1a5f4d226d48b6ff1cdf6f0899a5a1b79ef74c8ac77afa613aae5ec1cf53c8de69cfbab6b2f70df896be0315a90470f2b0da34d1644103be8e7d96ad SHA512 f2f88de8dd4038adaa1a63f2fa3678dd45ddda051be700d6eca563f4bd5b7c8dcb61fdf60bffb01b3fce0ffd01f7b2524686d997bfe4ca8b191cc7b6ce7375a1
+DIST telegram-purple_1.4.3.orig.tar.gz 491997 BLAKE2B 30d42b34525c6553498c67f8a28cfe789442555a3a135a116195edc982611b8ccae6d7c53006358ebdca679258ae6a40b29a1d2ebb764e082bc2ee77d39584db SHA512 697d070da5c6671dd54a1709b37153d4b569ae1cd19d574a2d92a777a89ebd7884596b35829564a7f6fd49104f5d26e35cbe9634f64c678b5f061af8197fba16
diff --git a/x11-plugins/pidgin-telegram/files/pidgin-telegram-1.4.3-change-metadata-location.patch b/x11-plugins/pidgin-telegram/files/pidgin-telegram-1.4.3-change-metadata-location.patch
new file mode 100644
index 000000000000..6971fb8d5075
--- /dev/null
+++ b/x11-plugins/pidgin-telegram/files/pidgin-telegram-1.4.3-change-metadata-location.patch
@@ -0,0 +1,33 @@
+From d18d4c7a46539c37eec30fdbdbb7b56b08469f12 Mon Sep 17 00:00:00 2001
+From: mirabilos <tg@debian.org>
+Date: Sat, 25 Apr 2020 19:29:28 +0200
+Subject: [PATCH] Use newer AppStream metadata location
+
+---
+ Makefile.in | 7 ++++---
+ 1 file changed, 4 insertions(+), 3 deletions(-)
+
+diff --git a/Makefile.in b/Makefile.in
+index 48bfae92..bbaed9df 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -216,15 +216,16 @@ install: noicon_install
+ install -m $(FILE_PERM) imgs/telegram22.png $(DESTDIR)$(DATA_ROOT_DIR_PURPLE)/pixmaps/pidgin/protocols/22/telegram.png
+ mkdir -m $(DIR_PERM) -p $(DESTDIR)$(DATA_ROOT_DIR_PURPLE)/pixmaps/pidgin/protocols/48
+ install -m $(FILE_PERM) imgs/telegram48.png $(DESTDIR)$(DATA_ROOT_DIR_PURPLE)/pixmaps/pidgin/protocols/48/telegram.png
+- mkdir -m $(DIR_PERM) -p $(DESTDIR)$(datarootdir)/appdata
+- install -m $(FILE_PERM) AppStream/telegram-purple.metainfo.xml $(DESTDIR)$(datarootdir)/appdata/telegram-purple.metainfo.xml
++ mkdir -m $(DIR_PERM) -p $(DESTDIR)$(datarootdir)/metainfo
++ install -m $(FILE_PERM) AppStream/telegram-purple.metainfo.xml $(DESTDIR)$(datarootdir)/metainfo/telegram-purple.metainfo.xml
+
+ .PHONY: uninstall
+ uninstall: noicon_uninstall
+ rm -f $(DESTDIR)$(DATA_ROOT_DIR_PURPLE)/pixmaps/pidgin/protocols/16/telegram.png
+ rm -f $(DESTDIR)$(DATA_ROOT_DIR_PURPLE)/pixmaps/pidgin/protocols/22/telegram.png
+ rm -f $(DESTDIR)$(DATA_ROOT_DIR_PURPLE)/pixmaps/pidgin/protocols/48/telegram.png
+- rm -f $(DESTDIR)$(datarootdir)/appdata/telegram-purple.metainfo.xml
++ rm -f $(DESTDIR)$(datarootdir)/appdata/telegram-purple.metainfo.xml # old location
++ rm -f $(DESTDIR)$(datarootdir)/metainfo/telegram-purple.metainfo.xml # new location
+
+
+ ### == The local_{,un}install targets, in case you're not root. == ###
diff --git a/x11-plugins/pidgin-telegram/pidgin-telegram-1.4.3.ebuild b/x11-plugins/pidgin-telegram/pidgin-telegram-1.4.3.ebuild
new file mode 100644
index 000000000000..dbf8c2bf6f00
--- /dev/null
+++ b/x11-plugins/pidgin-telegram/pidgin-telegram-1.4.3.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A libpurple protocol plugin that adds support for the Telegram messenger"
+HOMEPAGE="https://github.com/majn/telegram-purple"
+SRC_URI="https://github.com/majn/telegram-purple/releases/download/v${PV}/telegram-purple_${PV}.orig.tar.gz"
+
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="gcrypt libressl +nls +webp"
+
+RDEPEND="
+ net-im/pidgin
+ sys-libs/zlib:=
+ gcrypt? ( dev-libs/libgcrypt:0= )
+ !gcrypt? (
+ libressl? ( dev-libs/libressl:0= )
+ !libressl? ( dev-libs/openssl:0= )
+ )
+ webp? ( media-libs/libwebp:= )
+"
+
+DEPEND="${RDEPEND}"
+
+BDEPEND="
+ nls? ( sys-devel/gettext )
+ virtual/pkgconfig
+"
+
+S="${WORKDIR}/telegram-purple"
+
+DOCS=( "AUTHORS" "CHANGELOG.md" "HACKING.md" "HACKING.BUILD.md" "README.md" )
+
+PATCHES="${FILESDIR}/${P}-change-metadata-location.patch"
+
+src_prepare() {
+ default
+
+ # Remove '-Werror' to make it compile
+ find -name 'Makefile*' -exec sed -i -e 's/-Werror //' {} + || die
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable gcrypt)
+ $(use_enable nls translation)
+ $(use_enable webp libwebp)
+ )
+
+ econf "${myeconfargs[@]}"
+}