summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-plugins/wmmisc/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-plugins/wmmisc/files')
-rw-r--r--x11-plugins/wmmisc/files/wmmisc-1.1-build.patch48
1 files changed, 48 insertions, 0 deletions
diff --git a/x11-plugins/wmmisc/files/wmmisc-1.1-build.patch b/x11-plugins/wmmisc/files/wmmisc-1.1-build.patch
new file mode 100644
index 000000000000..d42400ab0132
--- /dev/null
+++ b/x11-plugins/wmmisc/files/wmmisc-1.1-build.patch
@@ -0,0 +1,48 @@
+diff -ur wmmisc-1.1.orig/src/general.mk wmmisc-1.1/src/general.mk
+--- wmmisc-1.1.orig/src/general.mk 2006-01-07 19:50:31.000000000 +0200
++++ wmmisc-1.1/src/general.mk 2008-01-16 20:44:59.000000000 +0200
+@@ -16,7 +16,7 @@
+ MANDIR = $(PREFIX)/share/man
+ # Set some destination locations.
+
+-CC = gcc
++CC ?= gcc
+ CXX = g++
+ # Set the compilers.
+
+@@ -45,13 +45,7 @@
+ # Set the assembler and flags.
+
+ LD = ld
+-LDFLAGS = -lm
+-ifeq ($(MODULAR_X),1)
+-LDFLAGS += $(shell pkg-config --libs x11 xpm xext)
+-else
+-LDFLAGS += -L/usr/X11R6/lib -lX11 -lXpm -lXext
+-endif
+-LDFLAGS += -Wl,-O1
++LIBS = -lm -lX11 -lXpm -lXext
+ # Set the linker and flags.
+
+ AR = ar
+@@ -64,7 +58,7 @@
+ ifeq ($(MODULAR_X),1)
+ INCLUDES = $(shell pkg-config --cflags x11 xpm xext)
+ else
+-INCLUDES = -I/usr/X11R6/include
++INCLUDES = -I/usr/include
+ endif
+ INCLUDES += -I.
+ # Set the include locations.
+diff -ur wmmisc-1.1.orig/src/Makefile wmmisc-1.1/src/Makefile
+--- wmmisc-1.1.orig/src/Makefile 2006-01-07 20:45:59.000000000 +0200
++++ wmmisc-1.1/src/Makefile 2008-01-16 20:43:31.000000000 +0200
+@@ -23,7 +23,7 @@
+
+ $(package): $(objects)
+ rm -f $(package)
+- $(CC) $(CFLAGS) -o $(package) $(objects) $(LDFLAGS)
++ $(CC) $(LDFLAGS) -o $(package) $(objects) $(LIBS)
+
+ wmgeneral.o: wmgeneral.c wmgeneral.h
+ rm -f wmgeneral.o