summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-plugins/wmmp
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-plugins/wmmp')
-rw-r--r--x11-plugins/wmmp/Manifest1
-rw-r--r--x11-plugins/wmmp/metadata.xml8
-rw-r--r--x11-plugins/wmmp/wmmp-0.10.0-r1.ebuild34
3 files changed, 43 insertions, 0 deletions
diff --git a/x11-plugins/wmmp/Manifest b/x11-plugins/wmmp/Manifest
new file mode 100644
index 000000000000..5785390496d2
--- /dev/null
+++ b/x11-plugins/wmmp/Manifest
@@ -0,0 +1 @@
+DIST WMmp-0.10.0.tar.gz 228560 SHA256 918ea42dc16fa5f3456cc28f38d286e948de30d1e5b5e00da2cfb45cf08c8d04
diff --git a/x11-plugins/wmmp/metadata.xml b/x11-plugins/wmmp/metadata.xml
new file mode 100644
index 000000000000..7c23b8f8736c
--- /dev/null
+++ b/x11-plugins/wmmp/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+ <upstream>
+ <remote-id type="sourceforge">musicpd</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/x11-plugins/wmmp/wmmp-0.10.0-r1.ebuild b/x11-plugins/wmmp/wmmp-0.10.0-r1.ebuild
new file mode 100644
index 000000000000..6b1dd077501e
--- /dev/null
+++ b/x11-plugins/wmmp/wmmp-0.10.0-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+MY_P=${P/wm/WM}
+
+DESCRIPTION="A Window Maker dock app client for Music Player Daemon(media-sound/mpd)"
+HOMEPAGE="http://mpd.wikia.com/wiki/Client:WMmp"
+SRC_URI="mirror://sourceforge/musicpd/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 sparc x86"
+IUSE=""
+
+RDEPEND="x11-libs/libXext
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_configure() {
+ econf --with-default-port=6600
+}
+
+src_compile() {
+ emake LDFLAGS="${LDFLAGS}" || die "make failed"
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog README THANKS TODO
+}