summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-19 08:01:54 +0100
committerSam James <sam@gentoo.org>2021-04-19 20:10:27 +0100
commit2b8de9ab38a948473222c55110b42997e65dea90 (patch)
tree2714938b0cd8feee5e21811417856fe2e5af0d7b /x11-plugins
parentx11-misc/skippy: respect PKG_CONFIG (diff)
downloadgentoo-2b8de9ab38a948473222c55110b42997e65dea90.tar.gz
gentoo-2b8de9ab38a948473222c55110b42997e65dea90.tar.bz2
gentoo-2b8de9ab38a948473222c55110b42997e65dea90.zip
x11-plugins/docker: respect PKG_CONFIG
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/docker/docker-1.5-r2.ebuild11
-rw-r--r--x11-plugins/docker/files/docker-1.5-makefile_rename.patch6
2 files changed, 10 insertions, 7 deletions
diff --git a/x11-plugins/docker/docker-1.5-r2.ebuild b/x11-plugins/docker/docker-1.5-r2.ebuild
index 6215a15a0c5e..9f742ebe552d 100644
--- a/x11-plugins/docker/docker-1.5-r2.ebuild
+++ b/x11-plugins/docker/docker-1.5-r2.ebuild
@@ -2,6 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+
inherit toolchain-funcs
DESCRIPTION="Openbox app which acts as a system tray for KDE and GNOME2"
@@ -11,16 +12,18 @@ SRC_URI="https://icculus.org/openbox/2/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha amd64 ppc ~ppc64 ~sparc x86"
-IUSE=""
RDEPEND=">=dev-libs/glib-2.0.4
x11-libs/libX11"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
-PATCHES=( "${FILESDIR}/${P}-makefile_rename.patch" )
+PATCHES=(
+ "${FILESDIR}"/${P}-makefile_rename.patch
+)
src_compile() {
+ tc-export PKG_CONFIG
emake CC="$(tc-getCC)"
}
diff --git a/x11-plugins/docker/files/docker-1.5-makefile_rename.patch b/x11-plugins/docker/files/docker-1.5-makefile_rename.patch
index cf20a9135aa5..36cc92b00bf0 100644
--- a/x11-plugins/docker/files/docker-1.5-makefile_rename.patch
+++ b/x11-plugins/docker/files/docker-1.5-makefile_rename.patch
@@ -1,5 +1,5 @@
---- a/Makefile 2015-01-19 20:10:47.762522964 +0100
-+++ b/Makefile 2015-01-19 20:11:11.463545692 +0100
+--- a/Makefile
++++ b/Makefile
@@ -5,12 +5,10 @@
#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#
@@ -33,7 +33,7 @@
- $(CC) $(CFLAGS) -L$(XLIBPATH) -lX11 \
- `pkg-config --libs glib-2.0` $^ -o $@
+ $(CC) $(LDFLAGS) $(CFLAGS) $^ -lX11 \
-+ `pkg-config --libs glib-2.0` -o $@
++ `${PKG_CONFIG} --libs glib-2.0` -o $@
%.o: %.c
$(CC) -c $(CFLAGS) `pkg-config --cflags glib-2.0` $<