summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAzamat H. Hackimov <azamat.hackimov@gmail.com>2020-09-23 02:38:33 +0300
committerBernard Cafarelli <voyageur@gentoo.org>2020-09-23 10:32:52 +0200
commit4f0fbba4e034b3970664df17bc3d5fa0cd2dc099 (patch)
treee1335145822aede1413b959c7082e622883cf951 /x11-plugins
parentnet-fs/samba: Security bump to versions 4.11.13, 4.12.7 and 4.13.0 (diff)
downloadgentoo-4f0fbba4e034b3970664df17bc3d5fa0cd2dc099.tar.gz
gentoo-4f0fbba4e034b3970664df17bc3d5fa0cd2dc099.tar.bz2
gentoo-4f0fbba4e034b3970664df17bc3d5fa0cd2dc099.zip
x11-plugins/wmcpuwatch: update ebuild
Updated SRC_URI and HOMEPAGE, migrated to EAPI=7 and cmake.eclass. Closes: https://bugs.gentoo.org/739810 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Azamat H. Hackimov <azamat.hackimov@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/17641 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/wmcpuwatch/metadata.xml3
-rw-r--r--x11-plugins/wmcpuwatch/wmcpuwatch-0.2-r1.ebuild18
2 files changed, 9 insertions, 12 deletions
diff --git a/x11-plugins/wmcpuwatch/metadata.xml b/x11-plugins/wmcpuwatch/metadata.xml
index 00a3935917ee..d34af4773b12 100644
--- a/x11-plugins/wmcpuwatch/metadata.xml
+++ b/x11-plugins/wmcpuwatch/metadata.xml
@@ -12,7 +12,4 @@ It is a fork of wmmon. wmmon shows the load of up to 10 CPUs. With a little twea
wmcpuwatch now shows the load of all CPUs in the lower frame which allows 40 CPUs at max.
</longdescription>
-<upstream>
- <remote-id type="bitbucket">StarFire/wmcpuwatch</remote-id>
-</upstream>
</pkgmetadata>
diff --git a/x11-plugins/wmcpuwatch/wmcpuwatch-0.2-r1.ebuild b/x11-plugins/wmcpuwatch/wmcpuwatch-0.2-r1.ebuild
index e758ba522eee..0edf74c5ae37 100644
--- a/x11-plugins/wmcpuwatch/wmcpuwatch-0.2-r1.ebuild
+++ b/x11-plugins/wmcpuwatch/wmcpuwatch-0.2-r1.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-inherit cmake-utils
+EAPI=7
+inherit cmake
DESCRIPTION="dockapp showing the load of every logical CPU on the system"
-HOMEPAGE="https://bitbucket.org/StarFire/wmcpuwatch"
-SRC_URI="https://bitbucket.org/StarFire/${PN}/downloads/${P}.tar.bz2"
+HOMEPAGE="https://bitbucket-archive.softwareheritage.org/projects/st/StarFire/wmcpuwatch.html"
+SRC_URI="https://bitbucket-archive.softwareheritage.org/static/83/8395d160-de4b-42d6-a7d9-939eade4f58a/attachments/${P}.tar.bz2"
LICENSE="GPL-3+"
SLOT="0"
@@ -14,18 +14,18 @@ KEYWORDS="~amd64 ~x86"
IUSE="doc"
RDEPEND=">=x11-libs/libdockapp-0.7:="
-DEPEND="${RDEPEND}
- doc? ( app-doc/doxygen[dot] )"
+DEPEND="${RDEPEND}"
+BDEPEND="doc? ( app-doc/doxygen[dot] )"
DOCS=( ChangeLog README.md )
PATCHES=( "${FILESDIR}"/${P}-cmake.patch )
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
use doc || sed -e "s/add_subdirectory(doc)//" -i CMakeLists.txt || die
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
use doc && dodoc -r "${BUILD_DIR}"/doc/html
}