summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-07 06:15:01 +0100
committerSam James <sam@gentoo.org>2021-04-13 00:26:30 +0000
commit5d586db58f70f21c44b84e7ef9e9051be8502ef7 (patch)
tree4dcbebb9512d4444f8bb749ca286073ed31553f3 /x11-plugins
parentsys-cluster/ipvsadm: call pkg-config via toolchain-funcs.eclass helper (diff)
downloadgentoo-5d586db58f70f21c44b84e7ef9e9051be8502ef7.tar.gz
gentoo-5d586db58f70f21c44b84e7ef9e9051be8502ef7.tar.bz2
gentoo-5d586db58f70f21c44b84e7ef9e9051be8502ef7.zip
x11-plugins/pidgin-xmpp-receipts: call pkg-config via toolchain-funcs.eclass helper
This ensures we call the correct pkg-config in e.g. cross. Package-Manager: Portage-3.0.14-prefix, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/pidgin-xmpp-receipts/pidgin-xmpp-receipts-0.8.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/x11-plugins/pidgin-xmpp-receipts/pidgin-xmpp-receipts-0.8.ebuild b/x11-plugins/pidgin-xmpp-receipts/pidgin-xmpp-receipts-0.8.ebuild
index 601b7d04adf2..f16b5e0b5d7c 100644
--- a/x11-plugins/pidgin-xmpp-receipts/pidgin-xmpp-receipts-0.8.ebuild
+++ b/x11-plugins/pidgin-xmpp-receipts/pidgin-xmpp-receipts-0.8.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -19,12 +19,12 @@ DEPEND="${RDEPEND}
virtual/pkgconfig"
src_compile() {
- GTK_PIDGIN_INCLUDES=$(pkg-config --cflags gtk+-2.0 pidgin)
+ GTK_PIDGIN_INCLUDES=$($(tc-getPKG_CONFIG) --cflags gtk+-2.0 pidgin)
$(tc-getCC) ${LDFLAGS} -shared ${CFLAGS} -fpic ${GTK_PIDGIN_INCLUDES} -o ${PN/pidgin-/}.so ${PN/pidgin-/}.c || die
}
src_install() {
- PLUGIN_DIR_PIDGIN=$(pkg-config --variable=plugindir pidgin)
+ PLUGIN_DIR_PIDGIN=$($(tc-getPKG_CONFIG) --variable=plugindir pidgin)
dodir "${PLUGIN_DIR_PIDGIN}"
insinto "${PLUGIN_DIR_PIDGIN}"
doins ${PN/pidgin-/}.so