summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2019-07-30 22:26:39 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2019-07-30 22:47:03 +0200
commit65481633956ba3274fb8c0ca97f8185658039cbd (patch)
tree333e44625eb3387a747dd1c6385ade3305252ef7 /x11-plugins
parentx11-plugins/wmbiff: drop old (diff)
downloadgentoo-65481633956ba3274fb8c0ca97f8185658039cbd.tar.gz
gentoo-65481633956ba3274fb8c0ca97f8185658039cbd.tar.bz2
gentoo-65481633956ba3274fb8c0ca97f8185658039cbd.zip
x11-plugins/wmbiff: 0.4.34 bump
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/wmbiff/Manifest1
-rw-r--r--x11-plugins/wmbiff/wmbiff-0.4.34.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/x11-plugins/wmbiff/Manifest b/x11-plugins/wmbiff/Manifest
index 14b8a39df30d..4e6a5b024cde 100644
--- a/x11-plugins/wmbiff/Manifest
+++ b/x11-plugins/wmbiff/Manifest
@@ -1,2 +1,3 @@
DIST wmbiff-0.4.28.tar.gz 111398 BLAKE2B 39ba4dbf50639b02c8969ae72b696fa83353ec3dcd46802f8333eb597f068d3d0d209f39a352a8f53830695c19c897b7d6f970c5362c2910128b80b0cdb24d32 SHA512 a17fd4b4c3de09a907b7ffccc50f4560a7fddd5cb4dd01c72460806dc55259ba0b587d75f7505171a2a833f6735ddc4ded0a484d4227bfd552cc7343d79d7720
DIST wmbiff-0.4.33.tar.gz 266114 BLAKE2B 06e5e454a2f8e78203dec66cc274d983e8ec1c0dc7bb82db4ec3c42a8671f0f7a399b79fc94f45e595dcd6fe56c87426dce3900f8fc0f12fbc704ad196390dc7 SHA512 9b88b5929e9234d17bfa5022eb95cbca1720c724827e078dbd44c0bcff77f386b7692a6576b3a96bb1f5fab602c274b3335c71543e5ad053c1cc476d114f818c
+DIST wmbiff-0.4.34.tar.gz 265020 BLAKE2B af4160b983ff46557c78f2f363f8a6b73841050a99d89d953ba4bd493bf016da00457c38bb8130e329f742ad244d62df4b47519b90ee0e8858c88acb0b1184ab SHA512 28a80b635cf6ef03fe688686dd52ed965c2bb17d009aa904967b381f6717ad99014c2c514e9eb973fb2ea83c99a388beb9568f4ac940cbd4631f61c8a13f8cf4
diff --git a/x11-plugins/wmbiff/wmbiff-0.4.34.ebuild b/x11-plugins/wmbiff/wmbiff-0.4.34.ebuild
new file mode 100644
index 000000000000..4c3609d57973
--- /dev/null
+++ b/x11-plugins/wmbiff/wmbiff-0.4.34.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools eutils
+
+DESCRIPTION="WMBiff is a dock applet for WindowMaker which can monitor up to 5 mailboxes"
+HOMEPAGE="https://www.dockapps.net/wmbiff"
+SRC_URI="https://www.dockapps.net/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="crypt"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm
+ crypt? (
+ >=dev-libs/libgcrypt-1.2.1:0
+ >=net-libs/gnutls-2.2.0
+ )"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+BDEPEND="virtual/pkgconfig"
+
+DOCS="ChangeLog FAQ NEWS README TODO wmbiff/sample.wmbiffrc"
+
+src_prepare() {
+ default
+ eapply "${FILESDIR}"/${PN}-0.4.27-invalid-strncpy.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable crypt crypto)
+}