summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2023-03-10 12:25:42 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2023-03-10 12:40:47 +0100
commita3e4abce155557ba25b8eb0bc9ab68011f924f0f (patch)
tree87def653f5285a3ac398d8ffa87b48f143768d08 /x11-plugins
parentx11-plugins/wmapmload: fix implicit function declarations in configure (diff)
downloadgentoo-a3e4abce155557ba25b8eb0bc9ab68011f924f0f.tar.gz
gentoo-a3e4abce155557ba25b8eb0bc9ab68011f924f0f.tar.bz2
gentoo-a3e4abce155557ba25b8eb0bc9ab68011f924f0f.zip
x11-plugins/wmacpiload-ac: fix implicit function declarations in configure
Closes: https://bugs.gentoo.org/898928 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/wmacpiload-ac/wmacpiload-ac-0.2.0-r1.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/x11-plugins/wmacpiload-ac/wmacpiload-ac-0.2.0-r1.ebuild b/x11-plugins/wmacpiload-ac/wmacpiload-ac-0.2.0-r1.ebuild
index 887bab550edc..4e2f936ff6f6 100644
--- a/x11-plugins/wmacpiload-ac/wmacpiload-ac-0.2.0-r1.ebuild
+++ b/x11-plugins/wmacpiload-ac/wmacpiload-ac-0.2.0-r1.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+inherit autotools
+
MY_P=${P/-ac}
DESCRIPTION="WMACPILoad based dockapp to monitor CPU temp and battery time on ACPI kernels"
@@ -30,6 +32,11 @@ PATCHES=(
"${FILESDIR}/${PN}-acpi-fix-battery-unit.patch"
)
+src_prepare() {
+ default
+ eautoreconf
+}
+
src_configure() {
econf $(use_enable debug)
}