summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2015-08-21 23:26:53 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2015-08-23 21:14:39 +0200
commitbdba47c8b236b58ea8ad2106f5fd539a110f06ce (patch)
tree53af11b3651682a7b37be32e41a611a8a074769f /x11-plugins
parentwww-client/chromium: Beta channel bump (45.0.2454.46) (diff)
downloadgentoo-bdba47c8b236b58ea8ad2106f5fd539a110f06ce.tar.gz
gentoo-bdba47c8b236b58ea8ad2106f5fd539a110f06ce.tar.bz2
gentoo-bdba47c8b236b58ea8ad2106f5fd539a110f06ce.zip
x11-plugins/wmcms: EAPI bump, fix compilation with new libdockapp
Fixes bug #558362 by Toralf Förster <toralf.foerster@gmx.de> Package-Manager: portage-2.2.20.1
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/wmcms/Manifest2
-rw-r--r--x11-plugins/wmcms/wmcms-0.3.5-r1.ebuild5
-rw-r--r--x11-plugins/wmcms/wmcms-0.3.5-r2.ebuild34
3 files changed, 38 insertions, 3 deletions
diff --git a/x11-plugins/wmcms/Manifest b/x11-plugins/wmcms/Manifest
index 2d52b490a2e8..d70557eb8ec2 100644
--- a/x11-plugins/wmcms/Manifest
+++ b/x11-plugins/wmcms/Manifest
@@ -1 +1 @@
-DIST wmcms-0.3.5.tar.bz2 18920 SHA256 9b47672b3fa5a2474fe26dabb0e95030a4792766ce6577391ab1cd784f21d09b
+DIST wmcms-0.3.5.tar.bz2 18920 SHA256 9b47672b3fa5a2474fe26dabb0e95030a4792766ce6577391ab1cd784f21d09b SHA512 f2852f8b81e1eac0396ca0964590fdf2560b97b5ee5266288641487ddfe77879e552c5e77e42f398ecf974a9030dd147ad64eedf7f7c32af53d69be31c8598fd WHIRLPOOL 5271e3a7c42745ea8f0b2a27dcba8d717e9b3e9243a862975d1f6b6f8430a0a92a80d3eaa0695ad8ba620a4b9d32c5a692c6178780ebde1168ff30bc5b478a84
diff --git a/x11-plugins/wmcms/wmcms-0.3.5-r1.ebuild b/x11-plugins/wmcms/wmcms-0.3.5-r1.ebuild
index 7846476faadb..42e7f824372f 100644
--- a/x11-plugins/wmcms/wmcms-0.3.5-r1.ebuild
+++ b/x11-plugins/wmcms/wmcms-0.3.5-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -13,7 +13,8 @@ SLOT="0"
KEYWORDS="amd64 ppc ppc64 sparc x86"
IUSE=""
-DEPEND="x11-libs/libdockapp"
+RDEPEND="<x11-libs/libdockapp-0.7"
+DEPEND="${RDEPEND}"
src_unpack() {
unpack ${A}
diff --git a/x11-plugins/wmcms/wmcms-0.3.5-r2.ebuild b/x11-plugins/wmcms/wmcms-0.3.5-r2.ebuild
new file mode 100644
index 000000000000..cbb2f6dcddf0
--- /dev/null
+++ b/x11-plugins/wmcms/wmcms-0.3.5-r2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils
+
+DESCRIPTION="WindowMaker CPU and Memory Usage Monitor Dock App"
+SRC_URI="http://orbita.starmedia.com/~neofpo/files/${P}.tar.bz2"
+HOMEPAGE="http://orbita.starmedia.com/~neofpo/wmcms.html"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND=">=x11-libs/libdockapp-0.7:="
+
+src_prepare() {
+ epatch "${FILESDIR}"/wmcms-0.3.5-s4t4n.patch
+
+ # Respect LDFLAGS, see bug #335031
+ sed -e 's/ -o wmcms/ ${LDFLAGS} -o wmcms/' -i Makefile || die
+
+ sed -e 's#<dockapp.h>#<libdockapp/dockapp.h>#' -i *.c || die
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ dobin wmcms
+}