summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2017-03-14 01:58:49 +0100
committerSebastian Pipping <sping@gentoo.org>2017-03-14 02:02:11 +0100
commit988726332894e6831c510e5f521d7caadfc70d0c (patch)
tree37da13c3aa73e43ac76516bdead87640dfd8c255 /x11-terms/tilda
parentapp-text/tesseract: 3.05.00 bump (diff)
downloadgentoo-988726332894e6831c510e5f521d7caadfc70d0c.tar.gz
gentoo-988726332894e6831c510e5f521d7caadfc70d0c.tar.bz2
gentoo-988726332894e6831c510e5f521d7caadfc70d0c.zip
x11-terms/tilda: Fix desktop icon
Package-Manager: Portage-2.3.4, Repoman-2.3.2
Diffstat (limited to 'x11-terms/tilda')
-rw-r--r--x11-terms/tilda/files/tilda-0.9.6-makefile.patch24
-rw-r--r--x11-terms/tilda/tilda-0.9.6-r1.ebuild31
2 files changed, 55 insertions, 0 deletions
diff --git a/x11-terms/tilda/files/tilda-0.9.6-makefile.patch b/x11-terms/tilda/files/tilda-0.9.6-makefile.patch
new file mode 100644
index 000000000000..cfb86fd0c522
--- /dev/null
+++ b/x11-terms/tilda/files/tilda-0.9.6-makefile.patch
@@ -0,0 +1,24 @@
+From 6ee8cb9e2d19b7b1e7b80f5f26557aaac1a91151 Mon Sep 17 00:00:00 2001
+From: Sebastian Pipping <sebastian@pipping.org>
+Date: Tue, 14 Mar 2017 01:40:28 +0100
+Subject: [PATCH] Make .desktop file use actual icon location
+
+---
+ Makefile.am | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index 0378052..074837b 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -27,6 +27,6 @@ EXTRA_DIST = tilda.desktop.in tilda.png tilda.glade
+
+ tilda.desktop: tilda.desktop.in
+ sed -e 's|\@BINDIR\@|$(bindir)|' \
+- -e 's|\@PIXMAPSDIR\@|$(datadir)/applications|' $< > $@
++ -e 's|\@PIXMAPSDIR\@|$(Pixmapsdir)|' $< > $@
+
+ ACLOCAL_AMFLAGS = -I m4
+--
+2.12.0
+
diff --git a/x11-terms/tilda/tilda-0.9.6-r1.ebuild b/x11-terms/tilda/tilda-0.9.6-r1.ebuild
new file mode 100644
index 000000000000..85cda089c8c0
--- /dev/null
+++ b/x11-terms/tilda/tilda-0.9.6-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools eutils
+
+DESCRIPTION="A drop down terminal, similar to the consoles found in first person shooters"
+HOMEPAGE="http://tilda.sourceforge.net"
+SRC_URI="mirror://sourceforge/tilda/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="x11-libs/vte:0
+ >=dev-libs/glib-2.8.4:2
+ dev-libs/confuse
+ gnome-base/libglade"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.9.6-gdk_resources.patch
+ epatch "${FILESDIR}"/${PN}-0.9.6-glib-single-include.patch
+ epatch "${FILESDIR}"/${PN}-0.9.6-makefile.patch
+ eapply_user
+
+ eautoreconf
+}