summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2020-09-23 11:05:54 +0200
committerLars Wendler <polynomial-c@gentoo.org>2020-09-23 11:06:42 +0200
commit6754b12d68cd6a1360f03b474306e460367b6aa8 (patch)
tree5cf8568efe0398a04f01e36aad904ec843c13b3b /x11-terms/xterm
parentdev-util/cmake: Bump to version 3.18.3 (diff)
downloadgentoo-6754b12d68cd6a1360f03b474306e460367b6aa8.tar.gz
gentoo-6754b12d68cd6a1360f03b474306e460367b6aa8.tar.bz2
gentoo-6754b12d68cd6a1360f03b474306e460367b6aa8.zip
x11-terms/xterm: Bump to version 360
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'x11-terms/xterm')
-rw-r--r--x11-terms/xterm/Manifest1
-rw-r--r--x11-terms/xterm/xterm-360.ebuild99
2 files changed, 100 insertions, 0 deletions
diff --git a/x11-terms/xterm/Manifest b/x11-terms/xterm/Manifest
index 7777f06599f6..b41f70a332e0 100644
--- a/x11-terms/xterm/Manifest
+++ b/x11-terms/xterm/Manifest
@@ -2,3 +2,4 @@ DIST xterm-337.tgz 1336781 BLAKE2B 6878154cc5d2f8547b8b8ffac0bff7603dce6d58c294b
DIST xterm-351.tgz 1401009 BLAKE2B df32425affce33deb199710be118e90da7b1975882aaf92ff1ad5e976ac18f280cf7d72362d82c0ff9f9530d8da3ba133e345ff9de7f0ac0a2134200c9cc87e6 SHA512 941507be19ad062b39c57288c6e28a17f0ceba090a2d1c3f626f638e5333ca9b4c762fe2fbc42908adf7854b00d9a98cb6eb7481dfa50fd0125459f8ca385c00
DIST xterm-353.tgz 1407183 BLAKE2B be5efe091a9b9511b264eed0c12568d0d92ac7189c883d62d21124ed45a5d229a3a063496f7bbf08e593bfdc5652c5d153d87f8313a9b2901da8e15483904565 SHA512 2ea63858ec069a769f0a25a159d17099044686e20649233631244fed29440fa8beebbd0dd8ccaf4260fb3d26996a49013eeeea7e0c98860e00d2e657019e2611
DIST xterm-357.tgz 1422256 BLAKE2B fb3f090c296b7f6063206538a2e7b38a9953433a029a531ebc2efbf7c9a6822a51f1bb6475ad2494279079b332de1fb15c262f51545f3d37ebc1b19fef9f341b SHA512 a4e3998496fe202835e97fef50eb608cbb0345d8f503dd4d629a1d313664b2c536e97e7eafdf9d346df87e31822f5cf6f78dc66833b0fe01b6d79dd7c58dc751
+DIST xterm-360.tgz 1431491 BLAKE2B 2afa7f9cb93136ad0bfb29e0862642221b4b1f583caa5890bbdd4c0a2370266f7c7f19419e3bb82f93d854b3c5703ddd30b896dcb5069873458ac3483dbd7073 SHA512 ffca51e21584e4b84b271a555bead45df1759a9e353d776fd7d8736fb001b71cfa14dc85336c01c304b4fc98297523b1a943792da73b453e1810b890671bb607
diff --git a/x11-terms/xterm/xterm-360.ebuild b/x11-terms/xterm/xterm-360.ebuild
new file mode 100644
index 000000000000..ace98c8c3afe
--- /dev/null
+++ b/x11-terms/xterm/xterm-360.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop flag-o-matic multilib
+
+DESCRIPTION="Terminal Emulator for X Windows"
+HOMEPAGE="https://invisible-island.net/xterm/"
+SRC_URI="ftp://ftp.invisible-island.net/${PN}/${P}.tgz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="+openpty sixel toolbar truetype unicode Xaw3d xinerama"
+
+BDEPEND="virtual/pkgconfig
+ x11-base/xorg-proto"
+DEPEND="kernel_linux? ( sys-libs/libutempter )
+ kernel_FreeBSD? ( sys-libs/libutempter )
+ media-libs/fontconfig:1.0
+ >=sys-libs/ncurses-5.7-r7:0=
+ x11-apps/xmessage
+ x11-libs/libICE
+ x11-libs/libX11
+ x11-libs/libXaw
+ x11-libs/libXft
+ x11-libs/libxkbfile
+ x11-libs/libXmu
+ x11-libs/libXrender
+ x11-libs/libXt
+ unicode? ( x11-apps/luit )
+ Xaw3d? ( x11-libs/libXaw3d )
+ xinerama? ( x11-libs/libXinerama )"
+RDEPEND="${DEPEND}
+ media-fonts/font-misc-misc
+ x11-apps/rgb"
+
+DOCS=( README{,.i18n} ctlseqs.txt )
+
+pkg_setup() {
+ DEFAULTS_DIR="${EPREFIX}"/usr/share/X11/app-defaults
+}
+
+src_configure() {
+ # 454736
+ # Workaround for ncurses[tinfo] until upstream fixes their buildsystem using
+ # something sane like pkg-config or ncurses5-config and stops guessing libs
+ # Everything gets linked against ncurses anyways, so don't shout
+ append-libs $(pkg-config --libs ncurses)
+
+ local myeconfargs=(
+ --disable-full-tgetent
+ --disable-imake
+ --disable-setgid
+ --disable-setuid
+ --enable-256-color
+ --enable-broken-osc
+ --enable-broken-st
+ --enable-dabbrev
+ --enable-exec-xterm
+ --enable-i18n
+ --enable-load-vt-fonts
+ --enable-logging
+ --enable-screen-dumps
+ --enable-warnings
+ --enable-wide-chars
+ --libdir="${EPREFIX}"/etc
+ --with-app-defaults="${DEFAULTS_DIR}"
+ --with-utempter
+ --with-x
+ $(use_enable openpty)
+ $(use_enable sixel sixel-graphics)
+ $(use_enable toolbar)
+ $(use_enable truetype freetype)
+ $(use_enable unicode luit)
+ $(use_enable unicode mini-luit)
+ $(use_with Xaw3d)
+ $(use_with xinerama)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ docinto html
+ dodoc xterm.log.html
+ domenu *.desktop
+
+ # Fix permissions -- it grabs them from live system, and they can
+ # be suid or sgid like they were in pre-unix98 pty or pre-utempter days,
+ # respectively (#69510).
+ # (info from Thomas Dickey) - Donnie Berkholz <spyderous@gentoo.org>
+ fperms 0755 /usr/bin/xterm
+
+ # restore the navy blue
+ sed -i -e 's:blue2$:blue:' "${ED}${DEFAULTS_DIR}"/XTerm-color || die
+}