summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2018-03-20 22:05:54 +0900
committerAkinori Hattori <hattya@gentoo.org>2018-03-20 22:06:57 +0900
commit8daabb4f731a4ddb7912c7e921b7308f141b5758 (patch)
tree018f385cc8c01bf5c090dbd7d6ea49fca3547cdc /x11-terms
parentx11-terms/mlterm: drop old (diff)
downloadgentoo-8daabb4f731a4ddb7912c7e921b7308f141b5758.tar.gz
gentoo-8daabb4f731a4ddb7912c7e921b7308f141b5758.tar.bz2
gentoo-8daabb4f731a4ddb7912c7e921b7308f141b5758.zip
x11-terms/mlterm: new upstream release
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/mlterm/Manifest1
-rw-r--r--x11-terms/mlterm/mlterm-3.8.5.ebuild127
2 files changed, 128 insertions, 0 deletions
diff --git a/x11-terms/mlterm/Manifest b/x11-terms/mlterm/Manifest
index 2d788f8d2e45..11e2e8ba1b6c 100644
--- a/x11-terms/mlterm/Manifest
+++ b/x11-terms/mlterm/Manifest
@@ -1,2 +1,3 @@
DIST mlterm-3.8.0.tar.gz 3756779 BLAKE2B 401695dceb90357f0822346e3d4e00360faded3729fb091b217ed232909f1e2e60bfb554e50d162f38115e77b425041f711f136756fbb2a349512c98dc538be4 SHA512 86d163aaf24668dea77e54ff775cb448c6c699bcc82e1d84fe9a9fbed90d9c834ee3e61348de77713b2dbd229b37b76d2be817d788710f224cd5c53e7f93049f
DIST mlterm-3.8.4.tar.gz 3881872 BLAKE2B 647810585b0143d0f680c99032cf478e02047acc80086b4c9cbadc59df49e09ba1626ee2ff2c8a1842c68047632c61001d31f7282d9eb8619f0260de7f0bb976 SHA512 6afe0a60001f180df18f2d2ad5e2954a1d9423313d7784eb0cf6a9736c6a62545f461d8e3d079aa1f43eb5f27f4b0c060a7da54e08bf758b283005b16aa1e5cd
+DIST mlterm-3.8.5.tar.gz 3928532 BLAKE2B e5d13ea0e67d4bce1470f585b419cb073552d68115f08b5051f66a90a9887ffba2794829be52d852ef2ed36502a3ef8ea8235b2b668804599efb74f65392b4e6 SHA512 c43a121ed6572bdd4501a6b27f54df65ff2c09682485c7902c5cbd6b4be64f35efcf8cce3923d77afc412d681a390edc240a6a2503478ea97e0c4953e0b807a7
diff --git a/x11-terms/mlterm/mlterm-3.8.5.ebuild b/x11-terms/mlterm/mlterm-3.8.5.ebuild
new file mode 100644
index 000000000000..b196e452cc99
--- /dev/null
+++ b/x11-terms/mlterm/mlterm-3.8.5.ebuild
@@ -0,0 +1,127 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit eutils
+
+DESCRIPTION="A multi-lingual terminal emulator"
+HOMEPAGE="http://mlterm.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="bidi cairo canna debug fbcon fcitx freewnn gtk gtk2 harfbuzz ibus libssh2 m17n-lib nls regis scim skk static-libs uim utempter xft"
+
+RDEPEND="x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ bidi? ( dev-libs/fribidi )
+ cairo? ( x11-libs/cairo[X(+)] )
+ canna? ( app-i18n/canna )
+ fbcon? ( media-fonts/unifont )
+ fcitx? ( app-i18n/fcitx )
+ freewnn? ( app-i18n/freewnn )
+ gtk? (
+ gtk2? ( x11-libs/gtk+:2 )
+ !gtk2? ( x11-libs/gtk+:3 )
+ )
+ harfbuzz? ( media-libs/harfbuzz[truetype(+)] )
+ ibus? ( app-i18n/ibus )
+ libssh2? ( net-libs/libssh2 )
+ m17n-lib? ( dev-libs/m17n-lib )
+ nls? ( virtual/libintl )
+ regis? (
+ || (
+ media-libs/sdl-ttf
+ media-libs/sdl2-ttf
+ )
+ )
+ scim? ( app-i18n/scim )
+ skk? (
+ || (
+ virtual/skkserv
+ app-i18n/skk-jisyo
+ )
+ )
+ uim? ( app-i18n/uim )
+ utempter? ( sys-libs/libutempter )
+ xft? ( x11-libs/libXft )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+REQUIRED_USE="gtk2? ( gtk )"
+
+PATCHES=( "${FILESDIR}"/${PN}-font.patch )
+DOCS=( doc/{en,ja} )
+
+src_prepare() {
+ # workaround for USE=fb
+ sed -i "/^[[:space:]]*main /s/\(main man\)/libvterm \1/" configure
+ # default config
+ sed -i \
+ -e "/ icon_path =/aicon_path = ${EPREFIX}/usr/share/pixmaps/${PN}-icon.svg" \
+ -e "/ scrollbar_view_name =/ascrollbar_view_name = sample" \
+ etc/main
+
+ default
+}
+
+src_configure() {
+ local myconf=(
+ $(use_enable bidi fribidi)
+ $(use_enable canna)
+ $(use_enable debug)
+ $(use_enable fcitx)
+ $(use_enable freewnn wnn)
+ $(use_enable harfbuzz otl)
+ $(use_enable ibus)
+ $(use_enable libssh2 ssh2)
+ $(use_enable m17n-lib m17nlib)
+ $(use_enable nls)
+ $(use_enable scim)
+ $(use_enable skk)
+ $(use_enable uim)
+ $(use_enable utempter utmp)
+ --with-gui=xlib$(usex fbcon ",fb" "")
+ --with-type-engines=xcore$(usex xft ",xft" "")$(usex cairo ",cairo" "")
+ --enable-optimize-redrawing
+ --enable-vt52
+ --disable-static
+ )
+
+ local scrollbars="sample,extra"
+ local tools="mlclient,mlcc,mlfc,mlmenu,${PN}-zoom"
+ if use gtk; then
+ myconf+=(
+ $(use_with gtk gtk $(usex gtk2 2.0 3.0))
+ --with-imagelib=gdk-pixbuf
+ )
+ scrollbars+=",pixmap_engine"
+ tools+=",mlconfig,mlimgloader"
+ fi
+ if use regis; then
+ tools+=",registobmp"
+ fi
+ myconf+=( --with-scrollbars="${scrollbars}" )
+ myconf+=( --with-tools="${tools}" )
+
+ addpredict /dev/ptmx
+ econf "${myconf[@]}"
+}
+
+src_test() {
+ :
+}
+
+src_install () {
+ default
+ prune_libtool_files
+
+ docinto contrib/icon
+ dodoc contrib/icon/README
+
+ doicon contrib/icon/${PN}*
+ make_desktop_entry ${PN} ${PN} ${PN}-icon "System;TerminalEmulator"
+}