summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2018-05-30 20:04:46 -0400
committerAaron Bauman <bman@gentoo.org>2018-05-31 08:57:04 -0400
commitf24ab2d290da6f8a530e2b3aff17c14b714517bc (patch)
tree0ae3f23d8367cc6d6f858d3fde6f444009aa8231 /x11-terms
parentx11-plugins/wmmp: bump EAPI. (diff)
downloadgentoo-f24ab2d290da6f8a530e2b3aff17c14b714517bc.tar.gz
gentoo-f24ab2d290da6f8a530e2b3aff17c14b714517bc.tar.bz2
gentoo-f24ab2d290da6f8a530e2b3aff17c14b714517bc.zip
x11-terms/xvt: bump EAPI and drop flag-o-matic eclass
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/xvt/files/xvt-int-main.patch4
-rw-r--r--x11-terms/xvt/files/xvt-makefile.patch4
-rw-r--r--x11-terms/xvt/files/xvt-ttyinit-svr4pty.diff4
-rw-r--r--x11-terms/xvt/xvt-2.1-r3.ebuild23
4 files changed, 19 insertions, 16 deletions
diff --git a/x11-terms/xvt/files/xvt-int-main.patch b/x11-terms/xvt/files/xvt-int-main.patch
index 81baa76ce5e0..a0874e45f419 100644
--- a/x11-terms/xvt/files/xvt-int-main.patch
+++ b/x11-terms/xvt/files/xvt-int-main.patch
@@ -1,5 +1,5 @@
---- xvt-1.0/xvt.c.orig 2009-09-04 15:49:13.000000000 +0200
-+++ xvt-1.0/xvt.c 2009-09-04 15:49:13.000000000 +0200
+--- a/xvt.c
++++ b/xvt.c
@@ -41,9 +41,9 @@
#endif /* UKC_LOCATIONS */
diff --git a/x11-terms/xvt/files/xvt-makefile.patch b/x11-terms/xvt/files/xvt-makefile.patch
index 368fdeeb00be..b147d9d8c2b9 100644
--- a/x11-terms/xvt/files/xvt-makefile.patch
+++ b/x11-terms/xvt/files/xvt-makefile.patch
@@ -1,5 +1,5 @@
---- xvt-1.0/Makefile.orig 2009-09-04 15:45:08.000000000 +0200
-+++ xvt-1.0/Makefile 2009-09-04 15:46:00.000000000 +0200
+--- a/Makefile
++++ b/Makefile
@@ -27,7 +27,7 @@
#ARCH=AIX3
#ARCH=ULTRIX
diff --git a/x11-terms/xvt/files/xvt-ttyinit-svr4pty.diff b/x11-terms/xvt/files/xvt-ttyinit-svr4pty.diff
index a858250c1d8a..1cc370b94d7a 100644
--- a/x11-terms/xvt/files/xvt-ttyinit-svr4pty.diff
+++ b/x11-terms/xvt/files/xvt-ttyinit-svr4pty.diff
@@ -1,5 +1,5 @@
---- ttyinit.c 2004-08-24 18:51:18.510722064 +0100
-+++ ttyinit.c.new 2004-08-24 18:50:30.539014872 +0100
+--- a/ttyinit.c
++++ b/ttyinit.c
@@ -46,6 +46,7 @@
#include <pwd.h>
#include <errno.h>
diff --git a/x11-terms/xvt/xvt-2.1-r3.ebuild b/x11-terms/xvt/xvt-2.1-r3.ebuild
index 51aaecb83268..1c3076cf2257 100644
--- a/x11-terms/xvt/xvt-2.1-r3.ebuild
+++ b/x11-terms/xvt/xvt-2.1-r3.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="2"
+EAPI=6
-inherit eutils flag-o-matic toolchain-funcs
+inherit toolchain-funcs
DESCRIPTION="A tiny vt100 terminal emulator for X"
HOMEPAGE="ftp://ftp.x.org/R5contrib/xvt-1.0.README"
@@ -21,27 +21,30 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${PN}-1.0
-src_prepare() {
+PATCHES=(
# this brings the distribution upto version 2.1
- epatch "${WORKDIR}"/${P}.diff
+ "${WORKDIR}"/${P}.diff
# fix #61393
- epatch "${FILESDIR}/${PN}-ttyinit-svr4pty.diff"
+ "${FILESDIR}/${PN}-ttyinit-svr4pty.diff"
# CFLAGS, CC #241554
- epatch "${FILESDIR}/${PN}-makefile.patch"
+ "${FILESDIR}/${PN}-makefile.patch"
# int main, not void main
- epatch "${FILESDIR}/${PN}-int-main.patch"
+ "${FILESDIR}/${PN}-int-main.patch"
# fix segfault (bug #363883)
- epatch "${FILESDIR}/${PN}-pts.patch"
+ "${FILESDIR}/${PN}-pts.patch"
+)
+src_prepare() {
+ default
tc-export CC
}
src_install() {
- dobin xvt || die "dobin failed"
+ dobin xvt
doman xvt.1
- dodoc README
+ einstalldocs
}