summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2021-02-03 10:21:33 +0100
committerLars Wendler <polynomial-c@gentoo.org>2021-02-03 10:22:47 +0100
commitfe40aa32123d0e866ada06f54b6929bee991815f (patch)
tree194e5c0bb70cadcb6e64846681aa38ceb687f1f2 /x11-terms
parentmedia-sound/qjackctl: disable git calls in 0.9.0 (diff)
downloadgentoo-fe40aa32123d0e866ada06f54b6929bee991815f.tar.gz
gentoo-fe40aa32123d0e866ada06f54b6929bee991815f.tar.bz2
gentoo-fe40aa32123d0e866ada06f54b6929bee991815f.zip
x11-terms/xterm: Bump to version 364
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/xterm/Manifest1
-rw-r--r--x11-terms/xterm/xterm-364.ebuild99
2 files changed, 100 insertions, 0 deletions
diff --git a/x11-terms/xterm/Manifest b/x11-terms/xterm/Manifest
index d1eea6c171d7..7650186b4dcd 100644
--- a/x11-terms/xterm/Manifest
+++ b/x11-terms/xterm/Manifest
@@ -4,3 +4,4 @@ DIST xterm-360.tgz 1431491 BLAKE2B 2afa7f9cb93136ad0bfb29e0862642221b4b1f583caa5
DIST xterm-361.tgz 1435017 BLAKE2B 8e413f3d9b8f3aa11fd71ed5692da9b274109bef5e0303470cf3eb81a333a12eb1437a01c023cff2dd0eb14aa19a849f6b00fa0a155c068421c7d070b1c64e35 SHA512 99e2a018729840c3ec8fe81d3cb305af249b641ceb40c2020f3cd4af3be7d88b6174a39fe8aa614d4ba1734af5f858762ffd68c9ee118ec3ef9030469583e852
DIST xterm-362.tgz 1436334 BLAKE2B c87b01806cba53700888cd9e9e84fa4d4c822044bc709fdf66ed32f6a2d7866f6bc0e090a778ccb3bee025825ca4d87c4e95b4c6fc8870ba0ec34faefba71418 SHA512 fddfa689fe948245964b347f27c8c66b28eee82cb78062f0e296053a5db9a20f74786b34058512b109064628992db94e87bc12c79f2db4a50acb79e408173168
DIST xterm-363.tgz 1442520 BLAKE2B f63efde533f9d495c3d6b744544e592608d2731f04af58a9d799f8ca7d705c81c507d9012fc4a1bd04b3e4c0a76fc00557d1a61cd9954f5fb2bf7b5ec624764f SHA512 e9148f144e5e38597c84ccd82033f4fb83a9dd222c4cecf7498e31065e7d0148c89631290e5f804fcd9d2d55f59f4fd271aaf220eb636fbe38ae245ea6537871
+DIST xterm-364.tgz 1444282 BLAKE2B 70ae7920bf993cc9973e254cf83e213ec09bee3a616a420ecf7b50874ceea59dfd7bc570e7705ac83f456bfc8668c2b03362a5c3b20009f7877f43de9984200b SHA512 c9363a4f64622729a8c954833956bf4019eb69dfc6e7b448be7f0dbf4ac5a56788a32d14f952e2c5021efd9c02e5390dadfbd9a11332a7a1c11c1e43972cd28d
diff --git a/x11-terms/xterm/xterm-364.ebuild b/x11-terms/xterm/xterm-364.ebuild
new file mode 100644
index 000000000000..0102172747d3
--- /dev/null
+++ b/x11-terms/xterm/xterm-364.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop flag-o-matic
+
+DESCRIPTION="Terminal Emulator for X Windows"
+HOMEPAGE="https://invisible-island.net/xterm/"
+SRC_URI="ftp://ftp.invisible-island.net/${PN}/${P}.tgz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="+openpty sixel toolbar truetype unicode Xaw3d xinerama"
+
+BDEPEND="virtual/pkgconfig
+ x11-base/xorg-proto"
+DEPEND="kernel_linux? ( sys-libs/libutempter )
+ kernel_FreeBSD? ( sys-libs/libutempter )
+ media-libs/fontconfig:1.0
+ >=sys-libs/ncurses-5.7-r7:0=
+ x11-apps/xmessage
+ x11-libs/libICE
+ x11-libs/libX11
+ x11-libs/libXaw
+ x11-libs/libXft
+ x11-libs/libxkbfile
+ x11-libs/libXmu
+ x11-libs/libXrender
+ x11-libs/libXt
+ unicode? ( x11-apps/luit )
+ Xaw3d? ( x11-libs/libXaw3d )
+ xinerama? ( x11-libs/libXinerama )"
+RDEPEND="${DEPEND}
+ media-fonts/font-misc-misc
+ x11-apps/rgb"
+
+DOCS=( README{,.i18n} ctlseqs.txt )
+
+pkg_setup() {
+ DEFAULTS_DIR="${EPREFIX}"/usr/share/X11/app-defaults
+}
+
+src_configure() {
+ # 454736
+ # Workaround for ncurses[tinfo] until upstream fixes their buildsystem using
+ # something sane like pkg-config or ncurses5-config and stops guessing libs
+ # Everything gets linked against ncurses anyways, so don't shout
+ append-libs $(pkg-config --libs ncurses)
+
+ local myeconfargs=(
+ --disable-full-tgetent
+ --disable-imake
+ --disable-setgid
+ --disable-setuid
+ --enable-256-color
+ --enable-broken-osc
+ --enable-broken-st
+ --enable-dabbrev
+ --enable-exec-xterm
+ --enable-i18n
+ --enable-load-vt-fonts
+ --enable-logging
+ --enable-screen-dumps
+ --enable-warnings
+ --enable-wide-chars
+ --libdir="${EPREFIX}"/etc
+ --with-app-defaults="${DEFAULTS_DIR}"
+ --with-utempter
+ --with-x
+ $(use_enable openpty)
+ $(use_enable sixel sixel-graphics)
+ $(use_enable toolbar)
+ $(use_enable truetype freetype)
+ $(use_enable unicode luit)
+ $(use_enable unicode mini-luit)
+ $(use_with Xaw3d)
+ $(use_with xinerama)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ docinto html
+ dodoc xterm.log.html
+ domenu *.desktop
+
+ # Fix permissions -- it grabs them from live system, and they can
+ # be suid or sgid like they were in pre-unix98 pty or pre-utempter days,
+ # respectively (#69510).
+ # (info from Thomas Dickey) - Donnie Berkholz <spyderous@gentoo.org>
+ fperms 0755 /usr/bin/xterm
+
+ # restore the navy blue
+ sed -i -e 's:blue2$:blue:' "${ED}${DEFAULTS_DIR}"/XTerm-color || die
+}