summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2020-07-13 17:08:43 -0700
committerMatt Turner <mattst88@gentoo.org>2020-07-13 17:45:12 -0700
commitf80d21b6798e721c14d7bc348c9b25361306e114 (patch)
treec955b153afa8d61643adb21168d27f4ed67ea9ff /x11-themes/adwaita-icon-theme/adwaita-icon-theme-3.36.1.ebuild
parentsys-auth/docker_auth: 1.5.0 bump (diff)
downloadgentoo-f80d21b6798e721c14d7bc348c9b25361306e114.tar.gz
gentoo-f80d21b6798e721c14d7bc348c9b25361306e114.tar.bz2
gentoo-f80d21b6798e721c14d7bc348c9b25361306e114.zip
x11-themes/adwaita-icon-theme: Version bump to 3.36.1
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-themes/adwaita-icon-theme/adwaita-icon-theme-3.36.1.ebuild')
-rw-r--r--x11-themes/adwaita-icon-theme/adwaita-icon-theme-3.36.1.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/x11-themes/adwaita-icon-theme/adwaita-icon-theme-3.36.1.ebuild b/x11-themes/adwaita-icon-theme/adwaita-icon-theme-3.36.1.ebuild
new file mode 100644
index 000000000000..e203c8b52578
--- /dev/null
+++ b/x11-themes/adwaita-icon-theme/adwaita-icon-theme-3.36.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit gnome2
+
+DESCRIPTION="GNOME default icon theme"
+HOMEPAGE="https://git.gnome.org/browse/adwaita-icon-theme/"
+
+SRC_URI="${SRC_URI}
+ branding? ( https://www.mail-archive.com/tango-artists@lists.freedesktop.org/msg00043/tango-gentoo-v1.1.tar.gz )
+"
+LICENSE="
+ || ( LGPL-3 CC-BY-SA-3.0 )
+ branding? ( CC-BY-SA-4.0 )
+"
+SLOT="0"
+IUSE="branding"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~sparc-solaris ~x64-solaris ~x86-solaris"
+
+# gtk+:3 is needed for build for the gtk-encode-symbolic-svg utility
+# librsvg is needed for gtk-encode-symbolic-svg to be able to read the source SVG via its pixbuf loader and at runtime for rendering scalable icons shipped by the theme
+RDEPEND="
+ >=x11-themes/hicolor-icon-theme-0.10
+ gnome-base/librsvg:2
+"
+DEPEND="${RDEPEND}
+ x11-libs/gtk+:3
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+# This ebuild does not install any binaries
+RESTRICT="binchecks strip"
+
+src_prepare() {
+ if use branding; then
+ for i in 16 22 24 32 48; do
+ cp "${WORKDIR}"/tango-gentoo-v1.1/${i}x${i}/gentoo.png \
+ "${S}"/Adwaita/${i}x${i}/places/start-here.png \
+ || die "Copying gentoo logos failed"
+ done
+ fi
+
+ # Install cursors in the right place used in Gentoo
+ sed -e 's:^\(cursordir.*\)icons\(.*\):\1cursors/xorg-x11\2:' \
+ -i "${S}"/Makefile.am \
+ -i "${S}"/Makefile.in || die
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure GTK_UPDATE_ICON_CACHE=$(type -P true)
+}