summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-themes/oxygen-gtk
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-themes/oxygen-gtk')
-rw-r--r--x11-themes/oxygen-gtk/Manifest2
-rw-r--r--x11-themes/oxygen-gtk/metadata.xml5
-rw-r--r--x11-themes/oxygen-gtk/oxygen-gtk-1.4.1.ebuild52
-rw-r--r--x11-themes/oxygen-gtk/oxygen-gtk-1.4.6.ebuild52
4 files changed, 111 insertions, 0 deletions
diff --git a/x11-themes/oxygen-gtk/Manifest b/x11-themes/oxygen-gtk/Manifest
new file mode 100644
index 000000000000..c101601cfa54
--- /dev/null
+++ b/x11-themes/oxygen-gtk/Manifest
@@ -0,0 +1,2 @@
+DIST oxygen-gtk2-1.4.6.tar.bz2 201105 SHA256 a289434347cc96054c75d1e4e4408b84adc2e8c7862f0be4e2da8fafbf26bf26 SHA512 89f0edba061973ef85607c6cdb8329768faea52f12147d7436530cdec59649c92472cacf1030e1ad6f610f138b11ad60f4f67847b670cf9b7409ad5b6ae25ed0 WHIRLPOOL 8d8f2ccd494a4affcd98ae22e052fa3841fe5a816f6308dc9dd9d4587693985f25b846831e776648a923e3d310bfececd6b07921c32927fb0b8269d52c8fb95e
+DIST oxygen-gtk3-1.4.1.tar.bz2 197242 SHA256 0e64227c85753a479904ecb41160cd06abf0a3da4a2cf33c11edf502bfe4a75d SHA512 22f18efe51029d078f80563956b1e67fc7d24fd165650d5050641785aedd55ac7cb065d61cb04e0b62b483e2d5c0c1dd13ffe6a4271e06be2f254375e97e8934 WHIRLPOOL 01a8f4c546cbb92ab6c2d75fd3197f534843cd2f1bd8c6c842bec647aedf3a1115634cebb918002dc80d4d7831d9bacd35b45a9f07822920be70274368945922
diff --git a/x11-themes/oxygen-gtk/metadata.xml b/x11-themes/oxygen-gtk/metadata.xml
new file mode 100644
index 000000000000..a23f444b67d6
--- /dev/null
+++ b/x11-themes/oxygen-gtk/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>kde</herd>
+</pkgmetadata>
diff --git a/x11-themes/oxygen-gtk/oxygen-gtk-1.4.1.ebuild b/x11-themes/oxygen-gtk/oxygen-gtk-1.4.1.ebuild
new file mode 100644
index 000000000000..4d4862846a27
--- /dev/null
+++ b/x11-themes/oxygen-gtk/oxygen-gtk-1.4.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MY_PN=${PN}3
+MY_P=${MY_PN}-${PV}
+
+inherit cmake-utils
+
+DESCRIPTION="Official GTK+:3 port of KDE's Oxygen widget style"
+HOMEPAGE="https://projects.kde.org/projects/playground/artwork/oxygen-gtk"
+SRC_URI="mirror://kde/stable/${MY_PN}/${PV}/src/${MY_P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+KEYWORDS="amd64 ~ppc x86"
+SLOT="3"
+IUSE="debug doc"
+
+RDEPEND="
+ !x11-themes/oxygen-gtk:0
+ dev-libs/dbus-glib
+ dev-libs/glib:2
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf
+ >=x11-libs/gtk+-3.10:3
+ x11-libs/libX11
+ x11-libs/pango
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+
+DOCS=( AUTHORS README TODO )
+
+S=${WORKDIR}/${MY_P}
+
+src_install() {
+ if use doc; then
+ { cd "${S}" && doxygen Doxyfile; } || die "Generating documentation failed"
+ HTML_DOCS=( "${S}/doc/html/" )
+ fi
+
+ cmake-utils_src_install
+
+ cat <<-EOF > 99oxygen-gtk3
+CONFIG_PROTECT="${EPREFIX}/usr/share/themes/oxygen-gtk/gtk-3.0"
+EOF
+ doenvd 99oxygen-gtk3
+}
diff --git a/x11-themes/oxygen-gtk/oxygen-gtk-1.4.6.ebuild b/x11-themes/oxygen-gtk/oxygen-gtk-1.4.6.ebuild
new file mode 100644
index 000000000000..19359ca73e18
--- /dev/null
+++ b/x11-themes/oxygen-gtk/oxygen-gtk-1.4.6.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MY_PN=${PN}2
+MY_P=${MY_PN}-${PV}
+
+inherit cmake-utils
+
+DESCRIPTION="Official GTK+:2 port of KDE's Oxygen widget style"
+HOMEPAGE="https://projects.kde.org/projects/playground/artwork/oxygen-gtk"
+SRC_URI="mirror://kde/stable/${MY_PN}/${PV}/src/${MY_P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+KEYWORDS="amd64 ~ppc x86"
+SLOT="2"
+IUSE="debug doc"
+
+RDEPEND="
+ !x11-themes/oxygen-gtk:0
+ dev-libs/dbus-glib
+ dev-libs/glib:2
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf
+ >=x11-libs/gtk+-2.24.2:2
+ x11-libs/libX11
+ x11-libs/pango
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+
+DOCS=( AUTHORS README TODO )
+
+S=${WORKDIR}/${MY_P}
+
+src_install() {
+ if use doc; then
+ { cd "${S}" && doxygen Doxyfile; } || die "Generating documentation failed"
+ HTML_DOCS=( "${S}/doc/html/" )
+ fi
+
+ cmake-utils_src_install
+
+ cat <<-EOF > 99oxygen-gtk2
+CONFIG_PROTECT="${EPREFIX}/usr/share/themes/oxygen-gtk/gtk-2.0"
+EOF
+ doenvd 99oxygen-gtk2
+}