summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-themes/verne-backgrounds
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-themes/verne-backgrounds')
-rw-r--r--x11-themes/verne-backgrounds/Manifest1
-rw-r--r--x11-themes/verne-backgrounds/metadata.xml7
-rw-r--r--x11-themes/verne-backgrounds/verne-backgrounds-15.91.0.1.ebuild46
3 files changed, 54 insertions, 0 deletions
diff --git a/x11-themes/verne-backgrounds/Manifest b/x11-themes/verne-backgrounds/Manifest
new file mode 100644
index 000000000000..ab47ab8ce344
--- /dev/null
+++ b/x11-themes/verne-backgrounds/Manifest
@@ -0,0 +1 @@
+DIST verne-backgrounds-15.91.0-1.fc16.src.rpm 7360450 SHA256 1b4be63f5eee44dbe09c6d6d84683556f3dbbd1745827964f0393ceffe539326
diff --git a/x11-themes/verne-backgrounds/metadata.xml b/x11-themes/verne-backgrounds/metadata.xml
new file mode 100644
index 000000000000..63ac5653603a
--- /dev/null
+++ b/x11-themes/verne-backgrounds/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>flameeyes@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/x11-themes/verne-backgrounds/verne-backgrounds-15.91.0.1.ebuild b/x11-themes/verne-backgrounds/verne-backgrounds-15.91.0.1.ebuild
new file mode 100644
index 000000000000..866c288aac72
--- /dev/null
+++ b/x11-themes/verne-backgrounds/verne-backgrounds-15.91.0.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+
+inherit versionator rpm
+
+SRC_PATH=development/16/source/SRPMS
+FEDORA=16
+
+MY_P="${PN}-$(get_version_component_range 1-3)"
+
+DESCRIPTION="Fedora official background artwork"
+HOMEPAGE="https://fedoraproject.org/wiki/F16_Artwork"
+
+SRC_URI="mirror://fedora-dev/${SRC_PATH}/${PN}-$(replace_version_separator 3 -).fc${FEDORA}.src.rpm"
+
+LICENSE="CC-BY-SA-3.0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="!x11-themes/fedora-backgrounds:16"
+DEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+SLOT=0
+
+src_unpack() {
+ rpm_src_unpack
+
+ # as of 2011-03-08 rpm.eclass does not unpack the further xz
+ # file automatically.
+ unpack ./${MY_P}.tar.xz
+}
+
+src_compile() { :; }
+src_test() { :; }
+
+src_install() {
+ # The install targets are serial anyway.
+ emake -j1 DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc Attribution
+}