summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAisha Tammy <gentoo@aisha.cc>2020-04-20 18:59:43 -0400
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2020-04-21 14:53:44 -0700
commite84ae9943a70dcac2434c18533327df73b471a71 (patch)
treef2c58b3783cae0c3eea9f1f85e5828583c837bcd /x11-wm/cwm
parentsys-apps/portage: Remove old versions (diff)
downloadgentoo-e84ae9943a70dcac2434c18533327df73b471a71.tar.gz
gentoo-e84ae9943a70dcac2434c18533327df73b471a71.tar.bz2
gentoo-e84ae9943a70dcac2434c18533327df73b471a71.zip
x11-wm/cwm: updated to latest 6.6 and new proxy-maintainer
Closes: https://bugs.gentoo.org/718682 Signed-off-by: Aisha Tammy <gentoo@aisha.cc> Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'x11-wm/cwm')
-rw-r--r--x11-wm/cwm/Manifest1
-rw-r--r--x11-wm/cwm/cwm-6.6.ebuild45
-rw-r--r--x11-wm/cwm/cwm-9999.ebuild36
-rw-r--r--x11-wm/cwm/files/cwm-Makefile.patch21
-rw-r--r--x11-wm/cwm/metadata.xml9
5 files changed, 93 insertions, 19 deletions
diff --git a/x11-wm/cwm/Manifest b/x11-wm/cwm/Manifest
index 57cb403b8f4f..a1b8eb1a9dfe 100644
--- a/x11-wm/cwm/Manifest
+++ b/x11-wm/cwm/Manifest
@@ -1,2 +1,3 @@
DIST cwm-5.6-chneukirchen.tar.gz 50799 BLAKE2B 4d9341e89b21187044bbcbc658dea2eac6f6c1c87f25e1b0b81871a9f8b95af7354c8b486bd77f201acba430e019a5c784591cfc5efb281fd40d6670749958ad SHA512 0bb5f9c69e1ed30ef38ced70008baa347032a0c31ee2d4a88e3b45092969a5427ef160577da4891aba3181067235b244f11fc796815f41448930b438099b5bfc
DIST cwm-5.6-xmw.tar.gz 53738 BLAKE2B 9c36c42fc35a8206035ed59fb8fe2e8eb13effcdb43d488bcc99c2d0f48476e206e46fd52c0928afdb51d55c68d9be03a186aaf4c49d03bcdf8754df0c5d81db SHA512 cf0174523838dba5997206be904ab667efc5ff7e413e98bb81cc3a69d40a79b54e21405787e088486feb8790d1094a2d3cce0be08d7ee36a2b9b0dadd78466c7
+DIST cwm-6.6.tar.gz 53062 BLAKE2B 3da762f0c1a48c83c773a1f355cc970c5e4f6100e7294a00f44c6b5b7e1ffe954fde0e3d106991b05cd1f8c898fe055b5305b0bd7bf533df5868d32adbae2c5f SHA512 ff94fd1b7d263f9de538e5b338db58a08e1bec3e4233b84ab0a3ac94c47a45e10b2c772f93b897e70baf9a3c04e1a6fa04604ac71655acb7ebd1d10edb381042
diff --git a/x11-wm/cwm/cwm-6.6.ebuild b/x11-wm/cwm/cwm-6.6.ebuild
new file mode 100644
index 000000000000..083e7d8776c3
--- /dev/null
+++ b/x11-wm/cwm/cwm-6.6.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop toolchain-funcs
+
+DESCRIPTION="OpenBSD fork of calmwm, a clean and lightweight window manager"
+HOMEPAGE="https://www.openbsd.org/cgi-bin/cvsweb/xenocara/app/cwm/
+ https://github.com/chneukirchen/cwm"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/leahneukirchen/${PN}.git"
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/leahneukirchen/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+LICENSE="ISC"
+SLOT="0"
+
+RDEPEND="x11-libs/libXft
+ x11-libs/libXinerama
+ x11-libs/libXrandr
+"
+DEPEND="${RDEPEND}"
+BDEPEND="sys-devel/bison
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-Makefile.patch"
+)
+
+src_compile() {
+ emake CFLAGS="${CFLAGS} -D_GNU_SOURCE" CC="$(tc-getCC)" PKG_CONFIG="$(tc-getPKG_CONFIG)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX=/usr install
+ dodoc README
+ make_session_desktop ${PN} ${PN}
+}
diff --git a/x11-wm/cwm/cwm-9999.ebuild b/x11-wm/cwm/cwm-9999.ebuild
index 8e881833ac13..23dab4acd436 100644
--- a/x11-wm/cwm/cwm-9999.ebuild
+++ b/x11-wm/cwm/cwm-9999.ebuild
@@ -1,37 +1,37 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit eutils toolchain-funcs git-r3
+inherit desktop toolchain-funcs
DESCRIPTION="OpenBSD fork of calmwm, a clean and lightweight window manager"
HOMEPAGE="https://www.openbsd.org/cgi-bin/cvsweb/xenocara/app/cwm/
https://github.com/chneukirchen/cwm"
-EGIT_BRANCH=linux
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/leahneukirchen/${PN}.git"
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/leahneukirchen/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
LICENSE="ISC"
SLOT="0"
-KEYWORDS=""
-IUSE="vanilla"
RDEPEND="x11-libs/libXft
x11-libs/libXinerama
- x11-libs/libXrandr"
-DEPEND="${RDEPEND}
+ x11-libs/libXrandr
+"
+DEPEND="${RDEPEND}"
+BDEPEND="sys-devel/bison
virtual/pkgconfig
- sys-devel/bison"
-
-pkg_setup() {
- if use vanilla ; then
- EGIT_REPO_URI="https://github.com/chneukirchen/cwm.git"
- else
- EGIT_REPO_URI="https://github.com/xmw/cwm.git"
- fi
-}
+"
src_compile() {
- emake CFLAGS="${CFLAGS} -D_GNU_SOURCE" CC="$(tc-getCC)"
+ emake CFLAGS="${CFLAGS} -D_GNU_SOURCE" CC="$(tc-getCC)" PKG_CONFIG="$(tc-getPKG_CONFIG)"
}
src_install() {
diff --git a/x11-wm/cwm/files/cwm-Makefile.patch b/x11-wm/cwm/files/cwm-Makefile.patch
new file mode 100644
index 000000000000..56755fe19067
--- /dev/null
+++ b/x11-wm/cwm/files/cwm-Makefile.patch
@@ -0,0 +1,21 @@
+diff --git a/Makefile b/Makefile
+index 74d0d0d..802cd33 100644
+--- a/Makefile
++++ b/Makefile
+@@ -13,12 +13,14 @@ OBJS= calmwm.o screen.o xmalloc.o client.o menu.o \
+ search.o util.o xutil.o conf.o xevents.o group.o \
+ kbfunc.o strlcpy.o strlcat.o y.tab.o \
+ strtonum.o reallocarray.o
++
++PKG_CONFIG?= pkg-config
+
+-CPPFLAGS+= `pkg-config --cflags x11 xft xrandr`
++CPPFLAGS+= `${PKG_CONFIG} --cflags x11 xft xrandr`
+
+ CFLAGS?= -Wall -O2 -g -D_GNU_SOURCE
+
+-LDFLAGS+= `pkg-config --libs x11 xft xrandr`
++LDFLAGS+= `${PKG_CONFIG} --libs x11 xft xrandr`
+
+ MANPREFIX?= ${PREFIX}/share/man
+
diff --git a/x11-wm/cwm/metadata.xml b/x11-wm/cwm/metadata.xml
index 9dddd6338e3d..7fd942a5adbf 100644
--- a/x11-wm/cwm/metadata.xml
+++ b/x11-wm/cwm/metadata.xml
@@ -1,7 +1,14 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!-- maintainer-needed -->
+ <maintainer type="person">
+ <email>gentoo@aisha.cc</email>
+ <name>Aisha Tammy</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
<upstream>
<remote-id type="github">chneukirchen/cwm</remote-id>
</upstream>