summaryrefslogtreecommitdiff
path: root/x11-wm/i3
diff options
context:
space:
mode:
authorNelo-T. Wallus <nelo@wallus.de>2017-09-13 19:35:29 +0200
committerLars Wendler <polynomial-c@gentoo.org>2017-09-13 21:22:32 +0200
commitba299d312f5965dc8ef5e7f737b5ceabc4b63bfd (patch)
tree052696fa00135e24b1cace628f5d9dee1d4bb5ec /x11-wm/i3
parentkde-apps/akregator: Fix file corruption, crashes (diff)
downloadgentoo-ba299d312f5965dc8ef5e7f737b5ceabc4b63bfd.tar.gz
gentoo-ba299d312f5965dc8ef5e7f737b5ceabc4b63bfd.tar.bz2
gentoo-ba299d312f5965dc8ef5e7f737b5ceabc4b63bfd.zip
x11-wm/i3: Bump version to 4.14
Package-Manager: Portage-2.3.8, Repoman-2.3.3 Closes: https://github.com/gentoo/gentoo/pull/5697
Diffstat (limited to 'x11-wm/i3')
-rw-r--r--x11-wm/i3/Manifest1
-rw-r--r--x11-wm/i3/i3-4.14.ebuild99
2 files changed, 100 insertions, 0 deletions
diff --git a/x11-wm/i3/Manifest b/x11-wm/i3/Manifest
index 71328505cda2..8329aa932cd9 100644
--- a/x11-wm/i3/Manifest
+++ b/x11-wm/i3/Manifest
@@ -1 +1,2 @@
DIST i3-4.13.tar.bz2 1121298 SHA256 94c13183e527a984132a3b050c8bf629626502a6e133e07b413641aec5f8cf8a SHA512 1bb1044e8d86e78d3ccb79d49f0eb26665dcd05a348058a5e57138151d74f57d77830efc3025893170fe1b8ec612f739f75247a427410f96286b09afd2c5f14c WHIRLPOOL c0e9b205837e30d214d525af6ceb8adcc4cbbba42d9aa0eab4e7639cbd8884d827c5783590eb23a6790e8d8d87fb81884afa369e48a7ae474613392dc6f9b371
+DIST i3-4.14.tar.gz 3936748 SHA256 6807a578275be936289986a77f77320e1581dad9e752f2fc7c443b6aeaa0d14c SHA512 fe3db78813987a15ed93d182968bcd5139e1d03f29d3e8effd9fce59f87bc8309407af0b2fa5f1cd83b8583e50ea0ade6b8eafc5dda6dea9161832dc9cebfdfe WHIRLPOOL 57aa268c52a4271a6170042c31b8e4cba82486ffce96981c96a305e2d7c613f2abc6e5f395c598fc93acfffdf34d45c8f131b79deedc2d2fc7cb5d1dd5ae2499
diff --git a/x11-wm/i3/i3-4.14.ebuild b/x11-wm/i3/i3-4.14.ebuild
new file mode 100644
index 000000000000..b98df36f9270
--- /dev/null
+++ b/x11-wm/i3/i3-4.14.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="An improved dynamic tiling window manager"
+HOMEPAGE="https://i3wm.org/"
+# iw3m.org tarball for 4.14 is broken, see https://github.com/i3/i3/issues/2905
+SRC_URI="https://github.com/i3/i3/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${P}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="doc debug test"
+
+CDEPEND="dev-libs/libev
+ dev-libs/libpcre
+ >=dev-libs/yajl-2.0.3
+ x11-libs/libxcb[xkb]
+ x11-libs/libxkbcommon[X]
+ x11-libs/startup-notification
+ x11-libs/xcb-util
+ x11-libs/xcb-util-cursor
+ x11-libs/xcb-util-keysyms
+ x11-libs/xcb-util-wm
+ x11-libs/xcb-util-xrm
+ >=x11-libs/cairo-1.14.4[X,xcb]
+ >=x11-libs/pango-1.30.0[X]"
+DEPEND="${CDEPEND}
+ app-text/asciidoc
+ doc? ( app-text/xmlto dev-lang/perl )
+ test? (
+ dev-perl/Module-Install
+ )
+ virtual/pkgconfig"
+RDEPEND="${CDEPEND}
+ dev-lang/perl
+ dev-perl/AnyEvent-I3
+ dev-perl/JSON-XS"
+
+# Test without debug will apply optimization levels, which results
+# in type-punned pointers - which in turn causes test failures.
+REQUIRED_USE="test? ( debug )"
+
+DOCS=(
+ "RELEASE-NOTES-${PV}"
+ docs
+)
+PATCHES=(
+ "${FILESDIR}/${PN}-musl-GLOB_TILDE.patch"
+)
+
+src_test() {
+ emake -C "${CBUILD}" check
+}
+
+src_prepare() {
+ default
+
+ cat <<- EOF > "${T}"/i3wm
+ #!/bin/sh
+ exec /usr/bin/i3
+ EOF
+
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable debug)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ emake -C "${CBUILD}"
+}
+
+src_install() {
+ emake -C "${CBUILD}" DESTDIR="${D}" install
+ doman "${CBUILD}"/man/*.1
+
+ use doc && einstalldocs
+
+ exeinto /etc/X11/Sessions
+ doexe "${T}/i3wm"
+}
+
+pkg_postinst() {
+ einfo "There are several packages that you may find useful with ${PN} and"
+ einfo "their usage is suggested by the upstream maintainers, namely:"
+ einfo " x11-misc/dmenu"
+ einfo " x11-misc/i3status"
+ einfo " x11-misc/i3lock"
+ einfo "Please refer to their description for additional info."
+}