summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-06-29 11:07:12 +0200
committerDavid Seifert <soap@gentoo.org>2022-06-29 11:07:12 +0200
commitf1a9b2784876f4e62ac2f79f00f44821921d2dcd (patch)
tree608e7974ad3ccd65b789911e08fd099d038df79b /x11-wm/matwm2/matwm2-0.1.2_pre3-r1.ebuild
parentapp-text/paperwork: fix renderD128 access violation (diff)
downloadgentoo-f1a9b2784876f4e62ac2f79f00f44821921d2dcd.tar.gz
gentoo-f1a9b2784876f4e62ac2f79f00f44821921d2dcd.tar.bz2
gentoo-f1a9b2784876f4e62ac2f79f00f44821921d2dcd.zip
x11-wm/matwm2: update EAPI 6 -> 8
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'x11-wm/matwm2/matwm2-0.1.2_pre3-r1.ebuild')
-rw-r--r--x11-wm/matwm2/matwm2-0.1.2_pre3-r1.ebuild65
1 files changed, 0 insertions, 65 deletions
diff --git a/x11-wm/matwm2/matwm2-0.1.2_pre3-r1.ebuild b/x11-wm/matwm2/matwm2-0.1.2_pre3-r1.ebuild
deleted file mode 100644
index c6e017074c9d..000000000000
--- a/x11-wm/matwm2/matwm2-0.1.2_pre3-r1.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit toolchain-funcs
-
-MY_PV="${PV//_/}"
-
-DESCRIPTION="Simple EWMH compatible window manager with titlebars and frames"
-HOMEPAGE="https://github.com/segin/matwm2"
-SRC_URI="https://github.com/segin/${PN}/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="debug xft xinerama"
-S="${WORKDIR}/${PN}-${MY_PV}/${PN}"
-
-RDEPEND="
- x11-libs/libXext
- x11-libs/libX11
- xft? ( x11-libs/libXft )
- xinerama? ( x11-libs/libXinerama )
-"
-DEPEND="
- ${RDEPEND}
- virtual/pkgconfig
-"
-
-PATCHES=( "${FILESDIR}/${P}-destdir-fix.patch" )
-
-src_prepare() {
- default
-
- # Let the package manager handle stripping
- sed -e 's/install -s/install/g' -i Makefile.in || die
-}
-
-src_configure() {
- # configure is not autotools based
- local myconfigureargs=(
- --prefix="${EPREFIX}/usr"
- --mandir="${EPREFIX}/usr/share/man"
- --cc="$(tc-getCC)"
- $(usex debug "--enable-debug" "")
- $(usex xft "" "--disable-xft")
- $(usex xinerama "" "--disable-xinerama")
- )
-
- ./configure "${myconfigureargs[@]}" || die
-}
-
-src_install() {
- default
-
- docompress -x "${EPREFIX}/usr/share/doc/${PF}"/default_matwmrc
- dodoc default_matwmrc
-
- insinto /usr/share/xsessions
- doins "${FILESDIR}"/${PN}.desktop
-
- echo ${PN} > "${T}"/${PN} || die
- exeinto /etc/X11/Sessions
- doexe "${T}"/${PN}
-}