summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2019-08-18 13:07:23 +0300
committerMart Raudsepp <leio@gentoo.org>2019-08-18 14:30:56 +0300
commitf981849f2156dd2e70f479f416c2670b4e8a9cbd (patch)
treec92c269e720be17efbc7a7c4007604b74c2f3468 /x11-wm/mutter
parentprofiles: amd64/arm/arm64/x86: Return from the future (diff)
downloadgentoo-f981849f2156dd2e70f479f416c2670b4e8a9cbd.tar.gz
gentoo-f981849f2156dd2e70f479f416c2670b4e8a9cbd.tar.bz2
gentoo-f981849f2156dd2e70f479f416c2670b4e8a9cbd.zip
x11-wm/mutter: update patchset, add pipewire support
Updated patchset adds back the problematic set of patches from 3.30.2-r2, but with more patches on top that should fix up the regressions. Pipewire is just hooked up to the relevant configure option via USE=screencast Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'x11-wm/mutter')
-rw-r--r--x11-wm/mutter/Manifest1
-rw-r--r--x11-wm/mutter/metadata.xml1
-rw-r--r--x11-wm/mutter/mutter-3.30.2-r4.ebuild149
3 files changed, 151 insertions, 0 deletions
diff --git a/x11-wm/mutter/Manifest b/x11-wm/mutter/Manifest
index 92a3a4c453e3..cf1fc2fed321 100644
--- a/x11-wm/mutter/Manifest
+++ b/x11-wm/mutter/Manifest
@@ -2,4 +2,5 @@ DIST mutter-3.26.2-patchset.tar.xz 48156 BLAKE2B 7b33495a8bb7ac69f5610e1dfcb1fef
DIST mutter-3.26.2.tar.xz 3622904 BLAKE2B b32af24c6ffcd0e6af38ab1ff7cd0ba16ea3ceb84c62ed21d9e38fff5357eda2648050beada3fc8727474407a419a2c218331c8a87f7eb68eddf824d26ca9c51 SHA512 95885b4c053d4bc467a7c11615ee3d1a3086a674ae10e7cb9bb241f692e66dd8190508db1cdf1760bc2f19100e532e68d5e147d344e94d1430d80dd26ca0156b
DIST mutter-3.30.2-r1-patchset.tar.xz 14096 BLAKE2B 83f2e975a4404b878e832a70fe7a84a2a39d291dc1f6191e5805633327d21fb0796b8b0172a35602bec9c7e879819ebdb189f324cba3f4a4aee232d5e439ba0a SHA512 f842920d6855803b8712e1736399805ecd3266a61dd7baba1f80383978d00533e34fd742103b578f9f2969ab2059f9e0c7b3812d2ea2283b6ffa91810bf6094f
DIST mutter-3.30.2-r3-patchset.tar.xz 30208 BLAKE2B 502e9c1d005cf268548e2732d4574b0eb7491940531c77c357e73e2da23b60acfbb183f9e818edd86cf0d6abca4e43c2e687db27544bb4fe7e9a33a162df01da SHA512 22b66395ffae07b208efa3a1305c71ea2282470a08300a5c3de23a2a45f03afef7804d5943934028286406adedbb9851dc562f4e57fdff77df22591893f0908b
+DIST mutter-3.30.2-r4-patchset.tar.xz 44820 BLAKE2B 2448dcd6bca338dbe2b87a93ca4374fd5b4cc5d8834dd40739e74a65280b7f00b99d61361082673f5f41e44fb40e36f0889d5ee00fbc034efe87294540fba48e SHA512 a7024b95bc56ab25cfdb27003b4b1fc39925117795c05f78b2d473fdbcf3bb6ce870ee5bc030ec4ce5e10b42d94fa0007bf5870bd2a4e94de3885c9434a39835
DIST mutter-3.30.2.tar.xz 3725692 BLAKE2B 280b7a6319e5d4705baee965936df6f31ba8ca96ce3812cf640578c6817aaa82b6ff8fde7b2740ecd8edb6c4746f4608f997772a24d67f12fcb0c5c77fc9b29a SHA512 3890270b7eb4b8753274d30ad26693b829a69b31f36501845c59b000deb174be58b5167f6754767dba02ebc44688697fbe7344a327879a073955047b69333a2e
diff --git a/x11-wm/mutter/metadata.xml b/x11-wm/mutter/metadata.xml
index bd2aac01e71a..4da93b48e48d 100644
--- a/x11-wm/mutter/metadata.xml
+++ b/x11-wm/mutter/metadata.xml
@@ -8,5 +8,6 @@
<use>
<flag name="elogind">Rely on <pkg>sys-auth/elogind</pkg> as logind provider for Wayland sessions</flag>
<flag name="gles2">Enable OpenGL ES 2.0 support</flag>
+ <flag name="screencast">Enable support for remote desktop and screen cast using <pkg>media-video/pipewire</pkg></flag>
</use>
</pkgmetadata>
diff --git a/x11-wm/mutter/mutter-3.30.2-r4.ebuild b/x11-wm/mutter/mutter-3.30.2-r4.ebuild
new file mode 100644
index 000000000000..4a195cee4a18
--- /dev/null
+++ b/x11-wm/mutter/mutter-3.30.2-r4.ebuild
@@ -0,0 +1,149 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GNOME2_EAUTORECONF="yes"
+inherit gnome2 virtualx
+
+DESCRIPTION="GNOME 3 compositing window manager based on Clutter"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/mutter/"
+SRC_URI+=" https://dev.gentoo.org/~leio/distfiles/${PF}-patchset.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0/3" # 0/libmutter_api_version - ONLY gnome-shell (or anything using mutter-clutter-<api_version>.pc) should use the subslot
+
+IUSE="debug elogind gles2 input_devices_wacom +introspection screencast systemd test udev wayland"
+# native backend requires gles3 for hybrid graphics blitting support and a logind provider
+REQUIRED_USE="
+ wayland? ( ^^ ( elogind systemd ) )"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+# libXi-1.7.4 or newer needed per:
+# https://bugzilla.gnome.org/show_bug.cgi?id=738944
+# gl.pc package is required, which is only installed by mesa if glx is enabled; pre-emptively requiring USE=X on mesa, as hopefully eventually it'll support disabling glx for wayland-only systems
+RDEPEND="
+ >=dev-libs/atk-2.5.3
+ >=x11-libs/gdk-pixbuf-2:2
+ >=dev-libs/json-glib-0.12.0
+ >=x11-libs/pango-1.30[introspection?]
+ >=x11-libs/cairo-1.14[X]
+ >=x11-libs/gtk+-3.19.8:3[X,introspection?]
+ >=dev-libs/glib-2.53.2:2
+ >=media-libs/libcanberra-0.26[gtk3]
+ >=x11-libs/startup-notification-0.7
+ >=x11-libs/libXcomposite-0.2
+ >=gnome-base/gsettings-desktop-schemas-3.21.4[introspection?]
+ gnome-base/gnome-desktop:3=
+
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ >=x11-libs/libXcomposite-0.4
+ x11-libs/libXcursor
+ x11-libs/libXdamage
+ x11-libs/libXext
+ >=x11-libs/libXfixes-3
+ >=x11-libs/libXi-1.7.4
+ x11-libs/libXinerama
+ >=x11-libs/libXrandr-1.5
+ x11-libs/libXrender
+ x11-libs/libxcb
+ x11-libs/libxkbfile
+ >=x11-libs/libxkbcommon-0.4.3[X]
+ x11-misc/xkeyboard-config
+
+ gnome-extra/zenity
+ media-libs/mesa[X(+),egl,gles2?]
+
+ input_devices_wacom? ( >=dev-libs/libwacom-0.13 )
+ introspection? ( >=dev-libs/gobject-introspection-1.42:= )
+ udev? ( >=virtual/libgudev-232:= )
+ screencast? ( >=media-video/pipewire-0.2.2:0/0.2 )
+ wayland? (
+ >=dev-libs/libinput-1.4
+ >=dev-libs/wayland-1.13.0
+ >=dev-libs/wayland-protocols-1.16
+ >=media-libs/mesa-10.3[egl,gbm,wayland,gles2]
+ systemd? ( sys-apps/systemd )
+ elogind? ( sys-auth/elogind )
+ >=virtual/libgudev-232:=
+ >=virtual/libudev-136:=
+ x11-base/xorg-server[wayland]
+ x11-libs/libdrm:=
+ )
+"
+DEPEND="${RDEPEND}
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.6
+ virtual/pkgconfig
+ x11-base/xorg-proto
+ test? ( app-text/docbook-xml-dtd:4.5 )
+ wayland? ( >=sys-kernel/linux-headers-4.4 )
+"
+
+PATCHES=(
+ # Some patches from gnome-3-30 branch on top of 3.30.2
+ "${WORKDIR}"/patches/
+ # Hack to not fail USE="-wayland,-gles2" builds with no mesa[gles2]
+ "${FILESDIR}"/3.28.3-no-gles2-fix.patch # requires eautoreconf
+)
+
+src_prepare() {
+ # Disable building of noinst_PROGRAM for tests
+ if ! use test; then
+ sed -e '/^noinst_PROGRAMS/d' \
+ -i cogl/tests/conform/Makefile.{am,in} || die
+ sed -e '/noinst_PROGRAMS += testboxes/d' \
+ -i src/Makefile-tests.am || die
+ sed -e '/noinst_PROGRAMS/ s/testboxes$(EXEEXT)//' \
+ -i src/Makefile.in || die
+ fi
+
+ gnome2_src_prepare
+
+ # Leave the damn CFLAGS alone
+ sed -e 's/$CFLAGS -g/$CFLAGS /' \
+ -i clutter/configure || die
+ sed -e 's/$CFLAGS -g -O0/$CFLAGS /' \
+ -i cogl/configure || die
+ sed -e 's/$CFLAGS -g -O/$CFLAGS /' \
+ -i configure || die
+}
+
+src_configure() {
+ # TODO: pipewire remote desktop support
+ # TODO: nvidia EGLDevice support
+ # TODO: elogind vs systemd is automagic in 3.28.3 - if elogind is found, it's used instead of systemd; but not a huge problem as elogind package blocks systemd package
+ # TODO: lack of --with-xwayland-grab-default-access-rules relies on default settings, but in Gentoo we might have some more packages we want to give Xgrab access (mostly virtual managers and remote desktops)
+ # Prefer gl driver by default
+ # GLX is forced by mutter but optional in clutter
+ # xlib-egl-platform required by mutter x11 backend
+ # native backend without wayland is useless
+ gnome2_src_configure \
+ --disable-static \
+ --enable-compile-warnings=minimum \
+ --enable-gl \
+ --enable-glx \
+ --enable-sm \
+ --enable-startup-notification \
+ --enable-verbose-mode \
+ --enable-xlib-egl-platform \
+ --with-default-driver=gl \
+ --with-libcanberra \
+ $(usex debug --enable-debug=yes "") \
+ $(use_enable gles2) \
+ $(use_enable gles2 cogl-gles2) \
+ $(use_enable introspection) \
+ $(use_enable screencast remote-desktop) \
+ $(use_enable wayland) \
+ $(use_enable wayland kms-egl-platform) \
+ $(use_enable wayland native-backend) \
+ $(use_enable wayland wayland-egl-server) \
+ $(use_with input_devices_wacom libwacom) \
+ $(use_with udev gudev)
+}
+
+src_test() {
+ virtx emake check
+}