summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2021-02-18 09:49:56 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2021-02-18 09:51:33 +0100
commitdd4e92c2de9fbf10e1620ee160695aea08ffb1c9 (patch)
tree87de18b9ab1f1589d23ca3e99dd477bbd49fd6a3 /x11-wm/windowmaker/windowmaker-0.95.9-r1.ebuild
parentdev-libs/weston: Stabilize 9.0.0 arm, #757378 (diff)
downloadgentoo-dd4e92c2de9fbf10e1620ee160695aea08ffb1c9.tar.gz
gentoo-dd4e92c2de9fbf10e1620ee160695aea08ffb1c9.tar.bz2
gentoo-dd4e92c2de9fbf10e1620ee160695aea08ffb1c9.zip
x11-wm/windowmaker: drop old
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'x11-wm/windowmaker/windowmaker-0.95.9-r1.ebuild')
-rw-r--r--x11-wm/windowmaker/windowmaker-0.95.9-r1.ebuild108
1 files changed, 0 insertions, 108 deletions
diff --git a/x11-wm/windowmaker/windowmaker-0.95.9-r1.ebuild b/x11-wm/windowmaker/windowmaker-0.95.9-r1.ebuild
deleted file mode 100644
index f7096cff3be4..000000000000
--- a/x11-wm/windowmaker/windowmaker-0.95.9-r1.ebuild
+++ /dev/null
@@ -1,108 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-inherit autotools desktop eutils
-
-DESCRIPTION="The fast and light GNUstep window manager"
-HOMEPAGE="https://www.windowmaker.org/"
-SRC_URI="https://windowmaker.org/pub/source/release/${P/windowm/WindowM}.tar.gz
- https://www.windowmaker.org/pub/source/release/WindowMaker-extra-0.1.tar.gz"
-
-SLOT="0"
-LICENSE="GPL-2"
-IUSE="gif imagemagick jpeg modelock nls png tiff webp xinerama +xpm xrandr"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
-
-DEPEND="media-libs/fontconfig
- >=x11-libs/libXft-2.1.0
- x11-libs/libXmu
- x11-libs/libXpm
- x11-libs/libXt
- x11-libs/libXv
- gif? ( >=media-libs/giflib-4.1.0-r3 )
- imagemagick? ( >=media-gfx/imagemagick-7:0= )
- jpeg? ( virtual/jpeg:0= )
- png? ( media-libs/libpng:0= )
- tiff? ( media-libs/tiff:0 )
- webp? ( media-libs/libwebp )
- xinerama? ( x11-libs/libXinerama )
- xrandr? ( x11-libs/libXrandr )"
-RDEPEND="${DEPEND}
- nls? ( >=sys-devel/gettext-0.10.39 )"
-
-S=${WORKDIR}/${P/windowm/WindowM}
-
-DOCS=( AUTHORS BUGFORM BUGS ChangeLog INSTALL INSTALL-WMAKER FAQ
- NEWS README README.definable-cursor README.i18n TODO )
-PATCHES=( "${FILESDIR}"/${PN}-0.95.8-configure_default_search_paths.patch )
-
-src_prepare() {
- # Fix some paths
- for file in WindowMaker/*menu* util/wmgenmenu.c; do
- if [[ -r $file ]] ; then
- sed -i -e "s|/usr/local/GNUstep/Applications/WPrefs.app|${EPREFIX}/usr/bin/|g;" "$file" || die
- sed -i -e "s|/usr/local/share/WindowMaker|${EPREFIX}/usr/share/WindowMaker|g;" "$file" || die
- sed -i -e "s|/opt/share/WindowMaker|${EPREFIX}/usr/share/WindowMaker|g;" "$file" || die
- fi;
- done;
-
- default
- eautoreconf
-}
-
-src_configure() {
- local myconf
-
- # image format types
- myconf="$(use_enable imagemagick magick) $(use_enable jpeg) $(use_enable gif) $(use_enable png) $(use_enable tiff) $(use_enable webp) $(use_enable xpm)"
-
- # non required X capabilities
- myconf="${myconf} $(use_enable modelock) $(use_enable xrandr randr) $(use_enable xinerama)"
-
- if use nls; then
- [[ -z $LINGUAS ]] && export LINGUAS="$(ls po/*.po | sed 's:po/\(.*\)\.po$:\1:' | xargs)"
- else
- myconf="${myconf} --disable-locale"
- fi
-
- # default settings with $myconf appended
- econf \
- --sysconfdir="${EPREFIX}"/etc/X11 \
- --with-x \
- --enable-usermenu \
- --with-pixmapdir="${EPREFIX}"/usr/share/pixmaps \
- --localedir="${EPREFIX}"/usr/share/locale \
- ${myconf}
-
- pushd ../WindowMaker-extra-0.1 || die
- econf
-}
-
-src_compile() {
- emake
-
- # WindowMaker Extra Package (themes and icons)
- pushd ../WindowMaker-extra-0.1 || die
- emake
-}
-
-src_install() {
- default
-
- # WindowMaker Extra
- pushd ../WindowMaker-extra-0.1 || die
- emake DESTDIR="${D}" install
-
- newdoc README README.extra
-
- # create wmaker session shell script
- echo "#!/usr/bin/env bash" > wmaker
- echo "${EPREFIX}/usr/bin/wmaker" >> wmaker
- exeinto /etc/X11/Sessions/
- doexe wmaker
-
- insinto /usr/share/xsessions
- doins "${FILESDIR}"/wmaker.desktop
- make_desktop_entry /usr/bin/wmaker
-}