summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-07-24 01:52:21 +0100
committerSam James <sam@gentoo.org>2022-07-24 01:59:33 +0100
commited17538a769ec1f20c0907bd77f186f1eb47abb3 (patch)
tree0ed8c3dba28c5845e8e857c8466e32371327e2b3 /x11-wm/xmonad-contrib
parentx11-wm/xmonad: add 0.17.0 (sync w/ ::haskell) (diff)
downloadgentoo-ed17538a769ec1f20c0907bd77f186f1eb47abb3.tar.gz
gentoo-ed17538a769ec1f20c0907bd77f186f1eb47abb3.tar.bz2
gentoo-ed17538a769ec1f20c0907bd77f186f1eb47abb3.zip
x11-wm/xmonad-contrib: add 0.17.0
Closes: https://bugs.gentoo.org/821148 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-wm/xmonad-contrib')
-rw-r--r--x11-wm/xmonad-contrib/Manifest1
-rw-r--r--x11-wm/xmonad-contrib/metadata.xml19
-rw-r--r--x11-wm/xmonad-contrib/xmonad-contrib-0.17.0.ebuild39
3 files changed, 44 insertions, 15 deletions
diff --git a/x11-wm/xmonad-contrib/Manifest b/x11-wm/xmonad-contrib/Manifest
index 4020cb455c4a..bcd158efb5c4 100644
--- a/x11-wm/xmonad-contrib/Manifest
+++ b/x11-wm/xmonad-contrib/Manifest
@@ -1 +1,2 @@
DIST xmonad-contrib-0.16.tar.gz 540237 BLAKE2B 7ddf8730481c39e9b5e40a548f3cbe36f301901656c57cc5ffdd11e05ad516019dc0b82c7dcf77665c152c390f7b7ae49c04ec6ae39347565b11a23aef23cce3 SHA512 22a18b4045cbfca0229cbf6c0bf1dfa595cbffbe6b82fd58b1fcf941cbfd306642160995b55859cead3cf574df696d2a3cea6507cac4d5c7c58cf09b3a86bc25
+DIST xmonad-contrib-0.17.0.tar.gz 615173 BLAKE2B d2e2724a3103502cafeddfdafe5b19cd3f2eb66fe26d49afe4b64c0c78bb3b18432e44fc8233aac951b20969013fa580f0af36d4da627f3c03145b647bff5a44 SHA512 357ef80565690a1e652f79c877964181134c7f02a5d325dbf3890246588ce8a545e91126041bcc2af3d9ebf5b3be28f4866ee9ede76ddbf0fc0387871319a900
diff --git a/x11-wm/xmonad-contrib/metadata.xml b/x11-wm/xmonad-contrib/metadata.xml
index ab6877a60b10..bb4b8043b4ab 100644
--- a/x11-wm/xmonad-contrib/metadata.xml
+++ b/x11-wm/xmonad-contrib/metadata.xml
@@ -3,20 +3,9 @@
<pkgmetadata>
<maintainer type="project">
<email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
</maintainer>
- <longdescription>
- Third party tiling algorithms, configurations and scripts to xmonad,
- a tiling window manager for X.
-
- For an introduction to building, configuring and using xmonad
- extensions, see "XMonad.Doc". In particular:
-
- "XMonad.Doc.Configuring", a guide to configuring xmonad
-
- "XMonad.Doc.Extending", using the contributed extensions library
-
- "XMonad.Doc.Developing", introduction to xmonad internals and writing
- your own extensions.
-
- </longdescription>
+ <use>
+ <flag name="xft">Use Xft to render text</flag>
+ </use>
</pkgmetadata>
diff --git a/x11-wm/xmonad-contrib/xmonad-contrib-0.17.0.ebuild b/x11-wm/xmonad-contrib/xmonad-contrib-0.17.0.ebuild
new file mode 100644
index 000000000000..f24bc78559a4
--- /dev/null
+++ b/x11-wm/xmonad-contrib/xmonad-contrib-0.17.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.7.9999
+#hackport: flags: -pedantic,use_xft:xft
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Community-maintained extensions extensions for xmonad"
+HOMEPAGE="https://xmonad.org/"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+xft"
+
+RDEPEND=">=dev-haskell/mtl-1:=[profile?] <dev-haskell/mtl-3:=[profile?]
+ dev-haskell/random:=[profile?]
+ dev-haskell/utf8-string:=[profile?]
+ >=dev-haskell/x11-1.10:=[profile?] <dev-haskell/x11-1.11:=[profile?]
+ >=dev-lang/ghc-8.4.3:=
+ >=x11-wm/xmonad-0.16.99999:=[profile?] <x11-wm/xmonad-0.18:=[profile?]
+ xft? ( >=dev-haskell/x11-xft-0.2:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1
+ test? ( >=dev-haskell/hspec-2.4.0 <dev-haskell/hspec-3
+ >=dev-haskell/quickcheck-2 )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-pedantic \
+ $(cabal_flag xft use_xft)
+}