summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2020-11-24 08:53:22 +0200
committerLars Wendler <polynomial-c@gentoo.org>2020-11-24 10:36:57 +0100
commitffcb27343cfc875fe62bb77a6f148cf33e4df946 (patch)
treef9d958587c36fd51f66464bb18541180514dafa1 /x11-wm
parentprofiles/arch/riscv: mask motif USE flag (diff)
downloadgentoo-ffcb27343cfc875fe62bb77a6f148cf33e4df946.tar.gz
gentoo-ffcb27343cfc875fe62bb77a6f148cf33e4df946.tar.bz2
gentoo-ffcb27343cfc875fe62bb77a6f148cf33e4df946.zip
x11-wm/i3: use optfeature, fix docdir path on 4.19-r1
Signed-off-by: Joonas Niilola <juippis@gentoo.org> Acked-by: Nelo-T. Wallus <nelo@wallus.de> Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/i3/files/i3-gaps-4.19-fix-docdir.patch22
-rw-r--r--x11-wm/i3/i3-4.19-r1.ebuild25
2 files changed, 34 insertions, 13 deletions
diff --git a/x11-wm/i3/files/i3-gaps-4.19-fix-docdir.patch b/x11-wm/i3/files/i3-gaps-4.19-fix-docdir.patch
new file mode 100644
index 000000000000..6917aa091dff
--- /dev/null
+++ b/x11-wm/i3/files/i3-gaps-4.19-fix-docdir.patch
@@ -0,0 +1,22 @@
+diff --git a/meson.build b/meson.build
+index 11541e21..a6f8974e 100644
+--- a/meson.build
++++ b/meson.build
+@@ -642,7 +642,7 @@ if get_option('docs')
+ '@OUTPUT@',
+ ],
+ install: true,
+- install_dir: join_paths(get_option('datadir'), 'doc', 'i3'),
++ install_dir: docdir,
+ )
+
+ custom_target(
+@@ -655,7 +655,7 @@ if get_option('docs')
+ '@OUTPUT@',
+ ],
+ install: true,
+- install_dir: join_paths(get_option('datadir'), 'doc', 'i3'),
++ install_dir: docdir,
+ )
+ endif
+
diff --git a/x11-wm/i3/i3-4.19-r1.ebuild b/x11-wm/i3/i3-4.19-r1.ebuild
index 3c6f131dc56b..3ef5738daddf 100644
--- a/x11-wm/i3/i3-4.19-r1.ebuild
+++ b/x11-wm/i3/i3-4.19-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit meson virtualx
+inherit meson optfeature virtualx
if [[ "${PV}" = *9999 ]]; then
inherit git-r3
fi
@@ -22,7 +22,7 @@ LICENSE="BSD"
SLOT="0"
IUSE="doc test"
-CDEPEND="dev-libs/libev
+COMMON_DEPEND="dev-libs/libev
dev-libs/libpcre
dev-libs/yajl
x11-libs/libxcb[xkb]
@@ -36,7 +36,7 @@ CDEPEND="dev-libs/libev
x11-misc/xkeyboard-config
x11-libs/cairo[X,xcb(+)]
x11-libs/pango[X]"
-DEPEND="${CDEPEND}
+DEPEND="${COMMON_DEPEND}
test? (
dev-perl/AnyEvent
dev-perl/X11-XCB
@@ -54,7 +54,7 @@ DEPEND="${CDEPEND}
app-text/xmlto
dev-lang/perl
)"
-RDEPEND="${CDEPEND}
+RDEPEND="${COMMON_DEPEND}
dev-lang/perl
dev-perl/AnyEvent-I3
dev-perl/JSON-XS"
@@ -62,6 +62,7 @@ BDEPEND="virtual/pkgconfig"
PATCHES=(
"${FILESDIR}/${PN}-4.16-musl-GLOB_TILDE.patch"
+ "${FILESDIR}/i3-gaps-4.19-fix-docdir.patch"
)
src_prepare() {
@@ -75,6 +76,7 @@ src_prepare() {
src_configure() {
local emesonargs=(
+ -Ddocdir="/usr/share/doc/${PF}"
$(meson_use doc docs)
$(meson_use doc mans)
)
@@ -94,13 +96,10 @@ src_test() {
}
pkg_postinst() {
- # Only show the elog information on a new install
- if [[ ! ${REPLACING_VERSIONS} ]]; then
- elog "There are several packages that you may find useful with ${PN} and"
- elog "their usage is suggested by the upstream maintainers, namely:"
- elog " x11-misc/dmenu"
- elog " x11-misc/i3status"
- elog " x11-misc/i3lock"
- elog "Please refer to their description for additional info."
- fi
+ elog "There are several packages that you may find useful with i3 and"
+ elog "their usage is suggested by the upstream maintainers."
+ elog "Uninstalled optional dependencies:"
+ optfeature "Application launcher" x11-misc/dmenu
+ optfeature "Simple screen locker" x11-misc/i3lock
+ optfeature "Status bar generator" x11-misc/i3status
}