summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2018-02-16 15:08:02 +0800
committerJason Zaman <perfinion@gentoo.org>2018-02-16 15:08:25 +0800
commitb791c727dda501026f2ec661785d41c56042e9dd (patch)
tree6e525be8573f5260002ea399aef9c8e3fb5ab19b /xfce-base/thunar
parentxfce-base/thunar: 1.6.14 bump, stable branch (diff)
downloadgentoo-b791c727dda501026f2ec661785d41c56042e9dd.tar.gz
gentoo-b791c727dda501026f2ec661785d41c56042e9dd.tar.bz2
gentoo-b791c727dda501026f2ec661785d41c56042e9dd.zip
xfce-base/thunar: 1.7.1 bump, dev branch
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'xfce-base/thunar')
-rw-r--r--xfce-base/thunar/Manifest1
-rw-r--r--xfce-base/thunar/thunar-1.7.1.ebuild80
2 files changed, 81 insertions, 0 deletions
diff --git a/xfce-base/thunar/Manifest b/xfce-base/thunar/Manifest
index 130b5483183c..91552a5cf998 100644
--- a/xfce-base/thunar/Manifest
+++ b/xfce-base/thunar/Manifest
@@ -3,3 +3,4 @@ DIST Thunar-1.6.12.tar.bz2 1929112 BLAKE2B 51e347340bdd322bcbd46a10b5b59c8249ac3
DIST Thunar-1.6.13.tar.bz2 1937341 BLAKE2B fc47188876e694f724e3f10a0c1e621b5cae4112c9cf4951e670cb56d30ab532b04e77a29fca79096b58aac260ae8a065a6b0caf72c8b4750944dea593be9f2f SHA512 d1ae8efd0652c21b14ff45be9eef2ccf6b4400c744b08b2096a47b1af4eade2df1a237d03ede3e5dccea018b626dd67ffda2ed946b31fc2d3ff214c79e30168f
DIST Thunar-1.6.14.tar.bz2 1964822 BLAKE2B f080f3d0634b4b4a8e11cdb902d5f300b1829979a98b573bdb6fd11b273cdc5e37f8e8c03556561b9f8730a70c7f7c34cbfbda76fe90f86cf2c443c3f426aabe SHA512 63287e35e71a6d1cb75a4d4db4d05f0fdf34d43b0ce7a2094e6aa9042d16f3eb60f7c5d755810bb0807112177e37954ba566b4f0ef701766205ed9e5561bd6e1
DIST Thunar-1.7.0.tar.bz2 2235806 BLAKE2B dfe81012dd0c8e760497f5c919bc2e7d4dd5e3fe78969776022f769b6332d15c9bbfadee8eef8eb5cb60d8e482ada9b7d9c2673db4252d6ae2adc4788e0d257e SHA512 28f88108a2e6c415f81363330eae6046e858988b06cf6fc4408043dc6225e229aafcc1ccd5245568fb8910594a42bc7917a259eebe3ba597f453c6635c8ce639
+DIST Thunar-1.7.1.tar.bz2 2264496 BLAKE2B 84fc0ae18ec4d4bd414bbce30b6ba7f1f0c90de6202d8b830335fb49561c85428ee13753bdc1cb810713e628b977aacf78c93d7bd88c9ac90e3a78f8d74f5737 SHA512 200d2f7a30529fa9a93340a24d019a883193952157f3b37e67d4618ccff95823dfa06f6b04845d185fcb5ead780ea5c69ba9b846c82ea22bc433321b2b160ffb
diff --git a/xfce-base/thunar/thunar-1.7.1.ebuild b/xfce-base/thunar/thunar-1.7.1.ebuild
new file mode 100644
index 000000000000..fb1e05deebaf
--- /dev/null
+++ b/xfce-base/thunar/thunar-1.7.1.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome2-utils virtualx xdg-utils
+
+MY_P=${P^}
+
+DESCRIPTION="File manager for the Xfce desktop environment"
+HOMEPAGE="https://www.xfce.org/projects/ https://docs.xfce.org/xfce/thunar/start"
+SRC_URI="mirror://xfce/src/xfce/${PN}/${PV%.*}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="exif introspection libnotify pcre test +trash-panel-plugin udisks"
+
+GVFS_DEPEND=">=gnome-base/gvfs-1.18.3"
+COMMON_DEPEND=">=dev-lang/perl-5.6
+ >=dev-libs/glib-2.30:=
+ >=x11-libs/gdk-pixbuf-2.14:=
+ >=x11-libs/gtk+-3.22:3=
+ >=xfce-base/exo-0.11:=
+ >=xfce-base/libxfce4ui-4.12:=
+ >=xfce-base/libxfce4util-4.12:=
+ >=xfce-base/xfconf-4.12:=
+ exif? ( >=media-libs/libexif-0.6.19:= )
+ introspection? ( dev-libs/gobject-introspection:= )
+ libnotify? ( >=x11-libs/libnotify-0.7:= )
+ pcre? ( >=dev-libs/libpcre-6:= )
+ trash-panel-plugin? ( >=xfce-base/xfce4-panel-4.10:= )
+ udisks? ( virtual/libgudev:= )"
+RDEPEND="${COMMON_DEPEND}
+ >=dev-util/desktop-file-utils-0.20-r1
+ x11-misc/shared-mime-info
+ trash-panel-plugin? ( ${GVFS_DEPEND} )
+ udisks? (
+ virtual/udev
+ ${GVFS_DEPEND}[udisks,udev]
+ )"
+DEPEND="${COMMON_DEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+DOCS=( AUTHORS ChangeLog FAQ HACKING NEWS README THANKS TODO )
+
+src_configure() {
+ local myconf=(
+ $(use_enable introspection)
+ $(use_enable udisks gudev)
+ $(use_enable libnotify notifications)
+ $(use_enable exif)
+ $(use_enable pcre)
+ $(use_enable trash-panel-plugin tpa-plugin)
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_test() {
+ virtx emake check
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ gnome2_icon_cache_update
+}